aboutsummaryrefslogtreecommitdiff
path: root/math/drgeo/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-11-28 04:53:20 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-11-28 04:53:20 +0000
commit939345df339eeb1caaac31e0f5c5c1e2c884cd29 (patch)
tree5e31694066567f6d125d3acbf646b6b48d3a3719 /math/drgeo/Makefile
parent772dd8c9f89dcb6926c8d4df000d5ea3afb63c1c (diff)
downloadports-939345df339eeb1caaac31e0f5c5c1e2c884cd29.tar.gz
ports-939345df339eeb1caaac31e0f5c5c1e2c884cd29.zip
- Support staging
- Use new LIB_DEPENDS syntax - Fix build on 10.x
Notes
Notes: svn path=/head/; revision=335076
Diffstat (limited to 'math/drgeo/Makefile')
-rw-r--r--math/drgeo/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/math/drgeo/Makefile b/math/drgeo/Makefile
index 02d9f0e4f97b..e96508b5e93a 100644
--- a/math/drgeo/Makefile
+++ b/math/drgeo/Makefile
@@ -10,16 +10,17 @@ MASTER_SITES= SF/ofset/${PORTNAME}/${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= GTK interactive geometry software
-LIB_DEPENDS= guile:${PORTSDIR}/lang/guile
+LIB_DEPENDS= libguile.so:${PORTSDIR}/lang/guile
+GNU_CONFIGURE= yes
USES= gettext gmake pkgconfig
USE_GNOME= gnomehack gnomeprefix intlhack libglade2
-GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GCC= any # doesn't link otherwise
+USE_GCC= yes # segfaults when built with clang
+
+PORTDATA= *
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|#!/bin/bash|#!/bin/sh|g' \
${WRKSRC}/plugin/drgeo/progs/tm_drgeo