aboutsummaryrefslogtreecommitdiff
path: root/math/dune-alugrid/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-14 22:48:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-14 22:48:45 +0000
commit4697f2aed783a2231963e7e0b2b50752b409ae30 (patch)
tree1b78d3f0ef9f3cc729511cde74c22bcc434359b0 /math/dune-alugrid/Makefile
parentfed9f268467e6b8ed1532454b31e20014dcd68b9 (diff)
downloadports-4697f2aed783a2231963e7e0b2b50752b409ae30.tar.gz
ports-4697f2aed783a2231963e7e0b2b50752b409ae30.zip
New port: math/dune-alugrid: DUNE framework: grid implementation providing simplex or cube grids
Notes
Notes: svn path=/head/; revision=528459
Diffstat (limited to 'math/dune-alugrid/Makefile')
-rw-r--r--math/dune-alugrid/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/math/dune-alugrid/Makefile b/math/dune-alugrid/Makefile
new file mode 100644
index 000000000000..83346a86e22e
--- /dev/null
+++ b/math/dune-alugrid/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= dune-alugrid
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.6.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DUNE framework: grid implementation providing simplex or cube grids
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= vc>0:devel/vc
+LIB_DEPENDS= libdunecommon.so:math/dune-common \
+ libdunegeometry.so:math/dune-geometry \
+ libdunegrid.so:math/dune-grid \
+ libmetis.so:math/metis \
+ libmpi.so:net/openmpi
+
+USES= cmake compiler:c++17-lang fortran pkgconfig
+USE_GITLAB= yes
+USE_LDCONFIG= yes
+
+GL_ACCOUNT= core
+GL_SITE= https://gitlab.dune-project.org
+GL_ACCOUNT= extensions
+GL_COMMIT= 9cec115318adc7c3f4faa16a626f61996710c533
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ sphinx-build:textproc/py-sphinx
+
+PORTDOCS= *
+
+.include <bsd.port.mk>