aboutsummaryrefslogtreecommitdiff
path: root/math/dune-geometry/Makefile
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2021-02-19 15:14:46 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2021-02-19 15:14:46 +0000
commit34fdd4dc58e2ebd98803c88ff8e684892954817c (patch)
tree204912d10c077dd7fe9cf6351801dbe1835e7b11 /math/dune-geometry/Makefile
parent8ec37e4f4203b2cdd0b58fb5c6b251153f72abb4 (diff)
downloadports-34fdd4dc58e2ebd98803c88ff8e684892954817c.tar.gz
ports-34fdd4dc58e2ebd98803c88ff8e684892954817c.zip
Introduce devel/onetbb and mark devel/tbb as legacy
Intel oneAPI tbb 2021.1 (onetbb) has been released[1][2] and has deprecated several interfaces over tbb 2020, breaking most dependent ports. Old tbb 2020 will be kept for a certain time to allow transition but will be removed in a near future as it CONFLICTS with devel/onetbb. New ports should now use devel/onetbb instead of devel/tbb. We tried to move a maximum number of dependent ports to devel/onetbb (or disable dependency when not possible), but some of them still remain stuck to devel/tbb. Remaining ones have not been identified as major dependencies themselves and will be fixed as soon as updates are available from upstream. PR: 252648, 252688 [3], 252683 [4], 252651 [5], 252690 [3], 252693 [3], 252695 [3], 252696 [3], 252786 [3], 252649, 252868 [6], 252870 [5], 252684 [7], 252785 [7] Approved by: yuri [3], jwb [4], thierry [5], FreeBSD@Shaneware.biz [6], maintainer timeout [7] [1] https://software.intel.com/content/www/us/en/develop/articles/intel-oneapi-threading-building-blocks-release-notes.html [2] https://software.intel.com/content/www/us/en/develop/articles/tbb-revamp.html
Notes
Notes: svn path=/head/; revision=566074
Diffstat (limited to 'math/dune-geometry/Makefile')
-rw-r--r--math/dune-geometry/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/dune-geometry/Makefile b/math/dune-geometry/Makefile
index 58f0ac5689c0..4b2aece4f01a 100644
--- a/math/dune-geometry/Makefile
+++ b/math/dune-geometry/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dune-geometry
DISTVERSIONPREFIX= v
DISTVERSION= 2.7.1
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -15,7 +16,7 @@ BUILD_DEPENDS= openmpi>0:net/openmpi \
vc>0:devel/vc
LIB_DEPENDS= libdunecommon.so:math/dune-common \
libopenblas.so:math/openblas \
- libtbb.so:devel/tbb
+ libtbb.so:devel/onetbb
USES= cmake compiler:c++17-lang fortran pkgconfig python
USE_GITLAB= yes
@@ -26,6 +27,7 @@ GL_ACCOUNT= core
GL_COMMIT= 9d56be3e286bc761dd5d453332a8d793eff00cbe
CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_ARGS= -DTBB_INCLUDE_DIR=${LOCALBASE}/include -DTBB_LIBRARIES=${LOCALBASE}/lib/libtbb.so
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes