aboutsummaryrefslogtreecommitdiff
path: root/math/dune-geometry/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-14 22:04:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-14 22:04:54 +0000
commit6adf84d1d97be102542c95788b0e080ca3aec77b (patch)
treefb22674a5cd337cf5b88a337fb190c283150d19b /math/dune-geometry/Makefile
parent4980f9c4dbaa983c7f4ecc7659119a0a1f82c833 (diff)
downloadports-6adf84d1d97be102542c95788b0e080ca3aec77b.tar.gz
ports-6adf84d1d97be102542c95788b0e080ca3aec77b.zip
New port: math/dune-geometry: DUNE framework: Geometry transformations, reference elements, etc
Notes
Notes: svn path=/head/; revision=528452
Diffstat (limited to 'math/dune-geometry/Makefile')
-rw-r--r--math/dune-geometry/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/math/dune-geometry/Makefile b/math/dune-geometry/Makefile
new file mode 100644
index 000000000000..417b383a93d7
--- /dev/null
+++ b/math/dune-geometry/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= dune-geometry
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.7.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DUNE framework: Geometry transformations, reference elements, etc
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+BUILD_DEPENDS= openmpi>0:net/openmpi \
+ vc>0:devel/vc
+LIB_DEPENDS= libdunecommon.so:math/dune-common \
+ libopenblas.so:math/openblas \
+ libtbb.so:devel/tbb
+
+USES= cmake compiler:c++17-lang fortran pkgconfig python
+USE_GITLAB= yes
+USE_LDCONFIG= yes
+
+GL_ACCOUNT= core
+GL_SITE= https://gitlab.dune-project.org
+GL_ACCOUNT= core
+GL_COMMIT= bcf9e469f3c105d5f497dbf81801e8dbd09cde92
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ sphinx-build:textproc/py-sphinx
+
+PORTDOCS= *
+
+.include <bsd.port.mk>