aboutsummaryrefslogtreecommitdiff
path: root/math/elpa
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-21 19:45:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-21 19:45:35 +0000
commit418488f390af7dc2bb5c9ba91cc8c16aebdec214 (patch)
tree24564cde569be9b5f5ce8a564ec635993ed151e7 /math/elpa
parent70ea3d275664fd115f4480850009f75adc1dbf16 (diff)
downloadports-418488f390af7dc2bb5c9ba91cc8c16aebdec214.tar.gz
ports-418488f390af7dc2bb5c9ba91cc8c16aebdec214.zip
math/elpa: Fix build on 14; Disable building test code
-Werror caused -P unknown argument to become an error. Reported this error to the elpa upstream. Reported by: fallout
Diffstat (limited to 'math/elpa')
-rw-r--r--math/elpa/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/math/elpa/Makefile b/math/elpa/Makefile
index 88a74aa28052..95cecc4d3f23 100644
--- a/math/elpa/Makefile
+++ b/math/elpa/Makefile
@@ -15,10 +15,13 @@ LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING/lgpl.txt
LIB_DEPENDS= libopenblas.so:math/openblas
USES= compiler:c11 fortran gmake libtool localbase perl5 shebangfix
+USE_LDCONFIG= yes
+
SHEBANG_GLOB= *.pl
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-avx --disable-avx2 --disable-static
-USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-avx --disable-avx2 --disable-static \
+ --disable-c-tests
INSTALL_TARGET= install-strip
@@ -37,6 +40,9 @@ MPI_LIB_DEPENDS= libmpich.so:net/mpich \
PORTDOCS= *
+post-patch: # workaround for: https://github.com/marekandreas/elpa/issues/6
+ @${FIND} ${WRKSRC} -name "*.mk" | ${XARGS} ${REINPLACE_CMD} -e 's|-Werror| |'
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:NSSE}