aboutsummaryrefslogtreecommitdiff
path: root/math/eukleides
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-04 18:40:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-04 18:40:21 +0000
commit24b3787e03875740f6ad30d3a611232a138495d3 (patch)
tree3e800cf7023984f832d971e3c4ddae93cde153d7 /math/eukleides
parentd1eb5fca09a091931c00f89f00019462ab97a4d2 (diff)
downloadports-24b3787e03875740f6ad30d3a611232a138495d3.tar.gz
ports-24b3787e03875740f6ad30d3a611232a138495d3.zip
add eukleides 0.9.0
A Euclidean geometry drawing language
Notes
Notes: svn path=/head/; revision=60610
Diffstat (limited to 'math/eukleides')
-rw-r--r--math/eukleides/Makefile27
-rw-r--r--math/eukleides/distinfo1
-rw-r--r--math/eukleides/files/patch-Makefile22
-rw-r--r--math/eukleides/pkg-comment1
-rw-r--r--math/eukleides/pkg-descr5
-rw-r--r--math/eukleides/pkg-plist6
6 files changed, 62 insertions, 0 deletions
diff --git a/math/eukleides/Makefile b/math/eukleides/Makefile
new file mode 100644
index 000000000000..4e7dd0c444cb
--- /dev/null
+++ b/math/eukleides/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: eukleides
+# Date created: Jun 4, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= eukleides
+PORTVERSION= 0.9.0
+CATEGORIES= math
+MASTER_SITES= http://perso.wanadoo.fr/obrecht/download/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= pstoedit:${PORTSDIR}/graphics/pstoedit \
+ epstopdf:${PORTSDIR}/print/teTeX
+
+USE_BISON= yes
+ALL_TARGET= ${PORTNAME}
+USE_GMAKE= yes
+
+MAN1= eukleides.1
+MLINKS= eukleides.1 euk2eps.1 eukleides.1 euk2edit.1
+
+.include <bsd.port.mk>
diff --git a/math/eukleides/distinfo b/math/eukleides/distinfo
new file mode 100644
index 000000000000..4eb2aba7a2bd
--- /dev/null
+++ b/math/eukleides/distinfo
@@ -0,0 +1 @@
+MD5 (eukleides.0.9.0.tar.gz) = 7619d7bd3be453b6d7fed30b1f81bfa0
diff --git a/math/eukleides/files/patch-Makefile b/math/eukleides/files/patch-Makefile
new file mode 100644
index 000000000000..7bf3c1298744
--- /dev/null
+++ b/math/eukleides/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Wed Jun 5 01:38:47 2002
++++ Makefile Wed Jun 5 01:41:39 2002
+@@ -1,14 +1,14 @@
+ # Eukleides 0.9.0 makefile
+ # Copyright (c) Christian Obrecht 2000-2002
+
+-CC = gcc
+-CFLAGS = -c -O2
++#CC = gcc
++CFLAGS += -c
+ OBJECTS = lex.yy.o parser.tab.o main.o geometry.o drawing.o
+ LEX = flex
+ YACC = bison -d
+-BIN = /usr/local/bin/
+-MAN = /usr/man/man1/
+-INFO = /usr/info/
++BIN = ${PREFIX}/bin/
++MAN = ${PREFIX}/man/man1/
++INFO = ${PREFIX}/info/
+ PAPER = --texinfo=@afourpaper
+ DOC = eukleides.info eukleides.dvi eukleides.ps
+
diff --git a/math/eukleides/pkg-comment b/math/eukleides/pkg-comment
new file mode 100644
index 000000000000..3f47c8290a1d
--- /dev/null
+++ b/math/eukleides/pkg-comment
@@ -0,0 +1 @@
+A Euclidean geometry drawing language
diff --git a/math/eukleides/pkg-descr b/math/eukleides/pkg-descr
new file mode 100644
index 000000000000..95bb2a1d6f88
--- /dev/null
+++ b/math/eukleides/pkg-descr
@@ -0,0 +1,5 @@
+A compiler which allows to typeset geometry figures within a (La)TeX
+document. This program is also useful to convert such figures in EPS
+format or in various other vector graphic formats.
+
+WWW: http://perso.wanadoo.fr/obrecht/
diff --git a/math/eukleides/pkg-plist b/math/eukleides/pkg-plist
new file mode 100644
index 000000000000..89d0d8ec7345
--- /dev/null
+++ b/math/eukleides/pkg-plist
@@ -0,0 +1,6 @@
+bin/eukleides
+bin/euk2eps
+bin/euk2edit
+@unexec install-info --delete %D/info/eukleides.info %D/info/dir
+info/eukleides.info
+@exec install-info %D/info/eukleides.info %D/info/dir