aboutsummaryrefslogtreecommitdiff
path: root/math/exprtk/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-27 07:24:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-27 07:24:05 +0000
commit67f0979d06673754e250db7df809193ce3fe79f1 (patch)
treebcee29b9c3023698112b17fe612cff516df6c518 /math/exprtk/Makefile
parentba3ad61c647ab7ee6265f643c48354d068390ed6 (diff)
downloadports-67f0979d06673754e250db7df809193ce3fe79f1.tar.gz
ports-67f0979d06673754e250db7df809193ce3fe79f1.zip
New port: math/exprtk: C++ mathematical expression library
Notes
Notes: svn path=/head/; revision=502772
Diffstat (limited to 'math/exprtk/Makefile')
-rw-r--r--math/exprtk/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/exprtk/Makefile b/math/exprtk/Makefile
new file mode 100644
index 000000000000..bebe190d54e5
--- /dev/null
+++ b/math/exprtk/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= exprtk
+DISTVERSION= g20190519
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ mathematical expression library
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= ArashPartow
+GH_TAGNAME= 12fc5df
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/exprtk.hpp
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/exprtk.hpp ${STAGEDIR}${PREFIX}/include
+
+.include <bsd.port.mk>