aboutsummaryrefslogtreecommitdiff
path: root/math/fenics-basix/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-15 08:19:34 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-15 08:49:43 +0000
commit454ff23696c861b09a629b2024a92bd4aa5c9a76 (patch)
tree5d0c6ff29b1a4a72ca04b979dc380c96ed04080b /math/fenics-basix/Makefile
parent204528c2fe9fc3556690fa2bb9483a3e1b906897 (diff)
downloadports-454ff23696c861b09a629b2024a92bd4aa5c9a76.tar.gz
ports-454ff23696c861b09a629b2024a92bd4aa5c9a76.zip
math/fenics-basix: New port: FEniCS finite element basis evaluation library
Diffstat (limited to 'math/fenics-basix/Makefile')
-rw-r--r--math/fenics-basix/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/fenics-basix/Makefile b/math/fenics-basix/Makefile
new file mode 100644
index 000000000000..05a236fff8fa
--- /dev/null
+++ b/math/fenics-basix/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= fenics-basix
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.2
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= FEniCS finite element basis evaluation library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+BUILD_DEPENDS= xtensor>0:math/xtensor \
+ xtl-quant-stack>0:devel/xtl-quant-stack
+LIB_DEPENDS= libopenblas.so:math/openblas
+
+USES= cmake compiler:c++17-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= FEniCS
+GH_PROJECT= basix
+
+WRKSRC_SUBDIR= cpp
+
+.include <bsd.port.mk>