aboutsummaryrefslogtreecommitdiff
path: root/math/fftw3
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-24 01:53:06 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-24 01:53:06 +0000
commitf53d36fa266c4a9f2adfbb5531a5db769929b39a (patch)
treea9c910c3f18a9b4dcf8e087ad22f4d346da6d47e /math/fftw3
parent4588473be9372c73d5d2b3924c77bc4133f9cb28 (diff)
downloadports-f53d36fa266c4a9f2adfbb5531a5db769929b39a.tar.gz
ports-f53d36fa266c4a9f2adfbb5531a5db769929b39a.zip
only show i386 options to i386
PR: 69488 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=114552
Diffstat (limited to 'math/fftw3')
-rw-r--r--math/fftw3/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 2740d725dc01..2db49e43d7e1 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= ahze@ahze.net
COMMENT= Fast C routines to compute the Discrete Fourier Transform
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=15
USE_GNOME= gnomehack gnomeprefix gnometarget lthack pkgconfig
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
@@ -36,12 +36,16 @@ FFTW3F_WRKSRC= ${WRKDIR}/${DISTNAME}-3F
FFTW3F_INSTALL_TARGET=install-pkgconfigDATA install-libLTLIBRARIES install-exec
OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off \
- OPTIMIZED_ATHLON "Enable AMD K7(Athlon) optimizations" off \
- SSE "Enable SSE optimized routines" off \
SMP_THREADS "Enable FFTW SMP threads library" off
.include <bsd.port.pre.mk>
+.if ${ARCH} == "i386"
+OPTIONS+= OPTIMIZED_ATHLON "Enable AMD K7(Athlon) optimizations" off \
+ SSE "Enable SSE optimized routines" off
+
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS) && !defined(WITH_OPTIMIZED_ATHLON)
CONFIGURE_ENV+= CFLAGS="${CFLAGS:N-O:N-O*} -O2 -ffast-math -fomit-frame-pointer"
.endif