aboutsummaryrefslogtreecommitdiff
path: root/math/foma
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-29 22:44:10 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-29 22:44:10 +0000
commit5ebed607cc00d6fbe8105bf8cd8d84d15dbd18f6 (patch)
treec869a0114a90ef3f64176b2d479cb822b6afd8c3 /math/foma
parentaf65230fd3f5ad84efd7c476e73c5ad38302caae (diff)
downloadports-5ebed607cc00d6fbe8105bf8cd8d84d15dbd18f6.tar.gz
ports-5ebed607cc00d6fbe8105bf8cd8d84d15dbd18f6.zip
Add USES=readline to fix build on current.
Notes
Notes: svn path=/head/; revision=363405
Diffstat (limited to 'math/foma')
-rw-r--r--math/foma/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/foma/Makefile b/math/foma/Makefile
index 516215b2993d..4da3c91753fd 100644
--- a/math/foma/Makefile
+++ b/math/foma/Makefile
@@ -11,14 +11,14 @@ COMMENT= Toolkit for constructing finite-state automata and transducers
LICENSE= GPLv2
-USES= bison gmake
+USES= bison gmake readline
USE_LDCONFIG= yes
do-install:
- cd ${WRKSRC} && ${INSTALL_DATA} fomalib.h fomalibconf.h ${STAGEDIR}${PREFIX}/include/
- cd ${WRKSRC} && ${INSTALL_PROGRAM} foma flookup cgflookup ${STAGEDIR}${PREFIX}/bin/
+ (cd ${WRKSRC} && ${INSTALL_DATA} fomalib.h fomalibconf.h ${STAGEDIR}${PREFIX}/include/)
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} foma flookup cgflookup ${STAGEDIR}${PREFIX}/bin/)
${INSTALL_LIB} ${WRKSRC}/libfoma.a ${STAGEDIR}${PREFIX}/lib/
${INSTALL_LIB} ${WRKSRC}/libfoma.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libfoma.so.0
- cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libfoma.so.0 libfoma.so
+ (cd ${STAGEDIR}${PREFIX}/lib && ${LN} -s libfoma.so.0 libfoma.so)
.include <bsd.port.mk>