aboutsummaryrefslogtreecommitdiff
path: root/math/fparser/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-19 00:25:06 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-19 01:25:37 +0000
commit2eb1585ce461adff906fe6263cfe2aaa345bc54c (patch)
tree71f1ae910a89b5e622a5dee3a0d55f6c2641f737 /math/fparser/Makefile
parenta8720dde236b43a5e345668b0ebab74a2994d512 (diff)
downloadports-2eb1585ce461adff906fe6263cfe2aaa345bc54c.tar.gz
ports-2eb1585ce461adff906fe6263cfe2aaa345bc54c.zip
math/fparser: New port: Function parser for C++
Diffstat (limited to 'math/fparser/Makefile')
-rw-r--r--math/fparser/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/math/fparser/Makefile b/math/fparser/Makefile
new file mode 100644
index 000000000000..7b812d8ec1b1
--- /dev/null
+++ b/math/fparser/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= fparser
+DISTVERSION= 4.5.2
+CATEGORIES= math
+MASTER_SITES= http://warp.povusers.org/FunctionParser/ # another fork exists: https://github.com/thliebig/fparser
+DISTNAME= ${PORTNAME}${DISTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Function parser for C++
+
+LICENSE= LGPL3
+
+USES= autoreconf gmake libtool zip
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+NO_WRKSUBDIR= yes
+
+INSTALL_TARGET= install-strip
+
+PLIST_FILES= include/fparser/fparser.hh \
+ include/fparser/fpaux.hh \
+ include/fparser/fpconfig.hh \
+ include/fparser/fptypes.hh \
+ lib/libfparser-4.5.so \
+ lib/libfparser.so \
+ libdata/pkgconfig/fparser.pc
+
+.include <bsd.port.mk>