aboutsummaryrefslogtreecommitdiff
path: root/math/fpc-fftw/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-07 20:59:16 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-07 20:59:16 +0000
commit9bb2aedd50faee7fc2d7ca4cd4fc5f9b2ea60e31 (patch)
treed67bc1e1217e356f1f15e337b5cad293e32f034e /math/fpc-fftw/Makefile
parent8f94b105f3c2f89e4e522ce274166b5723dc6b73 (diff)
downloadports-9bb2aedd50faee7fc2d7ca4cd4fc5f9b2ea60e31.tar.gz
ports-9bb2aedd50faee7fc2d7ca4cd4fc5f9b2ea60e31.zip
- New port: math/fpc-fftw
Free Pascal interface to the FFTW3 library Approved by: garga (mentor,implicit)
Notes
Notes: svn path=/head/; revision=172531
Diffstat (limited to 'math/fpc-fftw/Makefile')
-rw-r--r--math/fpc-fftw/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/math/fpc-fftw/Makefile b/math/fpc-fftw/Makefile
new file mode 100644
index 000000000000..63f65098d090
--- /dev/null
+++ b/math/fpc-fftw/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: fpc-fftw
+# Date created: 2006-09-05
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= math lang
+PKGNAMESUFFIX= -fftw
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to the FFTW3 library
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+LIB_DEPENDS= fftw3.4:${PORTSDIR}/math/fftw3
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/extra/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+.include "${MASTERDIR}/Makefile"