aboutsummaryrefslogtreecommitdiff
path: root/math/fxt/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-01-06 19:48:08 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-01-06 19:48:08 +0000
commit9edcde37b9cf7c2baee322a8fa33657f29594ca0 (patch)
tree354e3ebb6570564bda9d9c9ee2e51257a5dfde9c /math/fxt/Makefile
parent03255e1ccfb3a9b5b367a4226de00d5daa69a6bf (diff)
downloadports-9edcde37b9cf7c2baee322a8fa33657f29594ca0.tar.gz
ports-9edcde37b9cf7c2baee322a8fa33657f29594ca0.zip
- Remove home grown plist target, it used deprecated @dirrm
and make makeplist is doing the same job just fine - Remove DOCS option, only DOCSDIR directory was installed, bump PORTREVISION - plist changed for default configuration - Use options helper for EXAMPLES option
Notes
Notes: svn path=/head/; revision=405387
Diffstat (limited to 'math/fxt/Makefile')
-rw-r--r--math/fxt/Makefile39
1 files changed, 3 insertions, 36 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index 5aa080315bcc..05fd6198cf84 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fxt
PORTVERSION= 2015.07.17
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
@@ -16,7 +17,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USES= gmake tar:tgz
MAKEFILE= makefile
-OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE= EXAMPLES
post-patch:
@${REINPLACE_CMD} -E \
@@ -26,42 +27,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|sinl|Sin|g' ${WRKSRC}/src/aux0/trigrec.h
@${REINPLACE_CMD} -e 's|sinl|sin|g' ${WRKSRC}/src/fht/hartleyshift.h
-post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/demo && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}/)
-plist:
- @truncate -s0 pkg-plist
- @${ECHO_CMD} "lib/libfxt.a" >> pkg-plist
-
-#
-# Includes
-#
- @${FIND} ${PREFIX}/include/fxt/ ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> pkg-plist
- @${FIND} ${PREFIX}/include/fxt/ -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> pkg-plist
-
-#
-# Examples
-#
- @${FIND} ${EXAMPLESDIR}/ ! -type d | \
- ${SED} 's,^${EXAMPLESDIR},%%PORTDOCS%%%%EXAMPLESDIR%%,' \
- >> pkg-plist
- @${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
- ${SED} -E -e \
- 's,^${EXAMPLESDIR}(.*),%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%\1,' \
- >> pkg-plist
-
-#
-# Docs
-#
- @${FIND} ${DOCSDIR}/ ! -type d | \
- ${SED} 's,^${DOCSDIR},%%PORTDOCS%%%%DOCSDIR%%,' >> pkg-plist
- @${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
- ${SED} -E -e \
- 's,^${DOCSDIR}(.*),%%PORTDOCS%%@dirrm %%DOCSDIR%%\1,' \
- >> pkg-plist
-
.include <bsd.port.mk>