aboutsummaryrefslogtreecommitdiff
path: root/math/gemmlowp/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-10-05 09:49:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-10-05 09:49:39 +0000
commit5bc5c9628785eb06cf4767902b656a013d9c6bf4 (patch)
tree4bfe08dafaa8b03e05f3eed7029a3dec0facac70 /math/gemmlowp/Makefile
parent69cb9f591ba22219b982015088c083ef8ca5096d (diff)
downloadports-5bc5c9628785eb06cf4767902b656a013d9c6bf4.tar.gz
ports-5bc5c9628785eb06cf4767902b656a013d9c6bf4.zip
New port: math/gemmlowp: Low-precision matrix multiplication library
Notes
Notes: svn path=/head/; revision=513824
Diffstat (limited to 'math/gemmlowp/Makefile')
-rw-r--r--math/gemmlowp/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/gemmlowp/Makefile b/math/gemmlowp/Makefile
new file mode 100644
index 000000000000..17ebac1250e1
--- /dev/null
+++ b/math/gemmlowp/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= gemmlowp
+DISTVERSION= g20190812
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Low-precision matrix multiplication library
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= google
+GH_TAGNAME= dc69acd
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-install:
+.for dir in public fixedpoint eight_bit_int_gemm internal profiling meta
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
+.endfor
+ @${FIND} ${STAGEDIR} -name "*.cc" -delete
+
+.include <bsd.port.mk>