aboutsummaryrefslogtreecommitdiff
path: root/math/geogebra
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-12-27 09:21:48 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-12-27 09:30:51 +0000
commit0e5cbd3ebd12ba9a843339d00f106671f950b79f (patch)
tree30a3801c1f8b1b7c732bae86d363f9a5b50c6aa3 /math/geogebra
parent128d3b57be1f406be9656f40152c2290494da1b9 (diff)
downloadports-0e5cbd3ebd12ba9a843339d00f106671f950b79f.tar.gz
ports-0e5cbd3ebd12ba9a843339d00f106671f950b79f.zip
math/geogebra: install mime-type information
Using this, ggb files can be opened directly from the for example the dolphin file manager. Otherwise the application used for zip-files would be used. Obtained from: https://github.com/archlinux/svntogit-community/blob/packages/geogebra/trunk/geogebra-mime.xml
Diffstat (limited to 'math/geogebra')
-rw-r--r--math/geogebra/Makefile4
-rw-r--r--math/geogebra/files/geogebra-mime.xml29
-rw-r--r--math/geogebra/pkg-plist1
3 files changed, 33 insertions, 1 deletions
diff --git a/math/geogebra/Makefile b/math/geogebra/Makefile
index 8efb53e9eee4..287620fe94c7 100644
--- a/math/geogebra/Makefile
+++ b/math/geogebra/Makefile
@@ -2,6 +2,7 @@
PORTNAME= geogebra
PORTVERSION= 5.0.625.0
+PORTREVISION= 1
CATEGORIES= math education java
MASTER_SITES= http://download.geogebra.org/installers/5.0/ \
https://static.geogebra.org/images/ \
@@ -20,7 +21,7 @@ LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
ONLY_FOR_ARCHS= amd64 i386
-USES= tar:bzip2 desktop-file-utils gnome shebangfix
+USES= tar:bzip2 desktop-file-utils gnome shebangfix shared-mime-info
USE_JAVA= yes
CONFLICTS= math/geogebra-i18n
@@ -37,6 +38,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/geogebra.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/geogebra/*.jar ${STAGEDIR}${DATADIR}/${PORTNAME}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/mime/packages
+ ${INSTALL_DATA} ${FILESDIR}/geogebra-mime.xml ${STAGEDIR}${PREFIX}/share/mime/packages
${INSTALL_DATA} ${WRKDIR}/geogebra.desktop ${STAGEDIR}${DESKTOPDIR}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/32x32/apps
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
diff --git a/math/geogebra/files/geogebra-mime.xml b/math/geogebra/files/geogebra-mime.xml
new file mode 100644
index 000000000000..6f6ae5d9b2a6
--- /dev/null
+++ b/math/geogebra/files/geogebra-mime.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/vnd.geogebra.file">
+ <comment>GeoGebra worksheet</comment>
+ <comment xml:lang="cs">Pracovní list GeoGebry</comment>
+ <comment xml:lang="de">GeoGebra-Arbeitsblatt</comment>
+ <comment xml:lang="es">Archivo GeoGebra</comment>
+ <comment xml:lang="fr">Feuille de travail GeoGebra </comment>
+ <comment xml:lang="hi">जीओ-जेब्रा कार्य-पत्र</comment>
+ <comment xml:lang="it">Foglio di lavoro GeoGebra </comment>
+ <comment xml:lang="pt-BR">Planilha GeoGebra</comment>
+ <sub-class-of type="application/zip"/>
+ <glob pattern="*.ggb"/>
+ <icon name="geogebra"/>
+ </mime-type>
+ <mime-type type="application/vnd.geogebra.tool">
+ <comment>GeoGebra tool</comment>
+ <comment xml:lang="cs">Nástroj GeoGebry</comment>
+ <comment xml:lang="de">GeoGebra-Werkzeug</comment>
+ <comment xml:lang="es">Herramienta GeoGebra</comment>
+ <comment xml:lang="fr">Outil GeoGebra</comment>
+ <comment xml:lang="hi">जीओ-जेब्रा साधन</comment>
+ <comment xml:lang="it">Strumento GeoGebra</comment>
+ <comment xml:lang="pt-BR">Ferramenta GeoGebra</comment>
+ <sub-class-of type="application/zip"/>
+ <glob pattern="*.ggt"/>
+ <icon name="geogebra"/>
+ </mime-type>
+</mime-info>
diff --git a/math/geogebra/pkg-plist b/math/geogebra/pkg-plist
index ef622dc2d882..4ef2328e4afd 100644
--- a/math/geogebra/pkg-plist
+++ b/math/geogebra/pkg-plist
@@ -21,4 +21,5 @@ share/icons/hicolor/scalable/apps/geogebra.svg
%%DATADIR%%/geogebra/jogl.all-natives-linux-amd64.jar
%%DATADIR%%/geogebra/jogl.all-natives-linux-i586.jar
%%DATADIR%%/geogebra/jogl.all.jar
+share/mime/packages/geogebra-mime.xml
@dir share/mime/packages