aboutsummaryrefslogtreecommitdiff
path: root/math/givaro/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-15 20:31:20 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-15 20:31:20 +0000
commite55c717cb08120ba9ecda980d27c3ddc87d94f95 (patch)
tree38c59905825a8fd929d9abe21534cee8f2e1318d /math/givaro/Makefile
parent1e9581ff9ad09615254c41e920e9555a47267ee5 (diff)
downloadports-e55c717cb08120ba9ecda980d27c3ddc87d94f95.tar.gz
ports-e55c717cb08120ba9ecda980d27c3ddc87d94f95.zip
math/givaro: 3.5.0 -> 3.8.0
Notes
Notes: svn path=/head/; revision=365037
Diffstat (limited to 'math/givaro/Makefile')
-rw-r--r--math/givaro/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/math/givaro/Makefile b/math/givaro/Makefile
index 8fa27169a8ef..f38cd926bf19 100644
--- a/math/givaro/Makefile
+++ b/math/givaro/Makefile
@@ -1,25 +1,23 @@
-# Created by: b.f. <bf@FreeBSD.org>
# $FreeBSD$
PORTNAME= givaro
-PORTVERSION= 3.5.0
-PORTREVISION= 1
+PORTVERSION= 3.8.0
CATEGORIES= math
-MASTER_SITES= https://forge.imag.fr/frs/download.php/133/ LOCAL/bf
+MASTER_SITES= https://forge.imag.fr/frs/download.php/592/ LOCAL/bf
MAINTAINER= bf@FreeBSD.org
COMMENT= C++ library for computer algebra
-LICENSE= CeCILL-Bv1
+LICENSE= CeCILL-Bv1-en.txt
LICENSE_NAME= Ce[a] C[nrs] I[nria] L[ogiciel] L[ibre] B license, version 1
LICENSE_FILE= ${WRKSRC}/Licence_CeCILL-B_V1-en.txt
LICENSE_PERMS= auto-accept
-LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so.10:${PORTSDIR}/math/gmp
USES= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gmp="${LOCALBASE}"
+CONFIGURE_ARGS = --with-gmp="${LOCALBASE}"
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
@@ -28,11 +26,12 @@ OPTIONS_DEFINE= DOXYGEN
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOXYGEN}
-BUILD_DEPENDS += doxygen:${PORTSDIR}/devel/doxygen
+BUILD_DEPENDS += doxygen:${PORTSDIR}/devel/doxygen \
+ dot:${PORTSDIR}/graphics/graphviz
CONFIGURE_ARGS+= --enable-doc --with-docdir=${DOCSDIR}
-PLIST_SUB+= DOXYGEN=""
+PLIST_SUB+= PORTDOCS=""
.else
-PLIST_SUB+= DOXYGEN="@comment "
+PLIST_SUB+= PORTDOCS="@comment "
.endif
CPPFLAGS+= -I${LOCALBASE}/include
@@ -48,10 +47,11 @@ post-patch:
@${REINPLACE_CMD} -e 's/sed -i/& ""/' ${WRKSRC}/docs/Makefile.in
.endif
-.if ${PORT_OPTIONS:MDOXYGEN}
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/givaro-dev-html/
- ${TOUCH} ${STAGEDIR}${DOCSDIR}/givaro-dev-html/.keep-me
+.if ${PORT_OPTIONS:MDOXYGEN}
+ ${RMDIR} ${STAGEDIR}${DOCSDIR}/givaro-dev-html
+ ${FIND} ${WRKSRC}/docs/givaro-html -not -type d \
+ | ${SED} -ne 's,^${WRKSRC}/docs/givaro-html,${DOCSDIR}/givaro-html,p' >> ${TMPPLIST}
.endif
check regression-test test: build