aboutsummaryrefslogtreecommitdiff
path: root/math/givaro
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-23 09:55:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-23 09:55:11 +0000
commitf516337e21e528822d695380f3b496ba432a4784 (patch)
tree644521ff1fc4758c87cb2704ad8ceca71f28ce0d /math/givaro
parent7228783c8efbfeccefb0cf87c3a04d33266a3967 (diff)
downloadports-f516337e21e528822d695380f3b496ba432a4784.tar.gz
ports-f516337e21e528822d695380f3b496ba432a4784.zip
- Pet portlint
- Switch to USES=localbase - Switch to new test framework - Switch to options helpers - Regenerate patches
Notes
Notes: svn path=/head/; revision=429236
Diffstat (limited to 'math/givaro')
-rw-r--r--math/givaro/Makefile36
-rw-r--r--math/givaro/files/patch-src__library__tools__givtruncdomain.h4
-rw-r--r--math/givaro/pkg-plist2
3 files changed, 13 insertions, 29 deletions
diff --git a/math/givaro/Makefile b/math/givaro/Makefile
index 277d90d207d6..ed3f392191b5 100644
--- a/math/givaro/Makefile
+++ b/math/givaro/Makefile
@@ -13,29 +13,21 @@ LICENSE_NAME= Ce[a] C[nrs] I[nria] L[ogiciel] L[ibre] B license, version 1
LICENSE_FILE= ${WRKSRC}/Licence_CeCILL-B_V1-en.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LIB_DEPENDS= libgmp.so.10:math/gmp
+LIB_DEPENDS= libgmp.so:math/gmp
-USES= libtool
+USES= libtool localbase:ldflags
GNU_CONFIGURE= yes
-CONFIGURE_ARGS = --with-gmp="${LOCALBASE}"
+CONFIGURE_ARGS= --with-gmp="${LOCALBASE}"
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+TEST_TARGET= check
OPTIONS_DEFINE= DOXYGEN
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOXYGEN}
-BUILD_DEPENDS += doxygen:devel/doxygen \
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
dot:graphics/graphviz
-CONFIGURE_ARGS+= --enable-doc --with-docdir=${DOCSDIR}
-PLIST_SUB+= PORTDOCS=""
-.else
-PLIST_SUB+= PORTDOCS="@comment "
-.endif
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+DOXYGEN_CONFIGURE_ON= --enable-doc --with-docdir=${DOCSDIR}
post-patch:
@${REINPLACE_CMD} -e '/DEFAULT_CFLAGS=/{s/-O2 //;s/-pipe//;}' \
@@ -43,19 +35,11 @@ post-patch:
-e '/^WARN_CFLAGS="-Wall"/d' \
-e '/if test "x$$WARN" = "xyes"/s/$$/ WARN_CFLAGS="-Wall" ;/' \
${WRKSRC}/configure
-.if ${PORT_OPTIONS:MDOXYGEN}
@${REINPLACE_CMD} -e 's/sed -i/& ""/' ${WRKSRC}/docs/Makefile.in
-.endif
-post-install:
-.if ${PORT_OPTIONS:MDOXYGEN}
- ${RMDIR} ${STAGEDIR}${DOCSDIR}/givaro-dev-html
- ${FIND} ${WRKSRC}/docs/givaro-html -not -type d \
+post-install-DOXYGEN-on:
+ @${RMDIR} ${STAGEDIR}${DOCSDIR}/givaro-dev-html
+ @${FIND} ${WRKSRC}/docs/givaro-html -not -type d \
| ${SED} -ne 's,^${WRKSRC}/docs/givaro-html,${DOCSDIR}/givaro-html,p' >> ${TMPPLIST}
-.endif
-
-check regression-test test: build
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
- ${MAKE_ARGS} check
.include <bsd.port.mk>
diff --git a/math/givaro/files/patch-src__library__tools__givtruncdomain.h b/math/givaro/files/patch-src__library__tools__givtruncdomain.h
index f9cfddaae717..87ffad0fb751 100644
--- a/math/givaro/files/patch-src__library__tools__givtruncdomain.h
+++ b/math/givaro/files/patch-src__library__tools__givtruncdomain.h
@@ -1,5 +1,5 @@
---- ./src/library/tools/givtruncdomain.h.orig 2014-08-11 23:06:35.000000000 +0200
-+++ ./src/library/tools/givtruncdomain.h 2014-08-11 23:06:42.000000000 +0200
+--- src/library/tools/givtruncdomain.h.orig 2013-12-04 17:03:41 UTC
++++ src/library/tools/givtruncdomain.h
@@ -17,7 +17,7 @@
#ifdef __APPLE__
#include <utility>
diff --git a/math/givaro/pkg-plist b/math/givaro/pkg-plist
index e7a0a761ddf6..8b074bebc192 100644
--- a/math/givaro/pkg-plist
+++ b/math/givaro/pkg-plist
@@ -140,4 +140,4 @@ lib/libgivaro.a
lib/libgivaro.so
lib/libgivaro.so.0
lib/libgivaro.so.0.6.0
-%%PORTDOCS%%%%DOCSDIR%%/givaro.html
+%%DOXYGEN%%%%DOCSDIR%%/givaro.html