aboutsummaryrefslogtreecommitdiff
path: root/math/glm
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-12-01 13:04:07 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-12-01 13:04:07 +0000
commite76af7f3fac5c051c2c3554f691407887ddcf94c (patch)
tree2b27bd8a379dbb500531288648dd36abfa654a6d /math/glm
parent415318e43fdc0d8d6cac790f5ae20c8aa2b2d022 (diff)
downloadports-e76af7f3fac5c051c2c3554f691407887ddcf94c.tar.gz
ports-e76af7f3fac5c051c2c3554f691407887ddcf94c.zip
Update to version 0.9.6.1
Notes
Notes: svn path=/head/; revision=373705
Diffstat (limited to 'math/glm')
-rw-r--r--math/glm/Makefile3
-rw-r--r--math/glm/distinfo4
-rw-r--r--math/glm/pkg-plist33
3 files changed, 19 insertions, 21 deletions
diff --git a/math/glm/Makefile b/math/glm/Makefile
index 64b9e59c5849..91721e8fa643 100644
--- a/math/glm/Makefile
+++ b/math/glm/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= glm
-PORTVERSION= 0.9.5.4
-PORTREVISION= 1
+PORTVERSION= 0.9.6.0
CATEGORIES= math graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ogl-math/${PORTNAME}-${PORTVERSION}
diff --git a/math/glm/distinfo b/math/glm/distinfo
index ce4f425e5bba..04f1f5125bdf 100644
--- a/math/glm/distinfo
+++ b/math/glm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (glm-0.9.5.4.zip) = c25002f109104bb8eb37a7e74c745cbc0a713ec5d9a857050c7878edb5ee246c
-SIZE (glm-0.9.5.4.zip) = 4081182
+SHA256 (glm-0.9.6.0.zip) = 0a12e69ba3ad8370f97a7dc79d2d6392098f335499248aa2cf89902afb4b073f
+SIZE (glm-0.9.6.0.zip) = 4219782
diff --git a/math/glm/pkg-plist b/math/glm/pkg-plist
index 51d8d284e628..53086e708a99 100644
--- a/math/glm/pkg-plist
+++ b/math/glm/pkg-plist
@@ -2,7 +2,6 @@ include/glm/CMakeLists.txt
include/glm/common.hpp
include/glm/detail/_features.hpp
include/glm/detail/_fixes.hpp
-include/glm/detail/_literals.hpp
include/glm/detail/_noise.hpp
include/glm/detail/_swizzle.hpp
include/glm/detail/_swizzle_func.hpp
@@ -27,7 +26,6 @@ include/glm/detail/func_trigonometric.inl
include/glm/detail/func_vector_relational.hpp
include/glm/detail/func_vector_relational.inl
include/glm/detail/glm.cpp
-include/glm/detail/hint.hpp
include/glm/detail/intrinsic_common.hpp
include/glm/detail/intrinsic_common.inl
include/glm/detail/intrinsic_exponential.hpp
@@ -43,7 +41,6 @@ include/glm/detail/intrinsic_trigonometric.inl
include/glm/detail/intrinsic_vector_relational.hpp
include/glm/detail/intrinsic_vector_relational.inl
include/glm/detail/precision.hpp
-include/glm/detail/precision.inl
include/glm/detail/setup.hpp
include/glm/detail/type_float.hpp
include/glm/detail/type_gentype.hpp
@@ -86,10 +83,14 @@ include/glm/ext.hpp
include/glm/fwd.hpp
include/glm/geometric.hpp
include/glm/glm.hpp
+include/glm/gtc/bitfield.hpp
+include/glm/gtc/bitfield.inl
include/glm/gtc/constants.hpp
include/glm/gtc/constants.inl
include/glm/gtc/epsilon.hpp
include/glm/gtc/epsilon.inl
+include/glm/gtc/integer.hpp
+include/glm/gtc/integer.inl
include/glm/gtc/matrix_access.hpp
include/glm/gtc/matrix_access.inl
include/glm/gtc/matrix_integer.hpp
@@ -107,12 +108,16 @@ include/glm/gtc/random.hpp
include/glm/gtc/random.inl
include/glm/gtc/reciprocal.hpp
include/glm/gtc/reciprocal.inl
+include/glm/gtc/round.hpp
+include/glm/gtc/round.inl
include/glm/gtc/type_precision.hpp
include/glm/gtc/type_precision.inl
include/glm/gtc/type_ptr.hpp
include/glm/gtc/type_ptr.inl
include/glm/gtc/ulp.hpp
include/glm/gtc/ulp.inl
+include/glm/gtc/vec1.hpp
+include/glm/gtc/vec1.inl
include/glm/gtx/associated_min_max.hpp
include/glm/gtx/associated_min_max.inl
include/glm/gtx/bit.hpp
@@ -123,14 +128,14 @@ include/glm/gtx/color_space.hpp
include/glm/gtx/color_space.inl
include/glm/gtx/color_space_YCoCg.hpp
include/glm/gtx/color_space_YCoCg.inl
+include/glm/gtx/common.hpp
+include/glm/gtx/common.inl
include/glm/gtx/compatibility.hpp
include/glm/gtx/compatibility.inl
include/glm/gtx/component_wise.hpp
include/glm/gtx/component_wise.inl
-include/glm/gtx/constants.hpp
include/glm/gtx/dual_quaternion.hpp
include/glm/gtx/dual_quaternion.inl
-include/glm/gtx/epsilon.hpp
include/glm/gtx/euler_angles.hpp
include/glm/gtx/euler_angles.inl
include/glm/gtx/extend.hpp
@@ -147,10 +152,6 @@ include/glm/gtx/gradient_paint.hpp
include/glm/gtx/gradient_paint.inl
include/glm/gtx/handed_coordinate_space.hpp
include/glm/gtx/handed_coordinate_space.inl
-include/glm/gtx/inertia.hpp
-include/glm/gtx/inertia.inl
-include/glm/gtx/int_10_10_10_2.hpp
-include/glm/gtx/int_10_10_10_2.inl
include/glm/gtx/integer.hpp
include/glm/gtx/integer.inl
include/glm/gtx/intersect.hpp
@@ -161,6 +162,8 @@ include/glm/gtx/log_base.hpp
include/glm/gtx/log_base.inl
include/glm/gtx/matrix_cross_product.hpp
include/glm/gtx/matrix_cross_product.inl
+include/glm/gtx/matrix_decompose.hpp
+include/glm/gtx/matrix_decompose.inl
include/glm/gtx/matrix_interpolation.hpp
include/glm/gtx/matrix_interpolation.inl
include/glm/gtx/matrix_major_storage.hpp
@@ -175,7 +178,6 @@ include/glm/gtx/mixed_product.hpp
include/glm/gtx/mixed_product.inl
include/glm/gtx/multiple.hpp
include/glm/gtx/multiple.inl
-include/glm/gtx/noise.hpp
include/glm/gtx/norm.hpp
include/glm/gtx/norm.inl
include/glm/gtx/normal.hpp
@@ -196,14 +198,14 @@ include/glm/gtx/projection.hpp
include/glm/gtx/projection.inl
include/glm/gtx/quaternion.hpp
include/glm/gtx/quaternion.inl
-include/glm/gtx/random.hpp
+include/glm/gtx/range.hpp
include/glm/gtx/raw_data.hpp
include/glm/gtx/raw_data.inl
-include/glm/gtx/reciprocal.hpp
include/glm/gtx/rotate_normalized_axis.hpp
include/glm/gtx/rotate_normalized_axis.inl
include/glm/gtx/rotate_vector.hpp
include/glm/gtx/rotate_vector.inl
+include/glm/gtx/scalar_multiplication.hpp
include/glm/gtx/scalar_relational.hpp
include/glm/gtx/scalar_relational.inl
include/glm/gtx/simd_mat4.hpp
@@ -222,11 +224,8 @@ include/glm/gtx/transform.hpp
include/glm/gtx/transform.inl
include/glm/gtx/transform2.hpp
include/glm/gtx/transform2.inl
-include/glm/gtx/ulp.hpp
-include/glm/gtx/unsigned_int.hpp
-include/glm/gtx/unsigned_int.inl
-include/glm/gtx/vec1.hpp
-include/glm/gtx/vec1.inl
+include/glm/gtx/type_aligned.hpp
+include/glm/gtx/type_aligned.inl
include/glm/gtx/vector_angle.hpp
include/glm/gtx/vector_angle.inl
include/glm/gtx/vector_query.hpp