aboutsummaryrefslogtreecommitdiff
path: root/math/glpk/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-09-29 11:11:28 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-09-29 11:11:28 +0000
commit2b2d4cea6f28c1c1d29731fdfb42c6b1d3a61376 (patch)
treee0f668587eed9c1976fafd0df2cb39a209221194 /math/glpk/Makefile
parent3185229515e65a188ddac0c1b0683fb4baf428b0 (diff)
downloadports-2b2d4cea6f28c1c1d29731fdfb42c6b1d3a61376.tar.gz
ports-2b2d4cea6f28c1c1d29731fdfb42c6b1d3a61376.zip
Update to 3.0.2
Notes
Notes: svn path=/head/; revision=48266
Diffstat (limited to 'math/glpk/Makefile')
-rw-r--r--math/glpk/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/math/glpk/Makefile b/math/glpk/Makefile
index e71bde366692..8d1011dc1a7b 100644
--- a/math/glpk/Makefile
+++ b/math/glpk/Makefile
@@ -6,28 +6,36 @@
#
PORTNAME= glpk
-PORTVERSION= 3.0.1
+PORTVERSION= 3.0.2
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_GNU} \
http://people.freebsd.org/~demon/distfiles/
MASTER_SITE_SUBDIR= glpk
-.if !defined(NOPORTDOCS)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DOCFILES}
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-.endif
MAINTAINER= demon@FreeBSD.org
+.if !defined(NOPORTDOCS)
+BUILD_DEPENDS= texi2dvi:${PORTSDIR}/print/teTeX
+.endif
+
GNU_CONFIGURE= yes
-DOCFILES= glpk_lr-1.1.1.ps.gz glpk_sm.ps.gz glpk_ug-1.1.1.ps.gz
+DOCFILES= guide language libref simplex
+
+post-build:
+.if !defined(NOPORTDOCS)
+ for file in ${DOCFILES} ; do \
+ cd ${WRKSRC} && ${LOCALBASE}/bin/texi2dvi doc/$$file.texinfo ; \
+ ${LOCALBASE}/bin/dvips -o ${WRKSRC}/$$file.ps \
+ ${WRKSRC}/$$file.dvi ; \
+ done
+.endif
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
for file in ${DOCFILES} ; do \
- ${INSTALL_DATA} ${DISTDIR}/$$file ${DOCSDIR} ; \
- ${GUNZIP_CMD} ${DOCSDIR}/$$file ; \
+ ${INSTALL_DATA} ${WRKSRC}/$$file.ps ${DOCSDIR} ; \
done
.endif