aboutsummaryrefslogtreecommitdiff
path: root/math/gnumeric/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-03-27 00:19:05 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-03-27 00:19:05 +0000
commit3b2d33c5f94fb1b52eb8f8652990c525a1d445b7 (patch)
tree37fd61f03dd647ffea114692061183759166a563 /math/gnumeric/Makefile
parent3633b416d6a1350704d018f774f4cb54b7379625 (diff)
downloadports-3b2d33c5f94fb1b52eb8f8652990c525a1d445b7.tar.gz
ports-3b2d33c5f94fb1b52eb8f8652990c525a1d445b7.zip
Turn the libgnomedb dependency into an OPTION.
Notes
Notes: svn path=/head/; revision=158229
Diffstat (limited to 'math/gnumeric/Makefile')
-rw-r--r--math/gnumeric/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index a84489b270e7..ef4eb7536123 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -27,7 +27,6 @@ USE_PERL5= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomehier libgnomeprintui \
libgsf_gnome pygtk2 desktopfileutils
-WANT_GNOME= yes
USE_PYTHON= yes
INSTALLS_OMF= yes
INSTALLS_SHLIB= yes
@@ -44,6 +43,8 @@ MAN1= gnumeric.1 ssconvert.1 ssindex.1
PLIST_SUB= VERSION=${PORTVERSION}
+OPTIONS GNOMEDB "Enable libgnomedb support" off
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
@@ -52,7 +53,7 @@ PLIST_SUB+= PERL="@comment "
PLIST_SUB+= PERL=""
.endif
-.if ${HAVE_GNOME:Mlibgnomedb}!=""
+.if defined(WITH_GNOMEDB)
USE_GNOME+= libgnomedb
CONFIGURE_ARGS+= --with-gda
PLIST_SUB+= GNOMEDB=""