aboutsummaryrefslogtreecommitdiff
path: root/math/grace
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 08:41:40 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 08:41:40 +0000
commit121181f4e6951c5828ae4a73ebe6e82f9b9a210f (patch)
treebbffd1d52f98c29888eb898bf5599647fcaae1d6 /math/grace
parent8d087a6cf09331f49618430b0d609cc79134b723 (diff)
downloadports-121181f4e6951c5828ae4a73ebe6e82f9b9a210f.tar.gz
ports-121181f4e6951c5828ae4a73ebe6e82f9b9a210f.zip
A powerful plotting tool (successor of xmgr)
PR: ports/9222 Submitted by: Lars Koeller lkoeller@cc.fh-lippe.de
Notes
Notes: svn path=/head/; revision=17277
Diffstat (limited to 'math/grace')
-rw-r--r--math/grace/Makefile51
-rw-r--r--math/grace/distinfo1
-rw-r--r--math/grace/files/freebsd27
-rw-r--r--math/grace/files/mini-xmgr3.xpmbin0 -> 6563 bytes
-rw-r--r--math/grace/files/patch-aa53
-rw-r--r--math/grace/files/patch-ab19
-rw-r--r--math/grace/files/patch-ac19
-rw-r--r--math/grace/files/patch-ad19
-rw-r--r--math/grace/pkg-comment1
-rw-r--r--math/grace/pkg-descr25
-rw-r--r--math/grace/pkg-plist129
-rw-r--r--math/grace/scripts/configure3
12 files changed, 347 insertions, 0 deletions
diff --git a/math/grace/Makefile b/math/grace/Makefile
new file mode 100644
index 000000000000..7736365892f2
--- /dev/null
+++ b/math/grace/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: grace
+# Version required: 5.0.1
+# Date created: Dec 28 1998
+# Whom: Lars Koeller <lkoeller@cc.fh-lippe.de>
+#
+# $Id$
+#
+
+DISTNAME= grace-5.0.1
+PKGNAME= grace-5.0.1a
+CATEGORIES= math print
+#
+# You never know when and why this caotic team moves it to ../src/old/ :-)
+#
+MASTER_SITES= ftp://ftp.uni-bielefeld.de/pub/systems/FreeBSD/lkoeller/ \
+ ftp://plasma-gate.weizmann.ac.il/pub/grace/src/ \
+ ftp://plasma-gate.weizmann.ac.il/pub/grace/src/old/ \
+ ftp://abragam.med.utoronto.ca/pub/mirrors/grace/src/ \
+ ftp://abragam.med.utoronto.ca/pub/mirrors/grace/src/old/ \
+ ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/grace/src/old/ \
+ ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/grace/src/
+EXTRACT_SUFX= alpha.tar.gz
+
+MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
+
+BUILD_DEPENDS= ${X11BASE}/lib/libhlpclient.a:${PORTSDIR}/x11/libhelp \
+ ${LOCALBASE}/lib/libmfhdf.a:${PORTSDIR}/graphics/hdf \
+ ${LOCALBASE}/lib/libgd.a:${PORTSDIR}/graphics/gd \
+ ${LOCALBASE}/lib/libpdf.a:${PORTSDIR}/print/pdflib
+LIB_DEPENDS= Xbae.6:${PORTSDIR}/x11-toolkits/xbae \
+ fftw.2:${PORTSDIR}/math/fftw \
+ tiff.4:${PORTSDIR}/graphics/tiff34
+
+USE_X_PREFIX= YES
+REQUIRE_MOTIF= YES
+HAS_CONFIGURE= YES
+CONFIGURE_ARGS= -prefix=${X11BASE} \
+ --enable-extra-incpath=${X11BASE}/include/X11:${LOCALBASE}/include:${LOCALBASE}/include/tiff34:${LOCALBASE}/include/gd \
+ --enable-extra-ldpath=${LOCALBASE}/lib --enable-libhelp \
+ --enable-mfhdf --enable-grace-home=${X11BASE}/lib/X11/grace
+
+ALL_TARGET=
+INSTALL_TARGET= install links
+
+post-patch:
+ ${MV} ${WRKSRC}/configure ${WRKSRC}/configure.input
+ ${SED} "s%-lXm %${MOTIFLIB} %" ${WRKSRC}/configure.input > ${WRKSRC}/configure
+ chmod 755 ${WRKSRC}/configure
+ ${RM} -f ${WRKSRC}/configure.input
+
+.include <bsd.port.mk>
diff --git a/math/grace/distinfo b/math/grace/distinfo
new file mode 100644
index 000000000000..b991208afdb6
--- /dev/null
+++ b/math/grace/distinfo
@@ -0,0 +1 @@
+MD5 (grace-5.0.1alpha.tar.gz) = c367387d3fd2b0565cf8c2e81f9c37c0
diff --git a/math/grace/files/freebsd b/math/grace/files/freebsd
new file mode 100644
index 000000000000..9f21bfa5310c
--- /dev/null
+++ b/math/grace/files/freebsd
@@ -0,0 +1,27 @@
+#****************************************
+#* Intel Linux with X11R6 and Motif 2.0 *
+#****************************************
+
+###############################
+# Compiler
+#
+CC="gcc"
+###############################
+
+###############################
+# C flags
+#
+CFLAGS="-Wall -pedantic"
+###############################
+
+###############################
+# Misc optimization flags
+#
+OPTIMIZE="-O2"
+###############################
+
+###############################
+# Flags used for debugging
+#
+DEBUG="-g -O2"
+###############################
diff --git a/math/grace/files/mini-xmgr3.xpm b/math/grace/files/mini-xmgr3.xpm
new file mode 100644
index 000000000000..35b090764838
--- /dev/null
+++ b/math/grace/files/mini-xmgr3.xpm
Binary files differ
diff --git a/math/grace/files/patch-aa b/math/grace/files/patch-aa
new file mode 100644
index 000000000000..4e26813042c1
--- /dev/null
+++ b/math/grace/files/patch-aa
@@ -0,0 +1,53 @@
+*** configure.orig Tue Sep 15 14:51:57 1998
+--- configure Wed Dec 23 16:46:57 1998
+***************
+*** 660,665 ****
+--- 660,666 ----
+ case "${host}" in
+ i?86-*-linux-*) CONF_FILE="ix86-linux";;
+ *-*-linux-*) CONF_FILE="linux";;
++ *-*-freebsd*) CONF_FILE="freebsd";;
+ i?86-*-sco-*) CONF_FILE="ix86-sco";;
+ i?86-*-cygwin32) CONF_FILE="ix86-cygwin32";;
+ alpha*-dec-osf4.*) CONF_FILE="alpha-osf4";;
+***************
+*** 4729,4735 ****
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+! LIBS="-ldf $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 4735 "configure"
+ #include "confdefs.h"
+--- 4730,4736 ----
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+! LIBS="-lmfhdf -ldf -lz $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 4735 "configure"
+ #include "confdefs.h"
+***************
+*** 4753,4759 ****
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+! NETCDF_LIBS="$NETCDF_LIBS -ldf"; cat >> confdefs.h <<\EOF
+ #define HAVE_MFHDF 1
+ EOF
+
+--- 4754,4760 ----
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+! NETCDF_LIBS="$NETCDF_LIBS -lmfhdf -ldf -lz"; cat >> confdefs.h <<\EOF
+ #define HAVE_MFHDF 1
+ EOF
+
+***************
+*** 6858,6861 ****
+ chmod +x $CONFIG_STATUS
+ rm -fr confdefs* $ac_clean_files
+ test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
+-
+--- 6859,6861 ----
diff --git a/math/grace/files/patch-ab b/math/grace/files/patch-ab
new file mode 100644
index 000000000000..f27b3ec5b1bb
--- /dev/null
+++ b/math/grace/files/patch-ab
@@ -0,0 +1,19 @@
+*** src/pdfdrv.c.org Wed Dec 23 12:55:06 1998
+--- src/pdfdrv.c Wed Dec 23 12:55:20 1998
+***************
+*** 52,58 ****
+ #include "protos.h"
+
+ /* uncomment this if the PDFlib was compiled w/ support for TIFF images */
+! /* #define USE_TIFF */
+ #include <pdf.h>
+
+ #ifndef NONE_GUI
+--- 52,58 ----
+ #include "protos.h"
+
+ /* uncomment this if the PDFlib was compiled w/ support for TIFF images */
+! #define USE_TIFF
+ #include <pdf.h>
+
+ #ifndef NONE_GUI
diff --git a/math/grace/files/patch-ac b/math/grace/files/patch-ac
new file mode 100644
index 000000000000..4f7d88dedfc8
--- /dev/null
+++ b/math/grace/files/patch-ac
@@ -0,0 +1,19 @@
+*** examples/Makefile.orig Wed Dec 23 18:30:25 1998
+--- examples/Makefile Wed Dec 23 18:31:38 1998
+***************
+*** 32,38 ****
+ install : $(EXAMPLES) $(DOTEST)
+ $(MKINSTALLDIRS) $(GRACE_HOME)/examples
+ for i in $(EXAMPLES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/examples; done
+! $(INSTALL_PROGRAM) $(DOTEST) $(GRACE_HOME)/examples/$(DOTEST)
+
+ links : dummy
+
+--- 32,38 ----
+ install : $(EXAMPLES) $(DOTEST)
+ $(MKINSTALLDIRS) $(GRACE_HOME)/examples
+ for i in $(EXAMPLES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/examples; done
+! $(INSTALL) -c -o root -g wheel -m 555 $(DOTEST) $(GRACE_HOME)/examples/$(DOTEST)
+
+ links : dummy
+
diff --git a/math/grace/files/patch-ad b/math/grace/files/patch-ad
new file mode 100644
index 000000000000..38d8e848533c
--- /dev/null
+++ b/math/grace/files/patch-ad
@@ -0,0 +1,19 @@
+*** auxiliary/Makefile.org Mon Jul 20 23:51:55 1998
+--- auxiliary/Makefile Wed Dec 23 19:12:15 1998
+***************
+*** 22,28 ****
+ install : $(AUXILIARIES) fdf2fit
+ $(MKINSTALLDIRS) $(GRACE_HOME)/auxiliary
+ for i in $(AUXILIARIES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/auxiliary; done
+! $(INSTALL_PROGRAM) fdf2fit $(GRACE_HOME)/auxiliary
+
+ tests : dummy
+
+--- 22,28 ----
+ install : $(AUXILIARIES) fdf2fit
+ $(MKINSTALLDIRS) $(GRACE_HOME)/auxiliary
+ for i in $(AUXILIARIES); do $(INSTALL_DATA) $$i $(GRACE_HOME)/auxiliary; done
+! $(INSTALL) -c -o root -g wheel -m 555 fdf2fit $(GRACE_HOME)/auxiliary
+
+ tests : dummy
+
diff --git a/math/grace/pkg-comment b/math/grace/pkg-comment
new file mode 100644
index 000000000000..1e4af948fe54
--- /dev/null
+++ b/math/grace/pkg-comment
@@ -0,0 +1 @@
+A powerful plotting tool (successor of xmgr)
diff --git a/math/grace/pkg-descr b/math/grace/pkg-descr
new file mode 100644
index 000000000000..c3d9edf5ebbb
--- /dev/null
+++ b/math/grace/pkg-descr
@@ -0,0 +1,25 @@
+grace is an plotting tool for workstations or X-terminals using X. A few of
+its features are:
+
+ * User defined scaling, tick marks, labels, symbols, line styles, colors.
+ * Batch mode for unattended plotting.
+ * Read and write parameters used during a session.
+ * Polynomial regression, splines, running averages, DFT/FFT,
+ cross/auto-correlation.
+ * Hardcopy support for PostScript, HP-GL, and FrameMaker .mif format.
+
+While grace has a convenient point-and-click interface, most parameter settings
+and operations are available through a command line interface (found in
+Data/Commands).
+
+grace is the successor of the well known xmgr plotting tool!
+
+Known PROBLEMS:
+
+ - GD-1.3 library of Thomas Boutell:
+ * patterned fills of ellipses make Grace crash
+ * complex polygons are filled incorrectly sometimes
+
+ - PDFlib-0.6 library of Thomas Merz
+ * patterned fills are not implemented
+ * bitmapped text strings are not transparent
diff --git a/math/grace/pkg-plist b/math/grace/pkg-plist
new file mode 100644
index 000000000000..2a03b8bdc699
--- /dev/null
+++ b/math/grace/pkg-plist
@@ -0,0 +1,129 @@
+lib/X11/grace/auxiliary/README
+lib/X11/grace/auxiliary/fdf2fit
+lib/X11/grace/auxiliary/greg2jul.c
+lib/X11/grace/auxiliary/jul2greg.c
+lib/X11/grace/auxiliary/magic.xmgr
+lib/X11/grace/bin/gracebat
+lib/X11/grace/bin/grconvert
+lib/X11/grace/bin/xmgrace
+lib/X11/grace/doc/CHANGES.html
+lib/X11/grace/doc/FAQ.html
+lib/X11/grace/doc/GPL.html
+lib/X11/grace/doc/MIGRATION.html
+lib/X11/grace/doc/acegr_np.html
+lib/X11/grace/doc/commands.html
+lib/X11/grace/doc/data.html
+lib/X11/grace/doc/dblclick.html
+lib/X11/grace/doc/dlmodule.html
+lib/X11/grace/doc/edcrset.html
+lib/X11/grace/doc/file.html
+lib/X11/grace/doc/fonts.html
+lib/X11/grace/doc/graphops.html
+lib/X11/grace/doc/guide.html
+lib/X11/grace/doc/hotkeys.html
+lib/X11/grace/doc/intro.html
+lib/X11/grace/doc/main.html
+lib/X11/grace/doc/nohelp.html
+lib/X11/grace/doc/npipe.html
+lib/X11/grace/doc/options.html
+lib/X11/grace/doc/page.html
+lib/X11/grace/doc/philosophical-gnu-sm.jpg
+lib/X11/grace/doc/plot.html
+lib/X11/grace/doc/points.html
+lib/X11/grace/doc/regions.html
+lib/X11/grace/doc/sets.html
+lib/X11/grace/doc/test_np.c
+lib/X11/grace/doc/testf_np.f
+lib/X11/grace/doc/trans.html
+lib/X11/grace/doc/usage.html
+lib/X11/grace/doc/view.html
+lib/X11/grace/examples/altaxis.par
+lib/X11/grace/examples/au.d
+lib/X11/grace/examples/axes.agr
+lib/X11/grace/examples/bar.d
+lib/X11/grace/examples/bar2.d
+lib/X11/grace/examples/bars.d
+lib/X11/grace/examples/brw.dat
+lib/X11/grace/examples/co2.all
+lib/X11/grace/examples/co2.par
+lib/X11/grace/examples/dotest
+lib/X11/grace/examples/explain.agr
+lib/X11/grace/examples/fills.dat
+lib/X11/grace/examples/graphs.par
+lib/X11/grace/examples/hilo.dat
+lib/X11/grace/examples/log.d
+lib/X11/grace/examples/logistic.d
+lib/X11/grace/examples/logistic.fit
+lib/X11/grace/examples/logtest.par
+lib/X11/grace/examples/manygraphs.agr
+lib/X11/grace/examples/mlo.dat
+lib/X11/grace/examples/moresyms.agr
+lib/X11/grace/examples/polar.agr
+lib/X11/grace/examples/props.agr
+lib/X11/grace/examples/regions.par
+lib/X11/grace/examples/slideshow.d
+lib/X11/grace/examples/stackedb.d
+lib/X11/grace/examples/symslines.agr
+lib/X11/grace/examples/tbar3.dat
+lib/X11/grace/examples/terr.d
+lib/X11/grace/examples/terr2.d
+lib/X11/grace/examples/test.com
+lib/X11/grace/examples/test.dat
+lib/X11/grace/examples/test1.par
+lib/X11/grace/examples/test2.d
+lib/X11/grace/examples/tfonts.agr
+lib/X11/grace/examples/tforms.par
+lib/X11/grace/examples/times.dat
+lib/X11/grace/examples/tinset.d
+lib/X11/grace/examples/tlog.agr
+lib/X11/grace/examples/tmc.c
+lib/X11/grace/examples/tpipe.d
+lib/X11/grace/examples/tstack.dat
+lib/X11/grace/examples/txyr.dat
+lib/X11/grace/examples/typeset.agr
+lib/X11/grace/fonts/FontDataBase
+lib/X11/grace/fonts/enc/Default.enc
+lib/X11/grace/fonts/enc/IsoLatin1.enc
+lib/X11/grace/fonts/type1/d050000l.afm
+lib/X11/grace/fonts/type1/d050000l.pfb
+lib/X11/grace/fonts/type1/n019003l.afm
+lib/X11/grace/fonts/type1/n019003l.pfb
+lib/X11/grace/fonts/type1/n019004l.afm
+lib/X11/grace/fonts/type1/n019004l.pfb
+lib/X11/grace/fonts/type1/n019023l.afm
+lib/X11/grace/fonts/type1/n019023l.pfb
+lib/X11/grace/fonts/type1/n019024l.afm
+lib/X11/grace/fonts/type1/n019024l.pfb
+lib/X11/grace/fonts/type1/n021003l.afm
+lib/X11/grace/fonts/type1/n021003l.pfb
+lib/X11/grace/fonts/type1/n021004l.afm
+lib/X11/grace/fonts/type1/n021004l.pfb
+lib/X11/grace/fonts/type1/n021023l.afm
+lib/X11/grace/fonts/type1/n021023l.pfb
+lib/X11/grace/fonts/type1/n021024l.afm
+lib/X11/grace/fonts/type1/n021024l.pfb
+lib/X11/grace/fonts/type1/n022003l.afm
+lib/X11/grace/fonts/type1/n022003l.pfb
+lib/X11/grace/fonts/type1/n022004l.afm
+lib/X11/grace/fonts/type1/n022004l.pfb
+lib/X11/grace/fonts/type1/n022023l.afm
+lib/X11/grace/fonts/type1/n022023l.pfb
+lib/X11/grace/fonts/type1/n022024l.afm
+lib/X11/grace/fonts/type1/n022024l.pfb
+lib/X11/grace/fonts/type1/s050000l.afm
+lib/X11/grace/fonts/type1/s050000l.pfb
+lib/X11/grace/include/grace_np.h
+lib/X11/grace/lib/libgrace_np.a
+lib/X11/grace/gracerc.sample
+bin/xmgrace
+bin/gracebat
+@dirrm lib/X11/grace/auxiliary
+@dirrm lib/X11/grace/bin
+@dirrm lib/X11/grace/doc
+@dirrm lib/X11/grace/examples
+@dirrm lib/X11/grace/fonts/enc
+@dirrm lib/X11/grace/fonts/type1
+@dirrm lib/X11/grace/fonts
+@dirrm lib/X11/grace/include
+@dirrm lib/X11/grace/lib
+@dirrm lib/X11/grace
diff --git a/math/grace/scripts/configure b/math/grace/scripts/configure
new file mode 100644
index 000000000000..8005e1c3a290
--- /dev/null
+++ b/math/grace/scripts/configure
@@ -0,0 +1,3 @@
+#! /bin/sh
+
+cp ${FILESDIR}/freebsd ${WRKSRC}/conf/freebsd