aboutsummaryrefslogtreecommitdiff
path: root/math/gravity/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-13 22:22:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-13 22:24:46 +0000
commitde16e756bea51dcbe3d4cdf0cb42c50973c01277 (patch)
treed9259b381cf4b75b26de66179410bc5cbdc86883 /math/gravity/Makefile
parente74901c007b56fea2bed9038dfa482fd9a44705f (diff)
downloadports-de16e756bea51dcbe3d4cdf0cb42c50973c01277.tar.gz
ports-de16e756bea51dcbe3d4cdf0cb42c50973c01277.zip
math/gravity: Fix the test target
Test executable is built by the project by default. This was changed in the patch and made conditional on a special cmake variable. The test target is now updated to reflect this.
Diffstat (limited to 'math/gravity/Makefile')
-rw-r--r--math/gravity/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/math/gravity/Makefile b/math/gravity/Makefile
index 3a91bf2c94f3..340e9aa3596b 100644
--- a/math/gravity/Makefile
+++ b/math/gravity/Makefile
@@ -36,6 +36,9 @@ CMAKE_ON= Boost Ipopt
LDFLAGS+= -L${LOCALBASE}/lib/gcc${GCC_DEFAULT}
do-test:
- @${WRKSRC}/bin/Release/gravity_test
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_EXAMPLES:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${WRKSRC}/bin/Release/gravity_test
.include <bsd.port.mk>