aboutsummaryrefslogtreecommitdiff
path: root/math/gretl/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:16:16 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:16:16 +0000
commit8d6597e0bb9591c40fc6d0c6e2159fca51178d56 (patch)
treed3548a0f08ca434f11cb4415a93d98037409413b /math/gretl/Makefile
parenta9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2 (diff)
downloadports-8d6597e0bb9591c40fc6d0c6e2159fca51178d56.tar.gz
ports-8d6597e0bb9591c40fc6d0c6e2159fca51178d56.zip
Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.
With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=412348
Diffstat (limited to 'math/gretl/Makefile')
-rw-r--r--math/gretl/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 0d9cdd3c4526..f8179c49a651 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -12,8 +12,8 @@ COMMENT= GNU Regression, Econometrics, and Time-series Library
LICENSE= GPLv3
-LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
- libfftw3.so:${PORTSDIR}/math/fftw3
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libfftw3.so:math/fftw3
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -40,12 +40,12 @@ OPTIONS_DEFAULT= GUI OPENMP UNZIP
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MATLAS}
-LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:math/atlas
BLAS= -lf77blas
LAPACK= -lalapack -lcblas
.else
-LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
- liblapack.so:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:math/blas \
+ liblapack.so:math/lapack
BLAS= -lblas
LAPACK= -llapack
.endif
@@ -55,8 +55,8 @@ CONFIGURE_ARGS+= --enable-gtk2=yes --enable-gui=yes
INSTALLS_ICONS= yes
USE_GNOME= gtksourceview2
USES+= desktop-file-utils shared-mime-info
-BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
-RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
+BUILD_DEPENDS+= gnuplot:math/gnuplot
+RUN_DEPENDS+= gnuplot:math/gnuplot
PLIST_SUB+= GUI=""
.else
USE_GNOME= glib20 libxml2
@@ -75,7 +75,7 @@ PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+= --with-odbc
-LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:databases/unixODBC
PLIST_SUB+= ODBC=""
.else
CONFIGURE_ARGS+= --without-odbc
@@ -88,7 +88,7 @@ CONFIGURE_ARGS+= --enable-openmp
.if ${PORT_OPTIONS:MR}
CONFIGURE_ARGS+= --with-libR
-LIB_DEPENDS+= libR.so:${PORTSDIR}/math/R
+LIB_DEPENDS+= libR.so:math/R
.else
CONFIGURE_ARGS+= --without-libR
.endif