aboutsummaryrefslogtreecommitdiff
path: root/math/gretl
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2013-11-20 08:34:26 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2013-11-20 08:34:26 +0000
commit511b66cd9fc8425b83dfcba44d502482774b2ab2 (patch)
tree4a2ecaeea6d6d8c99f4398fa38c6f730b1fc7549 /math/gretl
parent3c930828983b93c42622c90f45165062c9fbf227 (diff)
downloadports-511b66cd9fc8425b83dfcba44d502482774b2ab2.tar.gz
ports-511b66cd9fc8425b83dfcba44d502482774b2ab2.zip
Update to 1.9.13
Notes
Notes: svn path=/head/; revision=334399
Diffstat (limited to 'math/gretl')
-rw-r--r--math/gretl/Makefile37
-rw-r--r--math/gretl/distinfo4
-rw-r--r--math/gretl/files/patch-gui2::Makefile.in30
-rw-r--r--math/gretl/files/patch-lib::Makefile.in8
-rw-r--r--math/gretl/pkg-plist5
5 files changed, 57 insertions, 27 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index d713d44659c8..fb31907a87d6 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -2,16 +2,17 @@
# $FreeBSD$
PORTNAME= gretl
-PORTVERSION= 1.9.12
-PORTREVISION= 1
+PORTVERSION= 1.9.13
CATEGORIES= math finance
MASTER_SITES= SF
MAINTAINER= bf@FreeBSD.org
COMMENT= GNU Regression, Econometrics, and Time-series Library
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- fftw3:${PORTSDIR}/math/fftw3
+LICENSE= GPLv3
+
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libfftw3.so:${PORTSDIR}/math/fftw3
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -30,30 +31,31 @@ CONFIGURE_ENV= LAPACK_LIBS="${LAPACK} ${BLAS}"
MAN1= gretl.1
-OPTIONS_DEFINE = ATLAS GUI ODBC OPENMP R
+OPTIONS_DEFINE = ATLAS GUI ODBC OPENMP R UNZIP
ATLAS_DESC = Use ATLAS for BLAS and LAPACK
GUI_DESC= Graphical user interface and plugins
R_DESC= libR support
+UNZIP_DESC= UnZip compression support via libgsf
-OPTIONS_DEFAULT= GUI OPENMP
+OPTIONS_DEFAULT= GUI OPENMP UNZIP
NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MATLAS}
-LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lf77blas
LAPACK= -lalapack -lcblas
.else
-LIB_DEPENDS+= blas:${PORTSDIR}/math/blas \
- lapack:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
+ liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.endif
.if ${PORT_OPTIONS:MGUI}
-CONFIGURE_ARGS+= --enable-gui=yes
+CONFIGURE_ARGS+= --enable-gtk2=yes --enable-gui=yes
INSTALLS_ICONS= yes
USE_GNOME= gtksourceview2
USES+= desktop-file-utils shared-mime-info
@@ -68,7 +70,7 @@ PLIST_SUB+= GUI="@comment "
.if ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+= --enable-nls=yes
-USES+= gettext
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --enable-nls=no
@@ -77,7 +79,7 @@ PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+= --with-odbc
-LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
PLIST_SUB+= ODBC=""
.else
CONFIGURE_ARGS+= --without-odbc
@@ -90,11 +92,18 @@ CONFIGURE_ARGS+= --enable-openmp
.if ${PORT_OPTIONS:MR}
CONFIGURE_ARGS+= --with-libR
-LIB_DEPENDS+= R:${PORTSDIR}/math/R
+LIB_DEPENDS+= libR.so:${PORTSDIR}/math/R
.else
CONFIGURE_ARGS+= --without-libR
.endif
+.if ${PORT_OPTIONS:MUNZIP}
+CONFIGURE_ARGS+= --with-gsf
+USE_GNOME+= libgsf
+.else
+CONFIGURE_ARGS+= --without-gsf
+.endif
+
.if !empty(MACHINE_CPU:Msse2)
CONFIGURE_ARGS+= --enable-sse2=yes
.else
@@ -110,7 +119,7 @@ post-patch:
${WRKSRC}/cephes/iv.c
regression-test test check: build
- @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${_MAKE_JOBS} \
+ @cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
${MAKE_ARGS} check
.include <bsd.port.mk>
diff --git a/math/gretl/distinfo b/math/gretl/distinfo
index 287d3bb7f8fa..87b4149f49a1 100644
--- a/math/gretl/distinfo
+++ b/math/gretl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gretl-1.9.12.tar.bz2) = dcca78388b815d56c94eb3fb6ed4d99fa19362aa9e806ab12228f1cf483470c4
-SIZE (gretl-1.9.12.tar.bz2) = 9359175
+SHA256 (gretl-1.9.13.tar.bz2) = ec5c43b207c9aca0946f19b05bb6b673e77c03530dffdcdb55b2e2b983aa26f0
+SIZE (gretl-1.9.13.tar.bz2) = 10157682
diff --git a/math/gretl/files/patch-gui2::Makefile.in b/math/gretl/files/patch-gui2::Makefile.in
index 8d3f6f90d830..a69067182f13 100644
--- a/math/gretl/files/patch-gui2::Makefile.in
+++ b/math/gretl/files/patch-gui2::Makefile.in
@@ -1,11 +1,29 @@
---- gui2/Makefile.in.orig 2010-08-28 11:10:12.000000000 -0400
-+++ gui2/Makefile.in 2011-02-02 15:50:09.000000000 -0500
-@@ -221,7 +221,7 @@
+--- gui2/Makefile.in.orig 2013-03-30 13:23:00.000000000 -0400
++++ gui2/Makefile.in 2013-11-20 00:31:53.000000000 -0500
+@@ -122,7 +122,7 @@
+ PROG = gretl
+ else
+ PROG = gretl_x11$(EXEEXT)
+- INSTALL_SCRIPT = install-script
++ INSTALL_SCRIPT_TARGET = install-script
+ endif
+
+ vpath %.c $(topsrc)/gui2
+@@ -215,7 +215,7 @@
+
+ .PHONY:
+
+-install: install-exec install-ui $(INSTALL_SCRIPT) install-data install-lang
++install: install-exec install-ui $(INSTALL_SCRIPT_TARGET) install-data install-lang
+
+ install-strip: $(PROG) install-data
$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) -s $(PROG) $(DESTDIR)$(bindir)/$(PROG)
+@@ -229,7 +229,7 @@
+ $(INSTALL_DATA) $(topsrc)/gui2/gretlmodel.xml $(DESTDIR)$(uidir)
- install-data: installdirs
+ install-script: installdirs
- $(INSTALL_PROGRAM) ../gretl_sh $(DESTDIR)$(bindir)/gretl
+ $(INSTALL_SCRIPT) ../gretl_sh $(DESTDIR)$(bindir)/gretl
- $(INSTALL_DATA) $(topsrc)/pixmaps/gretl-logo.xpm $(DESTDIR)$(gretldir)
- $(INSTALL_DATA) $(topsrc)/COPYING $(DESTDIR)$(gretldir)
+ install-exec: $(PROG) installdirs
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(bindir)/$(PROG)
diff --git a/math/gretl/files/patch-lib::Makefile.in b/math/gretl/files/patch-lib::Makefile.in
index abeb39dc5a72..3c88d3c6119c 100644
--- a/math/gretl/files/patch-lib::Makefile.in
+++ b/math/gretl/files/patch-lib::Makefile.in
@@ -1,11 +1,11 @@
---- lib/Makefile.in.orig 2013-04-20 18:39:30.000000000 -0400
-+++ lib/Makefile.in 2013-04-20 18:39:44.000000000 -0400
-@@ -68,7 +68,7 @@
+--- lib/Makefile.in.orig 2013-08-16 13:12:54.000000000 -0400
++++ lib/Makefile.in 2013-11-18 21:43:54.000000000 -0500
+@@ -70,7 +70,7 @@
LIBGRETL = libgretl-1.0.la
-LIBS = $(LAPACK_LIBS) -lm -ldl -lz $(XML_LIBS) \
+LIBS = $(LAPACK_LIBS) -lm -lz $(XML_LIBS) \
- $(GLIB_LIBS) $(GMP_LIBS) $(FFTW_LIBS) $(CURL_LIBS)
+ $(GLIB_LIBS) $(GMP_LIBS) $(FFTW_LIBS) $(CURL_LIBS) $(GSF_LIBS)
#### End of system configuration section. ####
diff --git a/math/gretl/pkg-plist b/math/gretl/pkg-plist
index 5e8e2c1db272..d58358f04fbe 100644
--- a/math/gretl/pkg-plist
+++ b/math/gretl/pkg-plist
@@ -197,7 +197,7 @@ lib/gretl-gtk2/vif.so
lib/libgretl-1.0.a
lib/libgretl-1.0.la
lib/libgretl-1.0.so
-lib/libgretl-1.0.so.7
+lib/libgretl-1.0.so.8
libdata/pkgconfig/gretl.pc
%%GUI%%share/applications/gretl.desktop
%%GUI%%%%DATADIR%%/COPYING
@@ -564,12 +564,15 @@ libdata/pkgconfig/gretl.pc
%%GUI%%share/icons/hicolor/32x32/mimetypes/text-gretl.script.png
%%GUI%%share/icons/hicolor/48x48/apps/gretl.png
%%GUI%%share/icons/hicolor/64x64/apps/gretl.png
+%%NLS%%share/locale/bg/LC_MESSAGES/gretl.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/gretl.mo
%%NLS%%share/locale/cs/LC_MESSAGES/gretl.mo
%%NLS%%share/locale/de/LC_MESSAGES/gretl.mo
%%NLS%%share/locale/el/LC_MESSAGES/gretl.mo
%%NLS%%share/locale/es/LC_MESSAGES/gretl.mo
%%NLS%%share/locale/eu/LC_MESSAGES/gretl.mo
%%NLS%%share/locale/fr/LC_MESSAGES/gretl.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/gretl.mo
%%NLS%%share/locale/it/LC_MESSAGES/gretl.mo
%%NLS%%share/locale/pl/LC_MESSAGES/gretl.mo
%%NLS%%share/locale/pt/LC_MESSAGES/gretl.mo