aboutsummaryrefslogtreecommitdiff
path: root/math/gretl
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-01 22:50:04 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-01 22:50:04 +0000
commit5f582b73ab228c78efcb60ec79e46d7de3bdeea7 (patch)
tree77e9674309d2ca97b8363af500f0566990fa2f03 /math/gretl
parent2734c5eab5b5ac2d79cbd762e7e6a66477a14532 (diff)
downloadports-5f582b73ab228c78efcb60ec79e46d7de3bdeea7.tar.gz
ports-5f582b73ab228c78efcb60ec79e46d7de3bdeea7.zip
math/gretl: fix build on GCC architectures
Since the last upgrade, gretl requires C11: ../lib/src/bhhh_max.c:37: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'Lval' Fix this by adding USES=compiler:c11 and replacing OPENMP_USES=compiler:openmp with OPENMP_USE=GCC=yes. This sets the correct CC. PR: 243027 Approved by: yuri (maintainer)
Notes
Notes: svn path=/head/; revision=521784
Diffstat (limited to 'math/gretl')
-rw-r--r--math/gretl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index f7fea244a5d5..34a7850c1a4d 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libjson-glib-1.0.so:devel/json-glib \
libmpfr.so:math/mpfr
-USES= fortran gmake gnome localbase libtool ncurses pathfix pkgconfig \
- readline tar:xz
+USES= compiler:c11 fortran gmake gnome localbase libtool ncurses \
+ pathfix pkgconfig readline tar:xz
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -69,7 +69,7 @@ ODBC_CONFIGURE_WITH= odbc
ODBC_LIB_DEPENDS= libodbc.so:databases/unixODBC
OPENMP_CONFIGURE_ENABLE= openmp
-OPENMP_USES= compiler:openmp
+OPENMP_USE= GCC=yes
R_DESC= libR support
R_CONFIGURE_WITH= libR