aboutsummaryrefslogtreecommitdiff
path: root/math/ideep/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-10-27 20:19:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-10-27 20:19:29 +0000
commit68f4f67e571b12a4d7570bab34589b714036445f (patch)
tree49968eb1389298dbf5788c81e0aa0bd2f64eb5b2 /math/ideep/Makefile
parentd0942f522edd2c350a370d1912093a89e952cd69 (diff)
downloadports-68f4f67e571b12a4d7570bab34589b714036445f.tar.gz
ports-68f4f67e571b12a4d7570bab34589b714036445f.zip
New port: math/ideep: Chainer module for numpy-like API and DNN acceleration using MKL-DNN
Notes
Notes: svn path=/head/; revision=515823
Diffstat (limited to 'math/ideep/Makefile')
-rw-r--r--math/ideep/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/ideep/Makefile b/math/ideep/Makefile
new file mode 100644
index 000000000000..6507ed70b066
--- /dev/null
+++ b/math/ideep/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= ideep
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.0.0-119
+DISTVERSIONSUFFIX= -gb57539e
+CATEGORIES= math # neural-networks
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Chainer module for numpy-like API and DNN acceleration using MKL-DNN
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${LOCALBASE}/include/rapidcheck.h:devel/rapidcheck
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= intel
+USE_LDCONFIG= yes
+
+do-test: # tests broken: https://github.com/intel/ideep/issues/34 and assume bundled mkl-dnn
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTING:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>