aboutsummaryrefslogtreecommitdiff
path: root/math/labplot
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-09-22 18:14:59 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-09-22 18:14:59 +0000
commitf44a091f3d75de7c5812c53f6218fc73a978877c (patch)
tree7700eb6d9eef5a0000cb983e7b3e9c74b64f6800 /math/labplot
parente674ba450b5bf61a341045268975b77af9913671 (diff)
downloadports-f44a091f3d75de7c5812c53f6218fc73a978877c.tar.gz
ports-f44a091f3d75de7c5812c53f6218fc73a978877c.zip
math/labplot: update to 2.8.0
Notes
Notes: svn path=/head/; revision=549618
Diffstat (limited to 'math/labplot')
-rw-r--r--math/labplot/Makefile5
-rw-r--r--math/labplot/distinfo6
-rw-r--r--math/labplot/files/patch-git_4255438c76
-rw-r--r--math/labplot/pkg-plist79
4 files changed, 114 insertions, 52 deletions
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 0a19305d1594..fbe76c8cd597 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= labplot
-PORTVERSION= 2.7.0
-PORTREVISION= 11
+DISTVERSION= 2.8.0
CATEGORIES= math kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
@@ -20,7 +19,7 @@ LIB_DEPENDS= libgsl.so:math/gsl \
USES= bison cmake compiler:c++11-lang desktop-file-utils kde:5 qt:5 \
shared-mime-info tar:xz
-USE_KDE= archive auth bookmarks codecs completion config configwidgets \
+USE_KDE= archive attica auth bookmarks codecs completion config configwidgets \
coreaddons crash ecm_build guiaddons i18n iconthemes itemviews \
jobwidgets kdelibs4support kio newstuff notifications parts \
service solid sonnet syntaxhighlighting textwidgets unitconversion \
diff --git a/math/labplot/distinfo b/math/labplot/distinfo
index 4efa909ff3b8..2d54a1e832e5 100644
--- a/math/labplot/distinfo
+++ b/math/labplot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1572037741
-SHA256 (labplot-2.7.0.tar.xz) = 5c4d6ed7df6e98557a6b78f018933c92654b7e50e7f051ad89ec4755e0f4e935
-SIZE (labplot-2.7.0.tar.xz) = 13306532
+TIMESTAMP = 1600793535
+SHA256 (labplot-2.8.0.tar.xz) = 8957c708ea572d9b7bfd7bdd1e9627bb1e10717c4b8cb10c7687ca6ca187a705
+SIZE (labplot-2.8.0.tar.xz) = 13117804
diff --git a/math/labplot/files/patch-git_4255438c b/math/labplot/files/patch-git_4255438c
new file mode 100644
index 000000000000..2f5616ebb458
--- /dev/null
+++ b/math/labplot/files/patch-git_4255438c
@@ -0,0 +1,76 @@
+From 4255438c98ce274a4bbb381b706b6ba5b41816c7 Mon Sep 17 00:00:00 2001
+From: Stefan Gerlach <stefan.gerlach@uni-konstanz.de>
+Date: Mon, 14 Sep 2020 16:56:37 +0200
+Subject: [PATCH] [cantor] 20.08.1 still uses old code & minor formating fixes
+
+---
+ CMakeLists.txt | 2 +-
+ src/backend/gsl/parser.y | 2 +-
+ src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp | 2 +-
+ src/kdefrontend/widgets/ExpressionTextEdit.cpp | 8 ++++----
+ 4 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 33b407046..57ad46dd8 100644
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -230,7 +230,7 @@ IF (Cantor_FOUND)
+ ELSE ()
+ MESSAGE (STATUS "Cantor Library ${Cantor_VERSION} TOO OLD. Minimum usable version is 19.12")
+ ENDIF ()
+- IF (${Cantor_VERSION} VERSION_GREATER "20.08")
++ IF (${Cantor_VERSION} VERSION_GREATER "20.08.1")
+ add_definitions (-DHAVE_NEW_CANTOR_LIBS)
+ ENDIF ()
+ ELSE ()
+diff --git a/src/backend/gsl/parser.y b/src/backend/gsl/parser.y
+index e90f9f7dc..10121a741 100644
+--- src/backend/gsl/parser.y
++++ src/backend/gsl/parser.y
+@@ -265,7 +265,7 @@ int yylex(param *p) {
+ pdebug("PARSER: yylex()\n");
+ char c;
+
+- /* skip white space */
++ /* skip white space */
+ while ((c = getcharstr(p)) == ' ' || c == '\t');
+
+ /* finish if reached EOF */
+diff --git a/src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp b/src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp
+index 8492a63a2..45e6a0f5a 100644
+--- src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp
++++ src/kdefrontend/dockwidgets/XYEquationCurveDock.cpp
+@@ -71,7 +71,7 @@ void XYEquationCurveDock::setupGeneral() {
+
+ auto* gridLayout = dynamic_cast<QGridLayout*>(generalTab->layout());
+ if (gridLayout) {
+- gridLayout->setContentsMargins(2,2,2,2);
++ gridLayout->setContentsMargins(2, 2, 2, 2);
+ gridLayout->setHorizontalSpacing(2);
+ gridLayout->setVerticalSpacing(2);
+ }
+diff --git a/src/kdefrontend/widgets/ExpressionTextEdit.cpp b/src/kdefrontend/widgets/ExpressionTextEdit.cpp
+index f6d26152b..e08b352d9 100644
+--- src/kdefrontend/widgets/ExpressionTextEdit.cpp
++++ src/kdefrontend/widgets/ExpressionTextEdit.cpp
+@@ -114,13 +114,13 @@ void ExpressionTextEdit::setExpressionType(XYEquationCurve::EquationType type) {
+ m_expressionType = type;
+ m_variables.clear();
+ if (type == XYEquationCurve::EquationType::Cartesian)
+- m_variables<<"x";
++ m_variables << "x";
+ else if (type == XYEquationCurve::EquationType::Polar)
+- m_variables<<"phi";
++ m_variables << "phi";
+ else if (type == XYEquationCurve::EquationType::Parametric)
+- m_variables<<"t";
++ m_variables << "t";
+ else if (type == XYEquationCurve::EquationType::Implicit)
+- m_variables<<"x"<<"y";
++ m_variables << "x" << "y";
+
+ m_highlighter->setVariables(m_variables);
+ }
+--
+GitLab
+
diff --git a/math/labplot/pkg-plist b/math/labplot/pkg-plist
index 3742769e466b..748722482d22 100644
--- a/math/labplot/pkg-plist
+++ b/math/labplot/pkg-plist
@@ -1,7 +1,8 @@
bin/labplot2
-etc/xdg/labplot2_themes.knsrc
-man/man1/labplot2.1.gz
+man/ca/man1/labplot2.1.gz
man/es/man1/labplot2.1.gz
+man/it/man1/labplot2.1.gz
+man/man1/labplot2.1.gz
man/nl/man1/labplot2.1.gz
man/sv/man1/labplot2.1.gz
man/uk/man1/labplot2.1.gz
@@ -51,48 +52,6 @@ share/doc/HTML/en/labplot2/tutorial-xy-function8.png
share/doc/HTML/en/labplot2/tutorial-xy-function9.png
share/doc/HTML/en/labplot2/workbook.png
share/doc/HTML/en/labplot2/worksheet.png
-share/doc/HTML/es/labplot2/index.cache.bz2
-share/doc/HTML/es/labplot2/index.docbook
-share/doc/HTML/nl/labplot2/index.cache.bz2
-share/doc/HTML/nl/labplot2/index.docbook
-share/doc/HTML/sv/labplot2/index.cache.bz2
-share/doc/HTML/sv/labplot2/index.docbook
-share/doc/HTML/uk/labplot2/export_spreadsheet_dialog.png
-share/doc/HTML/uk/labplot2/export_worksheet_dialog.png
-share/doc/HTML/uk/labplot2/import-dialog.png
-share/doc/HTML/uk/labplot2/index.cache.bz2
-share/doc/HTML/uk/labplot2/index.docbook
-share/doc/HTML/uk/labplot2/labplot.png
-share/doc/HTML/uk/labplot2/matrix.png
-share/doc/HTML/uk/labplot2/matrix_function_values.png
-share/doc/HTML/uk/labplot2/pe-context-menu.png
-share/doc/HTML/uk/labplot2/project-explorer.png
-share/doc/HTML/uk/labplot2/properties.png
-share/doc/HTML/uk/labplot2/spreadsheet.png
-share/doc/HTML/uk/labplot2/spreadsheet_generate_equidistant_values.png
-share/doc/HTML/uk/labplot2/spreadsheet_generate_function_values.png
-share/doc/HTML/uk/labplot2/spreadsheet_generate_random_values.png
-share/doc/HTML/uk/labplot2/tutorial-spreadsheet1.png
-share/doc/HTML/uk/labplot2/tutorial-spreadsheet2.png
-share/doc/HTML/uk/labplot2/tutorial-spreadsheet3.png
-share/doc/HTML/uk/labplot2/tutorial-spreadsheet4.png
-share/doc/HTML/uk/labplot2/tutorial-spreadsheet5.png
-share/doc/HTML/uk/labplot2/tutorial-spreadsheet6.png
-share/doc/HTML/uk/labplot2/tutorial-spreadsheet7.png
-share/doc/HTML/uk/labplot2/tutorial-spreadsheet8.png
-share/doc/HTML/uk/labplot2/tutorial-spreadsheet9.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function1.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function10.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function2.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function3.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function4.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function5.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function6.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function7.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function8.png
-share/doc/HTML/uk/labplot2/tutorial-xy-function9.png
-share/doc/HTML/uk/labplot2/workbook.png
-share/doc/HTML/uk/labplot2/worksheet.png
share/icons/hicolor/128x128/apps/labplot2.png
share/icons/hicolor/16x16/apps/labplot2.png
share/icons/hicolor/22x22/apps/labplot2.png
@@ -113,16 +72,20 @@ share/icons/hicolor/scalable/apps/labplot-auto-scale-x.svg
share/icons/hicolor/scalable/apps/labplot-auto-scale-y.svg
share/icons/hicolor/scalable/apps/labplot-axis-horizontal.svg
share/icons/hicolor/scalable/apps/labplot-axis-vertical.svg
+share/icons/hicolor/scalable/apps/labplot-back.svg
share/icons/hicolor/scalable/apps/labplot-cursor-arrow.svg
share/icons/hicolor/scalable/apps/labplot-editbreaklayout.svg
share/icons/hicolor/scalable/apps/labplot-editgrid.svg
share/icons/hicolor/scalable/apps/labplot-edithlayout.svg
share/icons/hicolor/scalable/apps/labplot-editvlayout.svg
share/icons/hicolor/scalable/apps/labplot-format-text-symbol.svg
+share/icons/hicolor/scalable/apps/labplot-forward.svg
share/icons/hicolor/scalable/apps/labplot-json-array.svg
share/icons/hicolor/scalable/apps/labplot-json-object.svg
share/icons/hicolor/scalable/apps/labplot-matrix-new.svg
share/icons/hicolor/scalable/apps/labplot-matrix.svg
+share/icons/hicolor/scalable/apps/labplot-maximize.svg
+share/icons/hicolor/scalable/apps/labplot-minimize.svg
share/icons/hicolor/scalable/apps/labplot-plot-axis-points.svg
share/icons/hicolor/scalable/apps/labplot-shift-down-y.svg
share/icons/hicolor/scalable/apps/labplot-shift-left-x.svg
@@ -167,7 +130,31 @@ share/kxmlgui5/labplot2/labplot2ui.rc
%%DATADIR%%/color-schemes/WontonSoup.colors
%%DATADIR%%/color-schemes/Zion.colors
%%DATADIR%%/color-schemes/ZionReversed.colors
+%%DATADIR%%/datasets/DASL.json
+%%DATADIR%%/datasets/DatasetCategories.json
+%%DATADIR%%/datasets/DatasetCollections.json
+%%DATADIR%%/datasets/JSEDataArchive.json
+%%DATADIR%%/datasets/OzDASL.json
+%%DATADIR%%/datasets/README.md
+%%DATADIR%%/datasets/Rdatasets.json
+%%DATADIR%%/datasets/Socrata.json
+%%DATADIR%%/datasets/StatLib.json
+%%DATADIR%%/example_projects/Big-city-pop.lml
+%%DATADIR%%/example_projects/Rainfall.lml
+%%DATADIR%%/example_projects/acc-deaths.lml
+%%DATADIR%%/example_projects/alcohol-cons.lml
+%%DATADIR%%/example_projects/cat-weight.lml
+%%DATADIR%%/example_projects/cooling-water.lml
+%%DATADIR%%/example_projects/example_projects.json
+%%DATADIR%%/example_projects/fit (Anscombe's quartet).lml
+%%DATADIR%%/example_projects/lake-level.lml
+%%DATADIR%%/example_projects/log_scales.lml
+%%DATADIR%%/example_projects/magnitude_plot.lml
+%%DATADIR%%/example_projects/mathematical_functions.lml
+%%DATADIR%%/example_projects/weight-height.lml
+%%DATADIR%%/example_projects/weight-speed.lml
%%DATADIR%%/labplot2.ico
+%%DATADIR%%/latex/preview.sty
%%DATADIR%%/pics/colorchooser/colorchooser_hue.xpm
%%DATADIR%%/pics/colorchooser/colorchooser_saturation.xpm
%%DATADIR%%/pics/colorchooser/colorchooser_value.xpm
@@ -261,6 +248,7 @@ share/kxmlgui5/labplot2/labplot2ui.rc
%%DATADIR%%/themes/Creme
%%DATADIR%%/themes/Dark
%%DATADIR%%/themes/DarkPastels
+%%DATADIR%%/themes/Default
%%DATADIR%%/themes/GreenOnBlack
%%DATADIR%%/themes/GreyOnBlack
%%DATADIR%%/themes/GreySlate
@@ -274,6 +262,7 @@ share/kxmlgui5/labplot2/labplot2ui.rc
%%DATADIR%%/themes/screenshots/Creme.png
%%DATADIR%%/themes/screenshots/Dark.png
%%DATADIR%%/themes/screenshots/DarkPastels.png
+%%DATADIR%%/themes/screenshots/Default.png
%%DATADIR%%/themes/screenshots/GreenOnBlack.png
%%DATADIR%%/themes/screenshots/GreyOnBlack.png
%%DATADIR%%/themes/screenshots/GreySlate.png
@@ -296,8 +285,6 @@ share/locale/fr/LC_MESSAGES/labplot2.mo
share/locale/gl/LC_MESSAGES/labplot2.mo
share/locale/hu/LC_MESSAGES/labplot2.mo
share/locale/it/LC_MESSAGES/labplot2.mo
-share/locale/ja/LC_MESSAGES/labplot2.mo
-share/locale/lt/LC_MESSAGES/labplot2.mo
share/locale/nds/LC_MESSAGES/labplot2.mo
share/locale/nl/LC_MESSAGES/labplot2.mo
share/locale/pl/LC_MESSAGES/labplot2.mo