aboutsummaryrefslogtreecommitdiff
path: root/math/lapack++
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
commit564a799c7173c288d4d3a9be78ac3d2db983d512 (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /math/lapack++
parentaf1790bfbbcd5831281907db9c04f3776b8d601c (diff)
downloadports-564a799c7173c288d4d3a9be78ac3d2db983d512.tar.gz
ports-564a799c7173c288d4d3a9be78ac3d2db983d512.zip
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=344614
Diffstat (limited to 'math/lapack++')
-rw-r--r--math/lapack++/Makefile6
-rw-r--r--math/lapack++/files/patch-configure11
-rw-r--r--math/lapack++/files/patch-src-genmd.cc10
3 files changed, 23 insertions, 4 deletions
diff --git a/math/lapack++/Makefile b/math/lapack++/Makefile
index 7d314d83dfeb..cb5bbadee8fd 100644
--- a/math/lapack++/Makefile
+++ b/math/lapack++/Makefile
@@ -3,7 +3,7 @@
PORTNAME= lapack++
PORTVERSION= 2.5.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MASTER_SITES= SF/lapackpp/lapackpp/${PORTVERSION} \
http://math.nist.gov/lapack++/:doc
@@ -19,8 +19,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= maho@FreeBSD.org
COMMENT= Linear Algebra PACKage in C++, a wrapper for LAPACK
-WANT_GNOME= yes
-USES= pathfix gmake
+USES= fortran gmake pathfix
NO_STAGE= yes
.include <bsd.port.pre.mk>
@@ -35,7 +34,6 @@ LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
.endif
-USE_FORTRAN= yes
GNU_CONFIGURE= yes
.if defined(WITH_ATLAS)
BLAS_LIB= -L${LOCALBASE}/lib -lf77blas
diff --git a/math/lapack++/files/patch-configure b/math/lapack++/files/patch-configure
new file mode 100644
index 000000000000..9055b19b0c1d
--- /dev/null
+++ b/math/lapack++/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig
++++ configure
+@@ -26093,7 +26093,7 @@
+ *)
+ ARCH="OS_${target_os}"
+ # Workaround for bogus system names
+- ARCH=` echo ${ARCH} | ${SED} 's/^a-z0-9_//g' `
++ ARCH=` echo ${ARCH} | ${SED} 's/[^A-Za-z0-9_]//g' `
+ ;;
+ esac
+ { echo "$as_me:$LINENO: result: $ARCH" >&5
diff --git a/math/lapack++/files/patch-src-genmd.cc b/math/lapack++/files/patch-src-genmd.cc
new file mode 100644
index 000000000000..bba2c18e1117
--- /dev/null
+++ b/math/lapack++/files/patch-src-genmd.cc
@@ -0,0 +1,10 @@
+--- src/genmd.cc.orig
++++ src/genmd.cc
+@@ -65,7 +65,6 @@
+ }
+
+ #if !(defined(OS_WIN32) || LAPACK_OS_WIN32)
+-extern "C" double drand48(void) throw ();
+ #endif
+
+ LaGenMatDouble& LaRandUniform(LaGenMatDouble &A,