aboutsummaryrefslogtreecommitdiff
path: root/math/latte-integrale
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-06 05:57:36 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-06 05:57:36 +0000
commit9d59366e310fda2b5da380666b59805bba219b54 (patch)
tree377d6e92dc099e116d37e5c611e201a89ccec4cf /math/latte-integrale
parent73faaaa2fb40ba60d03a6e5a550d10375b0c85c9 (diff)
downloadports-9d59366e310fda2b5da380666b59805bba219b54.tar.gz
ports-9d59366e310fda2b5da380666b59805bba219b54.zip
New port: math/latte-integrale: Software for counting lattice points/integration over convex polytopes
Notes
Notes: svn path=/head/; revision=486735
Diffstat (limited to 'math/latte-integrale')
-rw-r--r--math/latte-integrale/Makefile39
-rw-r--r--math/latte-integrale/distinfo3
-rw-r--r--math/latte-integrale/files/patch-EXAMPLES_Makefile.am9
-rw-r--r--math/latte-integrale/files/patch-Makefile.am14
-rw-r--r--math/latte-integrale/files/patch-code_maple_Makefile.am8
-rw-r--r--math/latte-integrale/files/patch-configure.ac11
-rw-r--r--math/latte-integrale/files/patch-doc_Makefile.am8
-rw-r--r--math/latte-integrale/pkg-descr12
-rw-r--r--math/latte-integrale/pkg-plist25
9 files changed, 129 insertions, 0 deletions
diff --git a/math/latte-integrale/Makefile b/math/latte-integrale/Makefile
new file mode 100644
index 000000000000..880839dcfcda
--- /dev/null
+++ b/math/latte-integrale/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= latte-integrale
+DISTVERSIONPREFIX= version_
+DISTVERSION= 1_7_5
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Software for counting lattice points/integration over convex polytopes
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lrs:math/lrslib \
+ points2triangs:math/topcom
+LIB_DEPENDS= lib4ti2util.so:math/4ti2 \
+ libcddgmp.so:math/cddlib \
+ libgmp.so:math/gmp \
+ libntl.so:math/ntl
+RUN_DEPENDS= lrs:math/lrslib \
+ points2triangs:math/topcom
+
+USES= autoreconf gmake libtool localbase:ldflags
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static \
+ --with-topcom=${LOCALBASE} --with-4ti2=${LOCALBASE} --with-cddlib=${LOCALBASE} --with-gmp=${LOCALBASE} --with-ntl=${LOCALBASE}
+USE_GITHUB= yes
+GH_ACCOUNT= latte-int
+GH_PROJECT= latte
+USE_LDCONFIG= yes
+
+CONFLICTS_INSTALL= latte
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+.include <bsd.port.mk>
diff --git a/math/latte-integrale/distinfo b/math/latte-integrale/distinfo
new file mode 100644
index 000000000000..7dcbbc50a86c
--- /dev/null
+++ b/math/latte-integrale/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543993357
+SHA256 (latte-int-latte-version_1_7_5_GH0.tar.gz) = 3da7cff7e451a12b29f5df28456367f66cd0092437e88aca5e61cc3f13eaa91c
+SIZE (latte-int-latte-version_1_7_5_GH0.tar.gz) = 9772961
diff --git a/math/latte-integrale/files/patch-EXAMPLES_Makefile.am b/math/latte-integrale/files/patch-EXAMPLES_Makefile.am
new file mode 100644
index 000000000000..287c844d6b6b
--- /dev/null
+++ b/math/latte-integrale/files/patch-EXAMPLES_Makefile.am
@@ -0,0 +1,9 @@
+--- EXAMPLES/Makefile.am.orig 2018-12-05 08:27:21 UTC
++++ EXAMPLES/Makefile.am
+@@ -1,5 +1,5 @@
+
+-examplesdir = $(pkgdatadir)/examples
++examplesdir = $(prefix)/share/examples/latte-integrale
+
+ # Install and distribute these examples.
+ # Without "nobase" the directories would be flattened
diff --git a/math/latte-integrale/files/patch-Makefile.am b/math/latte-integrale/files/patch-Makefile.am
new file mode 100644
index 000000000000..752a4c588ee7
--- /dev/null
+++ b/math/latte-integrale/files/patch-Makefile.am
@@ -0,0 +1,14 @@
+--- Makefile.am.orig 2018-12-05 08:20:55 UTC
++++ Makefile.am
+@@ -2,9 +2,9 @@ ACLOCAL_AMFLAGS = -I m4 -I m4/gnulib
+
+ SUBDIRS = code EXAMPLES doc
+
+-docdir = $(pkgdatadir)/doc
++docdir = ${prefix}/share/doc/latte-integrale
+
+-dist_doc_DATA = NEWS README
++dist_doc_DATA = # NEWS README
+
+
+ cvstag:
diff --git a/math/latte-integrale/files/patch-code_maple_Makefile.am b/math/latte-integrale/files/patch-code_maple_Makefile.am
new file mode 100644
index 000000000000..c566e3ca96ec
--- /dev/null
+++ b/math/latte-integrale/files/patch-code_maple_Makefile.am
@@ -0,0 +1,8 @@
+--- code/maple/Makefile.am.orig 2018-12-05 22:17:29 UTC
++++ code/maple/Makefile.am
+@@ -1,4 +1,4 @@
+-nobase_dist_pkgdata_DATA = \
++#nobase_dist_pkgdata_DATA = \
+ Conebyconeapproximations_08_11_2010.mpl RealBarvinok-mars-exemples-2014-03-10.mpl m-knapsack.mpl \
+ README
+
diff --git a/math/latte-integrale/files/patch-configure.ac b/math/latte-integrale/files/patch-configure.ac
new file mode 100644
index 000000000000..d1cd3ac9529e
--- /dev/null
+++ b/math/latte-integrale/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2018-12-05 08:19:48 UTC
++++ configure.ac
+@@ -2,7 +2,7 @@
+ # Process this file with autoconf to produce a configure script.
+
+ AC_PREREQ(2.59)
+-AC_INIT(latte-int, 1.7.5)
++AC_INIT(latte-integrale, 1.7.5)
+ AC_CONFIG_MACRO_DIR([m4])
+ AC_CONFIG_HEADERS([code/config.h:code/config.hin])
+ AM_INIT_AUTOMAKE([gnu 1.11]) # Need 1.11 for parallel test harness in code/maple
diff --git a/math/latte-integrale/files/patch-doc_Makefile.am b/math/latte-integrale/files/patch-doc_Makefile.am
new file mode 100644
index 000000000000..532a84b10c8a
--- /dev/null
+++ b/math/latte-integrale/files/patch-doc_Makefile.am
@@ -0,0 +1,8 @@
+--- doc/Makefile.am.orig 2018-12-05 22:18:20 UTC
++++ doc/Makefile.am
+@@ -1,4 +1,4 @@
+-docdir = $(pkgdatadir)/doc
++docdir = $(prefix)/share/doc/latte-integrale
+
+ doc_DATA = manual.pdf
+
diff --git a/math/latte-integrale/pkg-descr b/math/latte-integrale/pkg-descr
new file mode 100644
index 000000000000..74b3a71ce894
--- /dev/null
+++ b/math/latte-integrale/pkg-descr
@@ -0,0 +1,12 @@
+LattE (Lattice point Enumeration) is a computer software dedicated to the
+problems of counting lattice points and integration inside convex polytopes.
+LattE contains the first ever implementation of Barvinok's algorithm. The LattE
+macchiato version (by M. Koppe) incorporated fundamental improvements and
+speedups.
+
+LattE integrale, the latest version, has the ability to directly compute
+integrals of polynomial functions over polytopes and in particular to do exact
+volume computations. Version 1.6 adds the capability of computing the highest
+coefficients of weighted Ehrhart quasipolynomials.
+
+WWW: https://www.math.ucdavis.edu/~latte/
diff --git a/math/latte-integrale/pkg-plist b/math/latte-integrale/pkg-plist
new file mode 100644
index 000000000000..c8e85647d6de
--- /dev/null
+++ b/math/latte-integrale/pkg-plist
@@ -0,0 +1,25 @@
+bin/ConvertCDDextToLatte
+bin/ConvertCDDineToLatte
+bin/count
+bin/count-linear-forms-from-polynomial
+bin/ehrhart
+bin/ehrhart3
+bin/hilbert-from-rays
+bin/hilbert-from-rays-symm
+bin/integrate
+bin/latte-maximize
+bin/latte-minimize
+bin/latte2ext
+bin/latte2ine
+bin/polyhedron-to-cones
+bin/top-ehrhart-knapsack
+bin/triangulate
+lib/liblatte.so
+lib/liblatte.so.0
+lib/liblatte.so.0.0.0
+lib/libnormalize.so
+lib/libnormalize.so.0
+lib/libnormalize.so.0.0.0
+%%DATADIR%%/simplify.add
+%%DATADIR%%/simplify2.add
+%%DATADIR%%/simplify3.add