aboutsummaryrefslogtreecommitdiff
path: root/math/libRmath/Makefile
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2017-12-03 03:46:11 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2017-12-03 03:46:11 +0000
commitde876a285d0f54863a31dbbfa628af80161d609b (patch)
treec4983f64b4136075249b4c8e3c698417ffe4e482 /math/libRmath/Makefile
parent75ec601f79de3144a1f4407b93e1eb89f9777d3e (diff)
downloadports-de876a285d0f54863a31dbbfa628af80161d609b.tar.gz
ports-de876a285d0f54863a31dbbfa628af80161d609b.zip
math/libRmath: Update to version 3.4.3 and add armv[67] to ONLY_FOR_ARCHS
Notes
Notes: svn path=/head/; revision=455388
Diffstat (limited to 'math/libRmath/Makefile')
-rw-r--r--math/libRmath/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/math/libRmath/Makefile b/math/libRmath/Makefile
index 913fddfa9340..ba007c01ef90 100644
--- a/math/libRmath/Makefile
+++ b/math/libRmath/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libRmath
-DISTVERSION= 3.4.2
-PORTREVISION= 2
+DISTVERSION= 3.4.3
CATEGORIES= math lang
MASTER_SITES= CRAN/src/base/R-${PORTVERSION:C|\..*||}
DISTNAME= R-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
@@ -13,7 +12,8 @@ COMMENT= Standalone math library from R
LICENSE= GPLv2
-ONLY_FOR_ARCHS= aarch64 amd64 i386
+BROKEN_FreeBSD_10_armv6= Fails to build
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386
LIB_DEPENDS= libcurl.so:ftp/curl \
libpcre.so:devel/pcre
@@ -32,7 +32,9 @@ USE_LDCONFIG= yes
PLIST_SUB= RMATH_SOVERSION="${RMATH_SOVERSION}"
OPTIONS_DEFINE= FLANG
-OPTIONS_EXCLUDE_aarch64=FLANG
+OPTIONS_EXCLUDE_aarch64= FLANG
+OPTIONS_EXCLUDE_armv6= FLANG
+OPTIONS_EXCLUDE_armv7= FLANG
OPTIONS_EXCLUDE_i386= FLANG
FLANG_DESC= Use flang instead of the default Fortran compiler