aboutsummaryrefslogtreecommitdiff
path: root/math/ltl2ba/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-05-27 18:11:32 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-05-27 18:11:32 +0000
commitdc711f5047a170fc538e72f013ff1eeb838ac1f7 (patch)
tree40dcae70a6dd4c7e6181bead6f4c360adb7fb2ea /math/ltl2ba/Makefile
parent55452e601aee06d7e661223420d628c27e0c21e6 (diff)
downloadports-dc711f5047a170fc538e72f013ff1eeb838ac1f7.tar.gz
ports-dc711f5047a170fc538e72f013ff1eeb838ac1f7.zip
Add ltl2ba 1.1, fast translation from LTL formulae to Buechi automata.
Notes
Notes: svn path=/head/; revision=274737
Diffstat (limited to 'math/ltl2ba/Makefile')
-rw-r--r--math/ltl2ba/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/ltl2ba/Makefile b/math/ltl2ba/Makefile
new file mode 100644
index 000000000000..03bda7785bee
--- /dev/null
+++ b/math/ltl2ba/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ltl2ba
+# Date created: 25 May 2011
+# Whom: b.f. <bf@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ltl2ba
+PORTVERSION= 1.1
+CATEGORIES= math
+MASTER_SITES= http://www.lsv.ens-cachan.fr/~gastin/ltl2ba/ LOCAL/bf
+
+MAINTAINER= bf@FreeBSD.org
+COMMENT= Fast translation from LTL formulae to Buechi automata
+
+LICENSE= GPLv2
+
+ALL_TARGET= ltl2ba
+CFLAGS+= -DNXT
+PLIST_FILES= bin/ltl2ba
+
+post-patch:
+ ${REINPLACE_CMD} -e '/^CC=/d' -e '/^CFLAGS=/d' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ltl2ba ${PREFIX}/bin/
+
+.include <bsd.port.mk>