aboutsummaryrefslogtreecommitdiff
path: root/math/metis
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-10-10 05:40:57 +0000
committerSteve Price <steve@FreeBSD.org>1998-10-10 05:40:57 +0000
commit98744c8279d1f5885517de2a80ac4fea42baf9e0 (patch)
tree59639d407e3926b948619538718da0dbcc36618f /math/metis
parent7f19f8c2d6152f67cc8d5e8483f1a3e691514093 (diff)
downloadports-98744c8279d1f5885517de2a80ac4fea42baf9e0.tar.gz
ports-98744c8279d1f5885517de2a80ac4fea42baf9e0.zip
Update to version 4.0.
PR: 8243 Submitted by: old maintainer
Notes
Notes: svn path=/head/; revision=13840
Diffstat (limited to 'math/metis')
-rw-r--r--math/metis/Makefile8
-rw-r--r--math/metis/distinfo2
-rw-r--r--math/metis/files/patch-aa73
-rw-r--r--math/metis/files/patch-ab56
-rw-r--r--math/metis/files/patch-ac30
-rw-r--r--math/metis/files/patch-ad30
6 files changed, 125 insertions, 74 deletions
diff --git a/math/metis/Makefile b/math/metis/Makefile
index b8c9952acce0..959bd95b90b8 100644
--- a/math/metis/Makefile
+++ b/math/metis/Makefile
@@ -1,16 +1,16 @@
# New ports collection makefile for: METIS
-# Version required: 3.0
+# Version required: 4.0
# Date created: 26 Oct 97
# Whom: Pedro Giffuni <giffunip@asme.org>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/04/26 03:55:22 mph Exp $
#
-DISTNAME= metis-3.0
+DISTNAME= metis-4.0
CATEGORIES= math
MASTER_SITES= http://www.cs.umn.edu/~karypis/metis/metis/files/
-MAINTAINER= giffunip@asme.org
+MAINTAINER= ports@FreeBSD.org
ALL_TARGET=
diff --git a/math/metis/distinfo b/math/metis/distinfo
index 53594c543e3b..f5f67327e6ca 100644
--- a/math/metis/distinfo
+++ b/math/metis/distinfo
@@ -1 +1 @@
-MD5 (metis-3.0.tar.gz) = f547a7e503f497de29e1e54c1c13e91e
+MD5 (metis-4.0.tar.gz) = d8e46ff88441800fb0782b61b99048ff
diff --git a/math/metis/files/patch-aa b/math/metis/files/patch-aa
index 702a963c2189..631f79263f9e 100644
--- a/math/metis/files/patch-aa
+++ b/math/metis/files/patch-aa
@@ -1,27 +1,46 @@
---- Makefile.in.orig Sat Apr 25 23:41:58 1998
-+++ Makefile.in Sat Apr 25 23:43:23 1998
-@@ -1,9 +1,9 @@
-
- # Which compiler to use
--CC = cc
-+# CC = cc
-
- # What optimization level to use
--OPTFLAGS = -O2
-+# OPTFLAGS = -O2
-
- # What options to be used by the compiler
- COPTIONS =
-@@ -12,10 +12,10 @@
- LDOPTIONS =
-
- # What archiving to use
--AR = ar rv
-+# AR = ar rv
-
- # What to use for indexing the archive
--RANLIB = ranlib
-+# RANLIB = ranlib
- # RANLIB = ar -ts
- # RANLIB =
-
+*** Makefile.in.orig Fri Oct 9 20:16:24 1998
+--- Makefile.in Fri Oct 9 20:17:42 1998
+***************
+*** 1,9 ****
+
+ # Which compiler to use
+! CC = cc
+
+ # What optimization level to use
+! OPTFLAGS = -O2
+
+ # What options to be used by the compiler
+ COPTIONS =
+--- 1,9 ----
+
+ # Which compiler to use
+! # CC = cc
+
+ # What optimization level to use
+! # OPTFLAGS = -O2
+
+ # What options to be used by the compiler
+ COPTIONS =
+***************
+*** 12,21 ****
+ LDOPTIONS =
+
+ # What archiving to use
+! AR = ar rv
+
+ # What to use for indexing the archive
+! RANLIB = ranlib
+ # RANLIB = ar -ts
+ # RANLIB =
+
+--- 12,21 ----
+ LDOPTIONS =
+
+ # What archiving to use
+! # AR = ar rv
+
+ # What to use for indexing the archive
+! # RANLIB = ranlib
+ # RANLIB = ar -ts
+ # RANLIB =
+
diff --git a/math/metis/files/patch-ab b/math/metis/files/patch-ab
index 659723570fd9..4b0d3c27f638 100644
--- a/math/metis/files/patch-ab
+++ b/math/metis/files/patch-ab
@@ -1,20 +1,36 @@
---- Lib/Makefile.orig Sat Apr 25 23:43:54 1998
-+++ Lib/Makefile Sat Apr 25 23:44:31 1998
-@@ -2,7 +2,7 @@
-
- INCLUDES = -I./
-
--CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
-+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
- LD = $(CC) -L./
-
-
-@@ -17,7 +17,7 @@
- $(CC) $(CFLAGS) -c $*.c
-
- ../libmetis.a: $(OBJS)
-- $(AR) $@ $(OBJS)
-+ $(AR) $(ARFLAGS) $@ $(OBJS)
- $(RANLIB) $@
-
- checkin:
+*** Lib/Makefile.orig Fri Oct 9 20:19:01 1998
+--- Lib/Makefile Fri Oct 9 20:20:32 1998
+***************
+*** 2,8 ****
+
+ INCLUDES = -I.
+
+! CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+ LD = $(CC) -L.
+
+
+--- 2,8 ----
+
+ INCLUDES = -I.
+
+! CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+ LD = $(CC) -L.
+
+
+***************
+*** 21,27 ****
+ $(CC) $(CFLAGS) -c $*.c
+
+ ../libmetis.a: $(OBJS)
+! $(AR) $@ $(OBJS)
+ $(RANLIB) $@
+
+ clean:
+--- 21,27 ----
+ $(CC) $(CFLAGS) -c $*.c
+
+ ../libmetis.a: $(OBJS)
+! $(AR) $(ARFLAGS) $@ $(OBJS)
+ $(RANLIB) $@
+
+ clean:
diff --git a/math/metis/files/patch-ac b/math/metis/files/patch-ac
index dca2c7789b18..1bb1f4662175 100644
--- a/math/metis/files/patch-ac
+++ b/math/metis/files/patch-ac
@@ -1,11 +1,19 @@
---- Programs/Makefile.orig Sat Apr 25 23:44:50 1998
-+++ Programs/Makefile Sat Apr 25 23:46:35 1998
-@@ -3,7 +3,7 @@
- BINDIR = ..
-
- INCLUDES = -I../Lib
--CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
-+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
-
- LIBS = -lmetis -lm
- LD = $(CC) $(LDOPTIONS) -L./ -L../
+*** Programs/Makefile.orig Fri Oct 9 20:21:48 1998
+--- Programs/Makefile Fri Oct 9 20:22:16 1998
+***************
+*** 3,9 ****
+ BINDIR = ..
+
+ INCLUDES = -I../Lib
+! CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+
+ LIBS = -lmetis -lm
+ LD = $(CC) $(LDOPTIONS) -L. -L..
+--- 3,9 ----
+ BINDIR = ..
+
+ INCLUDES = -I../Lib
+! CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+
+ LIBS = -lmetis -lm
+ LD = $(CC) $(LDOPTIONS) -L. -L..
diff --git a/math/metis/files/patch-ad b/math/metis/files/patch-ad
index 05210eefcaff..0e0032718205 100644
--- a/math/metis/files/patch-ad
+++ b/math/metis/files/patch-ad
@@ -1,11 +1,19 @@
---- Test/Makefile.orig Sat Apr 25 23:46:45 1998
-+++ Test/Makefile Sat Apr 25 23:46:53 1998
-@@ -3,7 +3,7 @@
- BINDIR = ./
-
- INCLUDES = -I../Lib
--CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
-+CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
-
- LIBS = -lmetis -lm
- LD = $(CC) $(LDOPTIONS) -L../
+*** Test/Makefile.orig Fri Oct 9 20:23:24 1998
+--- Test/Makefile Fri Oct 9 20:23:40 1998
+***************
+*** 3,9 ****
+ BINDIR = ../Graphs
+
+ INCLUDES = -I../Lib
+! CFLAGS = $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+
+ LIBS = -lmetis -lm
+ LD = $(CC) $(LDOPTIONS) -L. -L..
+--- 3,9 ----
+ BINDIR = ../Graphs
+
+ INCLUDES = -I../Lib
+! CFLAGS += $(COPTIONS) $(OPTFLAGS) $(INCLUDES)
+
+ LIBS = -lmetis -lm
+ LD = $(CC) $(LDOPTIONS) -L. -L..