aboutsummaryrefslogtreecommitdiff
path: root/math/moab
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-17 07:39:18 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-17 07:39:18 +0000
commitdeb6e8c8fe1cd1de3eff1af1067f9d6b7227170e (patch)
tree2dd859db5ab3acaadc18841c83360fb17666c2da /math/moab
parent22f97c847c7c1346388f156afacffdf6c213fbef (diff)
downloadports-deb6e8c8fe1cd1de3eff1af1067f9d6b7227170e.tar.gz
ports-deb6e8c8fe1cd1de3eff1af1067f9d6b7227170e.zip
math/moab: fix build with GCC
Add USES=compiler:c++11-lang to fix: CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message): Could NOT find MPI (missing: MPI_CXX_FOUND) (found version "3.0") Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=506793
Diffstat (limited to 'math/moab')
-rw-r--r--math/moab/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/moab/Makefile b/math/moab/Makefile
index 16e77031e44b..f85060c6a408 100644
--- a/math/moab/Makefile
+++ b/math/moab/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libnetcdf.so:science/netcdf \
libopenblas.so:math/openblas
-USES= cmake:noninja eigen:3 fortran
+USES= cmake:noninja compiler:c++11-lang eigen:3 fortran
USE_LDCONFIG= yes
CMAKE_ARGS= -DBLAS_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so -DLAPACK_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so