aboutsummaryrefslogtreecommitdiff
path: root/math/moab
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-24 03:10:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-24 03:10:29 +0000
commited411ada6fd23e1dd9363b7f96786df9ecbb66a8 (patch)
tree22cd8730c2cf8518ca045b5b8e3a7fd74fe1c9cd /math/moab
parent639192571f9299f3ec5113a89f42398afe33893d (diff)
downloadports-ed411ada6fd23e1dd9363b7f96786df9ecbb66a8.tar.gz
ports-ed411ada6fd23e1dd9363b7f96786df9ecbb66a8.zip
math/moab: Update 4.6.3 -> 5.0.0
Port changes: * Change MASTER_SITES to bitbucket where official releases are * Change to CMAKE * Add MPI option * Fix WWW Reported by: portscout
Notes
Notes: svn path=/head/; revision=485723
Diffstat (limited to 'math/moab')
-rw-r--r--math/moab/Makefile26
-rw-r--r--math/moab/distinfo6
-rw-r--r--math/moab/files/patch-configure.ac12
-rw-r--r--math/moab/files/patch-src_io_NCHelper.cpp11
-rw-r--r--math/moab/files/patch-src_io_ReadABAQUS.cpp11
-rw-r--r--math/moab/files/patch-src_io_WriteNCDF.cpp8
-rw-r--r--math/moab/pkg-descr2
-rw-r--r--math/moab/pkg-plist97
8 files changed, 74 insertions, 99 deletions
diff --git a/math/moab/Makefile b/math/moab/Makefile
index fe36c191b46e..83f9edac4767 100644
--- a/math/moab/Makefile
+++ b/math/moab/Makefile
@@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= moab
-DISTVERSION= 4.6.3
+DISTVERSION= 5.0.0
CATEGORIES= math
-MASTER_SITES= http://ftp.mcs.anl.gov/pub/fathom/
+MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
MAINTAINER= yuri@FreeBSD.org
COMMENT= Component for representing and evaluating mesh data
@@ -12,15 +12,25 @@ LICENSE= BSD2CLAUSE
xLICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libhdf5.so:science/hdf5 \
- libnetcdf.so:science/netcdf
+ libnetcdf.so:science/netcdf \
+ libopenblas.so:math/openblas
-USES= autoreconf gmake libtool localbase:ldflags
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-static --with-netcdf=${LOCALBASE}
+USES= cmake:outsource,noninja eigen:3 fortran
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOCS
+CMAKE_ARGS= -DBLAS_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so -DLAPACK_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so
-PORTDOCS= *
+BB_ACCOUNT= fathomteam
+BB_PROJECT= ${PORTNAME}
+BB_COMMIT= c4eed56fd6d2
+
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+
+OPTIONS_DEFINE= MPI
+OPTIONS_DEFAULT= MPI
+OPTIONS_SUB= yes
+
+MPI_CMAKE_BOOL= ENABLE_MPI
+MPI_LIB_DEPENDS= libmpi.so:net/openmpi
.include <bsd.port.mk>
diff --git a/math/moab/distinfo b/math/moab/distinfo
index e6b9701ae78d..e7470b2d8c0e 100644
--- a/math/moab/distinfo
+++ b/math/moab/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1541374760
-SHA256 (moab-4.6.3.tar.gz) = a25933254a05013811d3769e5d96b01cc7b5d67026acacbaae4f3568ce18fd7f
-SIZE (moab-4.6.3.tar.gz) = 21861257
+TIMESTAMP = 1543026884
+SHA256 (moab-5.0.0.tar.gz) = 80fd376e71bc40b1cdf1c5ebd9c14e8cfe185e7554ff352431cbcb82a44920e3
+SIZE (moab-5.0.0.tar.gz) = 12370425
diff --git a/math/moab/files/patch-configure.ac b/math/moab/files/patch-configure.ac
deleted file mode 100644
index 6d6a7718c8fe..000000000000
--- a/math/moab/files/patch-configure.ac
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.ac.orig 2018-11-05 00:30:52 UTC
-+++ configure.ac
-@@ -31,7 +31,8 @@ LIBS="$LIBS -lm"
-
- AC_PROG_LN_S
- AC_PROG_MAKE_SET
--AC_DISABLE_SHARED
-+AC_ENABLE_SHARED
-+AC_DISABLE_STATIC
- AC_PROG_LIBTOOL
- FATHOM_COMPILER_FLAGS
- m4_ifdef([AM_SILENT_RULES],[
diff --git a/math/moab/files/patch-src_io_NCHelper.cpp b/math/moab/files/patch-src_io_NCHelper.cpp
deleted file mode 100644
index 1a00dedf38c6..000000000000
--- a/math/moab/files/patch-src_io_NCHelper.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/io/NCHelper.cpp.orig 2018-11-05 01:48:41 UTC
-+++ src/io/NCHelper.cpp
-@@ -714,7 +714,7 @@ ErrorCode NCHelper::get_tag_to_set(ReadN
- rval = mbImpl->tag_get_handle(tag_name.str().c_str(), 0, MB_TYPE_INTEGER, tagh, MB_TAG_CREAT | MB_TAG_SPARSE | MB_TAG_VARLEN);
- break;
- default:
-- std::cerr << "Unrecognized data type for tag " << tag_name << std::endl;
-+ std::cerr << "Unrecognized data type for tag " << tag_name.str() << std::endl;
- rval = MB_FAILURE;
- }
-
diff --git a/math/moab/files/patch-src_io_ReadABAQUS.cpp b/math/moab/files/patch-src_io_ReadABAQUS.cpp
deleted file mode 100644
index 335fd11e5769..000000000000
--- a/math/moab/files/patch-src_io_ReadABAQUS.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/io/ReadABAQUS.cpp.orig 2018-11-04 23:41:08 UTC
-+++ src/io/ReadABAQUS.cpp
-@@ -105,7 +105,7 @@ void ReadABAQUS::reset()
- ReadABAQUS::~ReadABAQUS()
- {
- mdbImpl->release_interface(readMeshIface);
-- if (NULL != abFile)
-+ if (abFile.is_open())
- abFile.close();
- }
-
diff --git a/math/moab/files/patch-src_io_WriteNCDF.cpp b/math/moab/files/patch-src_io_WriteNCDF.cpp
index 36e804036893..8c91cad073bb 100644
--- a/math/moab/files/patch-src_io_WriteNCDF.cpp
+++ b/math/moab/files/patch-src_io_WriteNCDF.cpp
@@ -1,13 +1,13 @@
---- src/io/WriteNCDF.cpp.orig 2018-11-05 01:47:40 UTC
+--- src/io/WriteNCDF.cpp.orig 2018-11-23 06:26:09 UTC
+++ src/io/WriteNCDF.cpp
-@@ -154,8 +154,8 @@ void WriteNCDF::time_and_date(char* time
+@@ -161,8 +161,8 @@ void WriteNCDF::time_and_date(char* time
strftime(date_string, TIME_STR_LEN, "%m/%d/%Y", local_time);
- // terminate with NULL character
+ // Terminate with NULL character
- time_string[10] = (char)NULL;
- date_string[10] = (char)NULL;
+ time_string[10] = (char)0;
+ date_string[10] = (char)0;
}
- ErrorCode WriteNCDF::write_file(const char *exodus_file_name,
+ ErrorCode WriteNCDF::write_file(const char *exodus_file_name,
diff --git a/math/moab/pkg-descr b/math/moab/pkg-descr
index 4b44baa85061..43b2f20ecb59 100644
--- a/math/moab/pkg-descr
+++ b/math/moab/pkg-descr
@@ -12,4 +12,4 @@ provenance information for the mesh. Because the data model used in MOAB is so
abstract, conventions are useful for describing how meta-data is stored into
that data model.
-WWW: http://sigma.mcs.anl.gov/moab-library/
+WWW: https://press3.mcs.anl.gov/sigma/moab-library/
diff --git a/math/moab/pkg-plist b/math/moab/pkg-plist
index 7a07eb78fa11..4e8d795b5a6b 100644
--- a/math/moab/pkg-plist
+++ b/math/moab/pkg-plist
@@ -1,54 +1,31 @@
-bin/dagmc_preproc
-bin/h5minfo
-bin/h5mvalidate
bin/hexmodops
bin/mbconvert
bin/mbdepth
bin/mbgsets
+bin/mbhonodes
bin/mbmem
+bin/mbquality
bin/mbsize
bin/mbskin
+bin/mbslavepart
bin/mbsurfplot
bin/mbtagprop
-bin/spheredecomp
-include/DagMC.hpp
-include/MBAdaptiveKDTree.hpp
-include/MBBSPTree.hpp
-include/MBBSPTreePoly.hpp
+bin/mbumr
+%%MPI%%include/Coupler.hpp
+%%MPI%%include/ElemUtil.hpp
include/MBCN.h
-include/MBCN.hpp
include/MBCN_protos.h
-include/MBCartVect.hpp
-include/MBCore.hpp
-include/MBEntityHandle.h
include/MBEntityType.h
-include/MBForward.hpp
-include/MBGeomUtil.hpp
-include/MBInterface.hpp
-include/MBOrientedBoxTreeTool.hpp
-include/MBParallelComm.hpp
-include/MBParallelData.hpp
-include/MBProcConfig.hpp
-include/MBRange.hpp
-include/MBReadUtilIface.hpp
-include/MBReaderIface.hpp
-include/MBReaderWriterSet.hpp
-include/MBSkinner.hpp
+%%MPI%%include/MBParallelConventions.h
include/MBTagConventions.hpp
-include/MBTypes.h
-include/MBUnknownInterface.hpp
-include/MBUtil.hpp
-include/MBVersion.h
-include/MBWriteUtilIface.hpp
-include/MBWriterIface.hpp
include/MBiMesh.hpp
-include/MBmpi.h
-include/MOAB_FCDefs.h
include/iBase.h
include/iBase_f.h
include/iMesh.h
+%%MPI%%include/iMeshP.h
+%%MPI%%include/iMeshP_f.h
+%%MPI%%include/iMeshP_protos.h
include/iMesh_extensions.h
-include/iMesh_extensions_protos.h
include/iMesh_f.h
include/iMesh_protos.h
include/moab/AdaptiveKDTree.hpp
@@ -66,27 +43,44 @@ include/moab/ElemEvaluator.hpp
include/moab/EntityHandle.hpp
include/moab/EntityType.hpp
include/moab/Error.hpp
+include/moab/ErrorHandler.hpp
include/moab/ExoIIInterface.hpp
include/moab/FBEngine.hpp
include/moab/FileOptions.hpp
include/moab/FindPtFuncs.h
include/moab/Forward.hpp
+include/moab/GeomQueryTool.hpp
include/moab/GeomTopoTool.hpp
include/moab/GeomUtil.hpp
+include/moab/HalfFacetRep.hpp
include/moab/HigherOrderFactory.hpp
include/moab/HomXform.hpp
include/moab/Interface.hpp
-include/moab/LinearHex.hpp
-include/moab/LinearQuad.hpp
-include/moab/LinearTet.hpp
-include/moab/LinearTri.hpp
+include/moab/IntxMesh/Intx2Mesh.hpp
+include/moab/IntxMesh/Intx2MeshInPlane.hpp
+include/moab/IntxMesh/Intx2MeshOnSphere.hpp
+include/moab/IntxMesh/IntxRllCssphere.hpp
+include/moab/IntxMesh/IntxUtils.hpp
include/moab/LloydSmoother.hpp
+include/moab/LocalDiscretization/LinearHex.hpp
+include/moab/LocalDiscretization/LinearQuad.hpp
+include/moab/LocalDiscretization/LinearTet.hpp
+include/moab/LocalDiscretization/LinearTri.hpp
+include/moab/LocalDiscretization/QuadraticHex.hpp
+include/moab/MOABConfig.h
include/moab/Matrix3.hpp
include/moab/MergeMesh.hpp
+include/moab/MeshGeneration.hpp
include/moab/MeshTopoUtil.hpp
+include/moab/NestedRefine.hpp
+include/moab/NestedRefineTemplates.hpp
+include/moab/OrientedBox.hpp
include/moab/OrientedBoxTreeTool.hpp
+%%MPI%%include/moab/ParallelComm.hpp
+%%MPI%%include/moab/ParallelData.hpp
+%%MPI%%include/moab/ParallelMergeMesh.hpp
+%%MPI%%include/moab/ProcConfig.hpp
include/moab/ProgOptions.hpp
-include/moab/QuadraticHex.hpp
include/moab/Range.hpp
include/moab/RangeMap.hpp
include/moab/ReadUtilIface.hpp
@@ -105,9 +99,12 @@ include/moab/TupleList.hpp
include/moab/Types.hpp
include/moab/UnknownInterface.hpp
include/moab/Util.hpp
-include/moab/Version.h
+include/moab/VtkUtil.hpp
include/moab/WriteUtilIface.hpp
include/moab/WriterIface.hpp
+%%MPI%%include/moab/gs.hpp
+include/moab/iMOAB.h
+include/moab/mhdf_public.h
include/moab/point_locater/element_maps/linear_hex_map.hpp
include/moab/point_locater/element_maps/linear_tet_map.hpp
include/moab/point_locater/element_maps/quadratic_hex_map.hpp
@@ -118,17 +115,19 @@ include/moab/point_locater/point_locater.hpp
include/moab/point_locater/tree/bvh_tree.hpp
include/moab/point_locater/tree/common_tree.hpp
include/moab/point_locater/tree/element_tree.hpp
-lib/MOABConfig.cmake
+include/moab/verdict.h
+include/moab/verdict/VerdictWrapper.hpp
+%%MPI%%include/moab_mpi.h
+%%MPI%%include/moab_mpi_config.h
+lib/cmake/MOAB/MOABConfig.cmake
+lib/cmake/MOAB/MOABTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/MOAB/MOABTargets.cmake
lib/iMesh-Defs.inc
lib/libMOAB.so
-lib/libMOAB.so.0
-lib/libMOAB.so.0.0.0
-lib/libdagmc.so
-lib/libdagmc.so.0
-lib/libdagmc.so.0.0.0
+lib/libMOAB.so.5
+lib/libMOAB.so.5.0.0
lib/libiMesh.so
-lib/libiMesh.so.0
-lib/libiMesh.so.0.0.0
-lib/moab.config
+lib/libiMesh.so.5
+lib/libiMesh.so.5.0.0
+%%MPI%%lib/libmbcoupler.so
lib/moab.make
-man/man1/mbconvert.1.gz