aboutsummaryrefslogtreecommitdiff
path: root/math/mprime/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-04-12 20:17:32 +0000
committerSteve Wills <swills@FreeBSD.org>2019-04-12 20:17:32 +0000
commitd0d7addef84bfc9200bf1729ae510ada8b597fd6 (patch)
treeee496cee416598d4588c3611a6359c1bc903e933 /math/mprime/Makefile
parent0088edb80e249501f5acf0da1bfea71f5ce2e914 (diff)
downloadports-d0d7addef84bfc9200bf1729ae510ada8b597fd6.tar.gz
ports-d0d7addef84bfc9200bf1729ae510ada8b597fd6.zip
math/mprime: avoid runtime issue
PR: 236546 Submitted by: rozhuk.im@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=498741
Diffstat (limited to 'math/mprime/Makefile')
-rw-r--r--math/mprime/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/math/mprime/Makefile b/math/mprime/Makefile
index 6e04683af5ec..df23e0fae32e 100644
--- a/math/mprime/Makefile
+++ b/math/mprime/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mprime
PORTVERSION= 29.4b7
+PORTREVISION= 1
CATEGORIES= math benchmarks net
MASTER_SITES= http://www.mersenne.org/ftp_root/gimps/ \
ftp://mersenne.org/gimps/
@@ -23,11 +24,13 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libgmp.so:math/gmp
USES= zip
+
NO_WRKSUBDIR= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makebsd
ALL_TARGET= mprime
+LLD_UNSAFE= yes
SUB_FILES= wrapper.sh
@@ -48,9 +51,9 @@ post-patch:
pre-build:
.if ${ARCH} == "amd64"
- @${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${PATCH_WRKSRC}/gwnum -f makebsd64
+ @${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${PATCH_WRKSRC}/gwnum ${MAKE_FLAGS} makebsd64 ${_MAKE_JOBS} ${MAKE_ARGS:C,^${DESTDIRNAME}=.*,,g}
.elif ${ARCH} == "i386"
- @${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${PATCH_WRKSRC}/gwnum -f makemsys
+ @${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${PATCH_WRKSRC}/gwnum ${MAKE_FLAGS} makemsys ${_MAKE_JOBS} ${MAKE_ARGS:C,^${DESTDIRNAME}=.*,,g}
.endif
do-install: