aboutsummaryrefslogtreecommitdiff
path: root/math/mumps
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-05-27 08:31:46 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-05-27 08:31:46 +0000
commitb1876f270f4963c28f13aff0bfe5d6110ca14223 (patch)
treef60ee298c48917432cae51bc35b31bc76597506a /math/mumps
parentc0f32886e42f10eb052ca3989bb9864f9abf8749 (diff)
downloadports-b1876f270f4963c28f13aff0bfe5d6110ca14223.tar.gz
ports-b1876f270f4963c28f13aff0bfe5d6110ca14223.zip
Upgrade to MUMPS 4.7.3.
Noticed by: Pedro F. Giffuni <giffunip (at) yahoo.com>
Notes
Notes: svn path=/head/; revision=191962
Diffstat (limited to 'math/mumps')
-rw-r--r--math/mumps/Makefile21
-rw-r--r--math/mumps/distinfo6
-rw-r--r--math/mumps/files/patch-Make.inc+Makefile.inc.generic4
3 files changed, 17 insertions, 14 deletions
diff --git a/math/mumps/Makefile b/math/mumps/Makefile
index 0a43069db021..082887aa7f02 100644
--- a/math/mumps/Makefile
+++ b/math/mumps/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= mumps
-PORTVERSION= 4.6.3
-PORTREVISION= 3
+PORTVERSION= 4.7.3
CATEGORIES= math
-MASTER_SITES= http://www.enseeiht.fr/apo/MUMPS/ \
- http://www.enseeiht.fr/irit/apo/MUMPS/ \
- http://graal.ens-lyon.fr/MUMPS/
+MASTER_SITES= http://mumps.enseeiht.fr/ \
+ http://graal.ens-lyon.fr/MUMPS/ \
+ http://www.enseeiht.fr/apo/MUMPS/ \
+ http://www.enseeiht.fr/irit/apo/MUMPS/
DISTNAME= MUMPS_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -31,7 +31,10 @@ COMMENT= MUltifrontal Massively Parallel sparse direct Solver
#-----------------------------------------------------------------------
WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+
+SLAVEDIRS= math/mumps-mpich
+
FC= gfortran42
F77= gfortran42
FORTRANLIBS= -lgfortranbegin -lgfortran
@@ -51,14 +54,14 @@ PLIST_SUB+= MUMPSVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
-WITH_ATLAS= yes
+WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
BLAS_LIBS= -lf77blas -latlas
LAPACK_LIBS= -lalapack -lcblas
.else
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS_LIBS= -lblas
LAPACK_LIBS= -llapack
.endif
diff --git a/math/mumps/distinfo b/math/mumps/distinfo
index ee90aaabb240..f14ff9eb6e7a 100644
--- a/math/mumps/distinfo
+++ b/math/mumps/distinfo
@@ -1,3 +1,3 @@
-MD5 (MUMPS_4.6.3.tar.gz) = c73ee3454b53690d61e9d8a0cf2a9520
-SHA256 (MUMPS_4.6.3.tar.gz) = 352c7728537ead2bb6e6d9640fbc6123693b0243ce9546335151a5346b7e8d52
-SIZE (MUMPS_4.6.3.tar.gz) = 2136010
+MD5 (MUMPS_4.7.3.tar.gz) = 6210446ae93f3d77751945cbbaccacc1
+SHA256 (MUMPS_4.7.3.tar.gz) = b3ad73f06c4af931f12cccda8556a25051073ba7d70b041b888316e975807d67
+SIZE (MUMPS_4.7.3.tar.gz) = 2110805
diff --git a/math/mumps/files/patch-Make.inc+Makefile.inc.generic b/math/mumps/files/patch-Make.inc+Makefile.inc.generic
index 30cfaa21b5f3..0381879259af 100644
--- a/math/mumps/files/patch-Make.inc+Makefile.inc.generic
+++ b/math/mumps/files/patch-Make.inc+Makefile.inc.generic
@@ -44,7 +44,7 @@
# SCALAP should define the SCALAPACK and BLACS libraries.
-SCALAP = -lscalapack -lblacs
-+SCALAP = -L@LOCALBASE@/lib -lscalapack -lblacs -lblacsc -lblacsf77 -lblacs
++SCALAP = -L@LOCALBASE@/lib -lblacs -lblacsc -lblacsf77 -lscalapack
# INCLUDE DIRECTORY FOR MPI
-INCPAR = -I/usr/include
@@ -52,7 +52,7 @@
# LIBRARIES USED BY THE PARALLEL VERSION OF MUMPS: $(SCALAP) and MPI
-LIBPAR = $(SCALAP) -L/usr/lib -lmpi
-+LIBPAR = $(SCALAP) -L@LOCALBASE@/mpich2/lib -lfmpich -lmpich
++LIBPAR = -L@LOCALBASE@/mpich2/lib -lfmpich -lmpich $(SCALAP)
# The parallel version is not concerned by the next two lines.
# They are related to the sequential library provided by MUMPS,