aboutsummaryrefslogtreecommitdiff
path: root/math/muparserx
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-06 02:08:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-06 02:08:24 +0000
commit8d5a307e7a836af13ea96e624a59ee48e5b27e45 (patch)
tree1f8001c9c518bb4381df853a74c74144b14b7e05 /math/muparserx
parentebeb9f3f116d8cb6290bc8b39201184c01b4c20e (diff)
downloadports-8d5a307e7a836af13ea96e624a59ee48e5b27e45.tar.gz
ports-8d5a307e7a836af13ea96e624a59ee48e5b27e45.zip
New port: math/muparserx: C++ math parser library with array and string support
Notes
Notes: svn path=/head/; revision=567456
Diffstat (limited to 'math/muparserx')
-rw-r--r--math/muparserx/Makefile24
-rw-r--r--math/muparserx/distinfo3
-rw-r--r--math/muparserx/pkg-descr4
-rw-r--r--math/muparserx/pkg-plist53
4 files changed, 84 insertions, 0 deletions
diff --git a/math/muparserx/Makefile b/math/muparserx/Makefile
new file mode 100644
index 000000000000..d10066351c2f
--- /dev/null
+++ b/math/muparserx/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= muparserx
+DISTVERSIONPREFIX= v
+DISTVERSION= 4.0.8-30
+DISTVERSIONSUFFIX= -g0a7c3b2
+CATEGORIES= math devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ math parser library with array and string support
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake compiler:c++11-lang
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= beltoforion
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_EXAMPLES
+
+.include <bsd.port.mk>
diff --git a/math/muparserx/distinfo b/math/muparserx/distinfo
new file mode 100644
index 000000000000..e1b4aaf59834
--- /dev/null
+++ b/math/muparserx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614995736
+SHA256 (beltoforion-muparserx-v4.0.8-30-g0a7c3b2_GH0.tar.gz) = 1c2cc4a16dbef2c8093c72f00aab876eb8bf60d531d8d08cf40b5c9d960b1740
+SIZE (beltoforion-muparserx-v4.0.8-30-g0a7c3b2_GH0.tar.gz) = 1867045
diff --git a/math/muparserx/pkg-descr b/math/muparserx/pkg-descr
new file mode 100644
index 000000000000..3bc65adb88cd
--- /dev/null
+++ b/math/muparserx/pkg-descr
@@ -0,0 +1,4 @@
+muParserx is a C++ library initially based on muParser enhanced with support for
+arrays, matrices and strings, and with a completely new parsing engine.
+
+WWW: https://beltoforion.de/en/muparserx/
diff --git a/math/muparserx/pkg-plist b/math/muparserx/pkg-plist
new file mode 100644
index 000000000000..7c2130d81e9e
--- /dev/null
+++ b/math/muparserx/pkg-plist
@@ -0,0 +1,53 @@
+include/muparserx/mpCompat.h
+include/muparserx/mpDefines.h
+include/muparserx/mpError.h
+include/muparserx/mpFuncCmplx.h
+include/muparserx/mpFuncCommon.h
+include/muparserx/mpFuncMatrix.h
+include/muparserx/mpFuncNonCmplx.h
+include/muparserx/mpFuncStr.h
+include/muparserx/mpFwdDecl.h
+include/muparserx/mpICallback.h
+include/muparserx/mpIOprt.h
+include/muparserx/mpIPackage.h
+include/muparserx/mpIPrecedence.h
+include/muparserx/mpIToken.h
+include/muparserx/mpIValReader.h
+include/muparserx/mpIValue.h
+include/muparserx/mpIfThenElse.h
+include/muparserx/mpMatrix.h
+include/muparserx/mpMatrixError.h
+include/muparserx/mpOprtBinAssign.h
+include/muparserx/mpOprtBinCommon.h
+include/muparserx/mpOprtCmplx.h
+include/muparserx/mpOprtIndex.h
+include/muparserx/mpOprtMatrix.h
+include/muparserx/mpOprtNonCmplx.h
+include/muparserx/mpOprtPostfixCommon.h
+include/muparserx/mpPackageCmplx.h
+include/muparserx/mpPackageCommon.h
+include/muparserx/mpPackageMatrix.h
+include/muparserx/mpPackageNonCmplx.h
+include/muparserx/mpPackageStr.h
+include/muparserx/mpPackageUnit.h
+include/muparserx/mpParser.h
+include/muparserx/mpParserBase.h
+include/muparserx/mpParserMessageProvider.h
+include/muparserx/mpRPN.h
+include/muparserx/mpScriptTokens.h
+include/muparserx/mpStack.h
+include/muparserx/mpTest.h
+include/muparserx/mpTokenReader.h
+include/muparserx/mpTypes.h
+include/muparserx/mpValReader.h
+include/muparserx/mpValue.h
+include/muparserx/mpValueCache.h
+include/muparserx/mpVariable.h
+include/muparserx/suSortPred.h
+include/muparserx/suStringTokens.h
+include/muparserx/utGeneric.h
+lib/libmuparserx.so
+lib/libmuparserx.so.4.0.9
+libdata/pkgconfig/muparserx.pc
+share/cmake/muparserx/muparserxConfig.cmake
+share/cmake/muparserx/muparserxConfigVersion.cmake