aboutsummaryrefslogtreecommitdiff
path: root/math/nanoflann/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-10-04 03:53:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-10-04 03:53:55 +0000
commit6b5949269b4469151c9bf1f1c02ed69aaa1d243b (patch)
treec038b420cb8a3284e3d2bc0c8b08f1429b0ac735 /math/nanoflann/Makefile
parenta525b4c2c27f572eafd64ad567d6d93505ca1592 (diff)
downloadports-6b5949269b4469151c9bf1f1c02ed69aaa1d243b.tar.gz
ports-6b5949269b4469151c9bf1f1c02ed69aaa1d243b.zip
New port: math/nanoflann: Header-only library for Nearest Neighbor (NN) search with KD-trees
Notes
Notes: svn path=/head/; revision=481201
Diffstat (limited to 'math/nanoflann/Makefile')
-rw-r--r--math/nanoflann/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/math/nanoflann/Makefile b/math/nanoflann/Makefile
new file mode 100644
index 000000000000..04915215c284
--- /dev/null
+++ b/math/nanoflann/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= nanoflann
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.0
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Header-only library for Nearest Neighbor (NN) search with KD-trees
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake:outsource
+USE_GITHUB= yes
+GH_ACCOUNT= jlblancoc
+
+CMAKE_OFF= BUILD_EXAMPLES BUILD_TESTS
+
+NO_ARCH= yes
+
+PLIST_FILES= include/nanoflann.hpp \
+ lib/cmake/nanoflann/nanoflannConfig.cmake \
+ lib/cmake/nanoflann/nanoflannConfigVersion.cmake \
+ lib/cmake/nanoflann/nanoflannTargets.cmake \
+ libdata/pkgconfig/nanoflann.pc
+
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTS=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+benchmarks: build # benchmarks fail to run: https://github.com/jlblancoc/nanoflann/issues/100
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_BENCHMARKS=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} benchmarks
+
+.include <bsd.port.mk>