aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-bim
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-30 17:49:45 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-30 17:54:39 +0000
commit8231864a3b0376f9df37cc3904c4e217efc6110d (patch)
tree1527743df58dab8dec2dc27426e051818ed96898 /math/octave-forge-bim
parentc87a22b7f399da0a3446fb75c57eaba8dc7769ca (diff)
downloadports-8231864a3b0376f9df37cc3904c4e217efc6110d.tar.gz
ports-8231864a3b0376f9df37cc3904c4e217efc6110d.zip
Mk/**octave.mk: Convert to USES=octave
As part of the improvements of USES infrastructure Mk/bsd.octave.mk has been converted to Mk/Uses/octave.mk. This also declutters some old stuffs in the octave-* ports and makes it simpler to add more octave-forge ports easily. While I am here make all the ports portclippy/portfmt compliant. And use USES macros whenever possible. Reviewed by: portmgr Approved by: tcberner Differential Revision: https://reviews.freebsd.org/D37887
Diffstat (limited to 'math/octave-forge-bim')
-rw-r--r--math/octave-forge-bim/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/math/octave-forge-bim/Makefile b/math/octave-forge-bim/Makefile
index 88a7e530487d..1aa560c0cfd7 100644
--- a/math/octave-forge-bim/Makefile
+++ b/math/octave-forge-bim/Makefile
@@ -8,28 +8,19 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
WWW= https://packages.octave.org/
LICENSE= GPLv2
-LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+LICENSE_FILE= ${WRKDIR}/${OCTAVE_SRC}/COPYING
+RUN_DEPENDS= ${OCTAVE_TARBALLS_DIR}/fpl.tar.gz:math/octave-forge-fpl \
+ ${OCTAVE_TARBALLS_DIR}/msh.tar.gz:math/octave-forge-msh
+
+USES= octave
USE_GITHUB= yes
GH_ACCOUNT= carlodefalco
GH_PROJECT= bim
-# OCTSRC is the name of the directory of the package.
-# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
-OCTSRC= ${GH_PROJECT}-${DISTVERSION}
-
-RUN_DEPENDS+= ${TARBALLS_DIR}/fpl.tar.gz:math/octave-forge-fpl
-RUN_DEPENDS+= ${TARBALLS_DIR}/msh.tar.gz:math/octave-forge-msh
-
-.include "${.CURDIR}/../../Mk/bsd.octave.mk"
-
-do-build:
- @${DO_NADA}
-
NO_ARCH= yes
+NO_BUILD= yes
-post-build:
- ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
+OCTAVE_SRC= ${GH_PROJECT}-${DISTVERSION}
.include <bsd.port.mk>