aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-ponchon-savarit/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-30 17:49:45 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-30 17:54:39 +0000
commit8231864a3b0376f9df37cc3904c4e217efc6110d (patch)
tree1527743df58dab8dec2dc27426e051818ed96898 /math/octave-forge-ponchon-savarit/Makefile
parentc87a22b7f399da0a3446fb75c57eaba8dc7769ca (diff)
downloadports-8231864a3b0376f9df37cc3904c4e217efc6110d.tar.gz
ports-8231864a3b0376f9df37cc3904c4e217efc6110d.zip
Mk/**octave.mk: Convert to USES=octave
As part of the improvements of USES infrastructure Mk/bsd.octave.mk has been converted to Mk/Uses/octave.mk. This also declutters some old stuffs in the octave-* ports and makes it simpler to add more octave-forge ports easily. While I am here make all the ports portclippy/portfmt compliant. And use USES macros whenever possible. Reviewed by: portmgr Approved by: tcberner Differential Revision: https://reviews.freebsd.org/D37887
Diffstat (limited to 'math/octave-forge-ponchon-savarit/Makefile')
-rw-r--r--math/octave-forge-ponchon-savarit/Makefile19
1 files changed, 4 insertions, 15 deletions
diff --git a/math/octave-forge-ponchon-savarit/Makefile b/math/octave-forge-ponchon-savarit/Makefile
index 8ba9799cb2b5..ad6bf20ff898 100644
--- a/math/octave-forge-ponchon-savarit/Makefile
+++ b/math/octave-forge-ponchon-savarit/Makefile
@@ -8,27 +8,16 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
WWW= https://packages.octave.org/
LICENSE= GPLv3
-LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+LICENSE_FILE= ${WRKDIR}/${OCTAVE_SRC}/COPYING
+USES= octave
USE_GITHUB= yes
GH_ACCOUNT= aumpierre-unb
GH_PROJECT= Ponchon-Savarit-for-GNU-Octave
-# OCTSRC is the name of the directory of the package.
-# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
-OCTSRC= ${GH_PROJECT}-${DISTVERSION}
-
-WRKSRC= ${WRKDIR}/${OCTSRC}/src
-
-do-build:
- @${DO_NADA}
+OCTAVE_SRC= ${GH_PROJECT}-${DISTVERSION}
NO_ARCH= yes
-
-.include "${.CURDIR}/../../Mk/bsd.octave.mk"
-
-post-build:
- ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
+NO_BUILD= yes
.include <bsd.port.mk>