aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-video
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2021-02-21 23:42:08 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2021-02-21 23:42:08 +0000
commit1c5330cb0bb82cddf95c7dacab1dc7e12dc139b6 (patch)
tree42f6a0a8378a80e92a2b15b9ec14e14c29ce54f9 /math/octave-forge-video
parentcef63c5c0b847ef72a91a91b497e67d8ef746673 (diff)
downloadports-1c5330cb0bb82cddf95c7dacab1dc7e12dc139b6.tar.gz
ports-1c5330cb0bb82cddf95c7dacab1dc7e12dc139b6.zip
- Resurrect port.
- Update to 2.0.0.
Notes
Notes: svn path=/head/; revision=566255
Diffstat (limited to 'math/octave-forge-video')
-rw-r--r--math/octave-forge-video/Makefile34
-rw-r--r--math/octave-forge-video/distinfo3
-rw-r--r--math/octave-forge-video/pkg-descr11
3 files changed, 48 insertions, 0 deletions
diff --git a/math/octave-forge-video/Makefile b/math/octave-forge-video/Makefile
new file mode 100644
index 000000000000..859931bf3d63
--- /dev/null
+++ b/math/octave-forge-video/Makefile
@@ -0,0 +1,34 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-video
+PORTVERSION= 2.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+USES= pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= HOME=${WRKSRC}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+LIB_DEPENDS+= libavcodec.so:multimedia/ffmpeg
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-video/distinfo b/math/octave-forge-video/distinfo
new file mode 100644
index 000000000000..dad3687f7cca
--- /dev/null
+++ b/math/octave-forge-video/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613950323
+SHA256 (octave-forge/video-2.0.0.tar.gz) = 3b5724281f9059cfb2678eac03ec0bde2b269568761f4d105cda16d8081bd268
+SIZE (octave-forge/video-2.0.0.tar.gz) = 61998
diff --git a/math/octave-forge-video/pkg-descr b/math/octave-forge-video/pkg-descr
new file mode 100644
index 000000000000..9818327f6b51
--- /dev/null
+++ b/math/octave-forge-video/pkg-descr
@@ -0,0 +1,11 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is video.
+
+Implements addframe, avifile, aviinfo, and aviread, using ffmpeg.
+(and approximately conforms to Matlab interface)
+
+WWW: http://octave.sourceforge.net/