aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2016-07-27 05:44:40 +0000
committerMaho Nakata <maho@FreeBSD.org>2016-07-27 05:44:40 +0000
commit539ea053194b03ad43784093bb64cac56cb3ed61 (patch)
treeb31703317cbaf61ebdd795c666a5d2ab49a94634 /math/octave/Makefile
parent0a0ec570926d4caf0ec0c21906456656d30654e0 (diff)
downloadports-539ea053194b03ad43784093bb64cac56cb3ed61.tar.gz
ports-539ea053194b03ad43784093bb64cac56cb3ed61.zip
1. Some dependencies were added per QA advice.
2. updated to version 4.0.3 deleted obsolete patch 'patch-libinterp-octave-value-ov-classdef' Java and GUI are now optional plist is now generated automatically revised dependencies PR: 211291 Submitted by: bsam (1), Alexander Sherikov (2)
Notes
Notes: svn path=/head/; revision=419163
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 3367eb76e7cf..0c00576841d1 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= octave
-PORTVERSION= 4.0.0
-PORTREVISION= 2
+PORTVERSION= 4.0.3
CATEGORIES= math
MASTER_SITES= GNU
@@ -33,16 +32,20 @@ LIB_DEPENDS= libGraphicsMagick.so:graphics/GraphicsMagick \
libumfpack.so:math/suitesparse \
libglpk.so:math/glpk \
libgl2ps.so:print/gl2ps \
- libqscintilla2.so:devel/qscintilla2
+ libqscintilla2.so:devel/qscintilla2 \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
-USES= charsetfix fortran gmake libtool perl5 pkgconfig tar:xz
+USES= charsetfix fortran gmake libtool perl5 pkgconfig readline tar:xz
USE_LDCONFIG= yes
USE_PERL5= build
USE_TEX= dvipsk:build
GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.7+
-USE_QT4= gui network uic_build moc_build rcc_build linguist_build
+USE_QT4= corelib gui network opengl uic_build moc_build rcc_build linguist_build
+USE_XORG= x11 xext xfixes xft
+USE_GL= gl glu
OCTAVE_VERSION= ${PORTVERSION}
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}