aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2018-11-16 15:18:35 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2018-11-16 15:18:35 +0000
commita92540473be43d7ad316e640cc292c8fc7e71549 (patch)
tree03d4c2f94786b03e276559a1e0ccd13a3e9b38db /math/octave/Makefile
parentde105ceb57b117b3a12899d8b859189971e62a7c (diff)
downloadports-a92540473be43d7ad316e640cc292c8fc7e71549.tar.gz
ports-a92540473be43d7ad316e640cc292c8fc7e71549.zip
- adds USES+= gl (USE_GL without USES+= gl is deprecated);
- adds USES+= desktop-file-utils iconv; - adds USE_XORG+= xcursor xinerama xrender; - adds USE_QT+= printsupport sql widgets; - strips liboctave.so.6.0.0. - Corrects configure options for --withosmesa PR: ports/233240 Submitted by: Lorenzo Salvadore <phascolarctos@protonmail.ch>
Notes
Notes: svn path=/head/; revision=485083
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 8ebb38fed527..b17d3ce82b1b 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -41,16 +41,18 @@ LIB_DEPENDS= libGraphicsMagick.so:graphics/GraphicsMagick \
libsundials_arkode.so:math/sundials
USES= charsetfix fortran gmake libtool perl5 pkgconfig qt:5 readline \
- tar:xz compiler:c++14-lang
+ tar:xz compiler:c++14-lang \
+ desktop-file-utils gl iconv
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}/${PORTVERSION}
USE_PERL5= build
-USE_TEX= dvipsk:build formats:build
GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.7+
USE_QT= core gui help network opengl \
- qmake_build buildtools_build linguist_build
-USE_XORG= x11 xext xfixes xft
+ qmake_build buildtools_build linguist_build \
+ printsupport sql widgets
+USE_XORG= x11 xext xfixes xft \
+ xcursor xinerama xrender
USE_GL= gl glu
OCTAVE_VERSION= ${PORTVERSION}
@@ -73,21 +75,23 @@ CONFIGURE_ARGS= --host=${GNU_HOST} \
--disable-jit \
--disable-openmp \
--with-qt=5 \
- --with-OSMesa-includedir=${LOCALBASE}/include/GL \
- --with-OSMesa-libdir=${LOCALBASE}/lib
+ --with-osmesa
+
+INFO= octave liboctave
OPTIONS_DEFINE= DOCS
+DOCS_CONFIGURE_ENABLE= docs
+
OPTIONS_RADIO= BLAS
OPTIONS_RADIO_BLAS= OPENBLAS NETLIB ATLAS
OPTIONS_DEFAULT= OPENBLAS
+DOCS_USE= TEX=dvipsk:build,formats:build
OPENBLAS_USES= blaslapack:openblas
NETLIB_USES= blaslapack:netlib
ATLAS_USES= blaslapack:atlas
-INFO= octave liboctave
-
post-patch:
${REINPLACE_CMD} 's+"makeinfo"+"${LOCALBASE}/bin/makeinfo"+' ${WRKSRC}/libinterp/corefcn/help.cc
${REINPLACE_CMD} 's+lapack lapack_rs6k+${LAPACKLIB:C/-l//}+' ${WRKSRC}/configure
@@ -97,6 +101,7 @@ post-patch:
post-install:
(cd ${STAGEDIR}${DATADIR} && ${LN} -s ${PORTVERSION}/imagelib .)
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/octave/${PORTVERSION}/liboctave.so.6.0.0
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}