aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2011-06-23 07:28:50 +0000
committerMaho Nakata <maho@FreeBSD.org>2011-06-23 07:28:50 +0000
commitf2cf0ade3da419784f4d4252650cbf6a97c1ec6d (patch)
tree3ddc524fe28e5175971fe5ddaf6de7313d091714 /math/octave/Makefile
parent8de66b5c2471f7f304b229dded970f622ce18626 (diff)
downloadports-f2cf0ade3da419784f4d4252650cbf6a97c1ec6d.tar.gz
ports-f2cf0ade3da419784f4d4252650cbf6a97c1ec6d.zip
Update to 3.4.1.
Add a make target called "check" you can now check octave port by $ make check . [1] Note: 10 tests failed on FreeBSD 8.1/RELEASE amd64. Discussion with @tmacchant via twitter
Notes
Notes: svn path=/head/; revision=276100
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile28
1 files changed, 16 insertions, 12 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index c289f53fcd42..5e87d643b921 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= octave
-PORTVERSION= 3.4.0
-PORTREVISION= 2
+PORTVERSION= 3.4.1
CATEGORIES= math
MASTER_SITES= ftp://ftp.gnu.org/gnu/octave/ \
ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/
@@ -23,18 +22,19 @@ BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
gsed:${PORTSDIR}/textproc/gsed \
${PREFIX}/bin/makeinfo:${PORTSDIR}/print/texinfo
-LIB_DEPENDS= glpk.30:${PORTSDIR}/math/glpk \
- umfpack.1:${PORTSDIR}/math/suitesparse \
- qhull:${PORTSDIR}/math/qhull \
+LIB_DEPENDS= GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick \
arpack:${PORTSDIR}/math/arpack \
- qrupdate:${PORTSDIR}/math/qrupdate \
- fftw3f:${PORTSDIR}/math/fftw3-float \
+ curl:${PORTSDIR}/ftp/curl \
fftw3:${PORTSDIR}/math/fftw3 \
- ftgl:${PORTSDIR}/graphics/ftgl \
+ fftw3f:${PORTSDIR}/math/fftw3-float \
fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick \
- curl:${PORTSDIR}/ftp/curl \
- hdf5:${PORTSDIR}/science/hdf5-18
+ ftgl:${PORTSDIR}/graphics/ftgl \
+ hdf5:${PORTSDIR}/science/hdf5-18 \
+ pcre.0:${PORTSDIR}/devel/pcre \
+ qhull:${PORTSDIR}/math/qhull \
+ qrupdate:${PORTSDIR}/math/qrupdate \
+ umfpack.1:${PORTSDIR}/math/suitesparse \
+ glpk.30:${PORTSDIR}/math/glpk
USE_BZIP2= yes
USE_PERL5_BUILD=yes
@@ -116,7 +116,7 @@ post-install:
.endfor
.endif
${RM} -f ${WRKDIR}/PLIST
-.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave ${PREFIX}/libexec/octave ${PREFIX}/lib/octave-${OCTAVE_VERSION}
+.for d in ${PREFIX}/include/octave-${OCTAVE_VERSION} ${PREFIX}/share/octave ${PREFIX}/lib/octave/${OCTAVE_VERSION} ${PREFIX}/libexec/octave ${PREFIX}/lib/octave/site
@${FIND} -s $d -not -type d | \
${SED} -e 's#^${PREFIX}/##' >> ${WRKDIR}/PLIST
@${FIND} -s $d -type d -empty | \
@@ -127,4 +127,8 @@ post-install:
.endfor
cd ${WRKDIR} ; ${SED} -i -e "/PLIST/ r PLIST" ${TMPPLIST}
+
+check:
+ (cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} check)
+
.include <bsd.port.post.mk>