aboutsummaryrefslogtreecommitdiff
path: root/math/openfst
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2013-12-26 16:13:15 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2013-12-26 16:13:15 +0000
commit15ecb42277d85b742d4275ca6ea243ec26e8263e (patch)
tree01c99261b9380c1beb8f57929063d662a484e639 /math/openfst
parent4483e41440bb0f26f90a46d86d5ed97cb73095a3 (diff)
downloadports-15ecb42277d85b742d4275ca6ea243ec26e8263e.tar.gz
ports-15ecb42277d85b742d4275ca6ea243ec26e8263e.zip
New port : openfst.
OpenFst is a library for constructing, combining, optimizing, and searching weighted finite-state transducers (FSTs). Weighted finite-state transducers are automata where each transition has an input label, an output label, and a weight. The more familiar finite-state acceptor is represented as a transducer with each transition's input and output label equal. Finite-state acceptors are used to represent sets of strings (specifically, regular or rational sets); finite-state transducers are used to represent binary relations between pairs of strings (specifically, rational transductions). The weights can be used to represent the cost of taking a particular transition.
Notes
Notes: svn path=/head/; revision=337544
Diffstat (limited to 'math/openfst')
-rw-r--r--math/openfst/Makefile21
-rw-r--r--math/openfst/distinfo2
-rw-r--r--math/openfst/pkg-descr20
-rw-r--r--math/openfst/pkg-plist316
4 files changed, 359 insertions, 0 deletions
diff --git a/math/openfst/Makefile b/math/openfst/Makefile
new file mode 100644
index 000000000000..cfe0aa117537
--- /dev/null
+++ b/math/openfst/Makefile
@@ -0,0 +1,21 @@
+# Created by: Dmitry Sivachenko <mitya@yandex-team.ru>
+# $FreeBSD$
+
+PORTNAME= openfst
+PORTVERSION= 1.3.4
+CATEGORIES= math
+MASTER_SITES= http://www.openfst.org/twiki/pub/FST/FstDownload/
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Library for working with weighted finite-state transducers (FSTs)
+
+LICENSE= AL2
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-compact-fsts --enable-const-fsts --enable-far --enable-lookahead-fsts --enable-pdt
+
+post-patch:
+ ${REINPLACE_CMD} -e s#-ldl## ${WRKSRC}/src/extensions/far/Makefile.in ${WRKSRC}/src/extensions/pdt/Makefile.in ${WRKSRC}/src/bin/Makefile.in ${WRKSRC}/src/test/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/math/openfst/distinfo b/math/openfst/distinfo
new file mode 100644
index 000000000000..6e36291836f5
--- /dev/null
+++ b/math/openfst/distinfo
@@ -0,0 +1,2 @@
+SHA256 (openfst-1.3.4.tar.gz) = e95fa96674e1c9d6866bbf79b9cd755c5121ad165b76224c7c6bbfa139399a61
+SIZE (openfst-1.3.4.tar.gz) = 769158
diff --git a/math/openfst/pkg-descr b/math/openfst/pkg-descr
new file mode 100644
index 000000000000..ace996bb72e7
--- /dev/null
+++ b/math/openfst/pkg-descr
@@ -0,0 +1,20 @@
+OpenFst is a library for constructing, combining, optimizing, and searching
+weighted finite-state transducers (FSTs). Weighted finite-state transducers
+are automata where each transition has an input label, an output label, and
+a weight. The more familiar finite-state acceptor is represented as a
+transducer with each transition's input and output label equal.
+Finite-state acceptors are used to represent sets of strings (specifically,
+regular or rational sets); finite-state transducers are used to represent
+binary relations between pairs of strings (specifically, rational
+transductions). The weights can be used to represent the cost of taking
+a particular transition.
+FSTs have key applications in speech recognition and synthesis, machine
+translation, optical character recognition, pattern matching, string
+processing, machine learning, information extraction and retrieval
+among others. Often a weighted transducer is used to represent a
+probabilistic model (e.g., an n-gram model, pronunciation model). FSTs can
+be optimized by determinization and minimization, models can be applied to
+hypothesis sets (also represented as automata) or cascaded by finite-state
+composition, and the best results can be selected by shortest-path algorithms.
+
+WWW: http://www.openfst.org/
diff --git a/math/openfst/pkg-plist b/math/openfst/pkg-plist
new file mode 100644
index 000000000000..38079ba0553d
--- /dev/null
+++ b/math/openfst/pkg-plist
@@ -0,0 +1,316 @@
+bin/farcompilestrings
+bin/farcreate
+bin/farequal
+bin/farextract
+bin/farinfo
+bin/farprintstrings
+bin/fstarcsort
+bin/fstclosure
+bin/fstcompile
+bin/fstcompose
+bin/fstconcat
+bin/fstconnect
+bin/fstconvert
+bin/fstdeterminize
+bin/fstdifference
+bin/fstdraw
+bin/fstencode
+bin/fstepsnormalize
+bin/fstequal
+bin/fstequivalent
+bin/fstinfo
+bin/fstintersect
+bin/fstinvert
+bin/fstmap
+bin/fstminimize
+bin/fstprint
+bin/fstproject
+bin/fstprune
+bin/fstpush
+bin/fstrandgen
+bin/fstrelabel
+bin/fstreplace
+bin/fstreverse
+bin/fstreweight
+bin/fstrmepsilon
+bin/fstshortestdistance
+bin/fstshortestpath
+bin/fstsymbols
+bin/fstsynchronize
+bin/fsttopsort
+bin/fstunion
+bin/pdtcompose
+bin/pdtexpand
+bin/pdtinfo
+bin/pdtreplace
+bin/pdtreverse
+bin/pdtshortestpath
+include/fst/accumulator.h
+include/fst/add-on.h
+include/fst/arc-map.h
+include/fst/arc.h
+include/fst/arcfilter.h
+include/fst/arcsort.h
+include/fst/bi-table.h
+include/fst/cache.h
+include/fst/closure.h
+include/fst/compact-fst.h
+include/fst/compat.h
+include/fst/complement.h
+include/fst/compose-filter.h
+include/fst/compose.h
+include/fst/concat.h
+include/fst/config.h
+include/fst/connect.h
+include/fst/const-fst.h
+include/fst/determinize.h
+include/fst/dfs-visit.h
+include/fst/difference.h
+include/fst/edit-fst.h
+include/fst/encode.h
+include/fst/epsnormalize.h
+include/fst/equal.h
+include/fst/equivalent.h
+include/fst/expanded-fst.h
+include/fst/expectation-weight.h
+include/fst/extensions/far/compile-strings.h
+include/fst/extensions/far/create.h
+include/fst/extensions/far/equal.h
+include/fst/extensions/far/extract.h
+include/fst/extensions/far/far.h
+include/fst/extensions/far/farlib.h
+include/fst/extensions/far/farscript.h
+include/fst/extensions/far/info.h
+include/fst/extensions/far/main.h
+include/fst/extensions/far/print-strings.h
+include/fst/extensions/far/stlist.h
+include/fst/extensions/far/sttable.h
+include/fst/extensions/pdt/collection.h
+include/fst/extensions/pdt/compose.h
+include/fst/extensions/pdt/expand.h
+include/fst/extensions/pdt/info.h
+include/fst/extensions/pdt/paren.h
+include/fst/extensions/pdt/pdt.h
+include/fst/extensions/pdt/pdtlib.h
+include/fst/extensions/pdt/pdtscript.h
+include/fst/extensions/pdt/replace.h
+include/fst/extensions/pdt/reverse.h
+include/fst/extensions/pdt/shortest-path.h
+include/fst/factor-weight.h
+include/fst/flags.h
+include/fst/float-weight.h
+include/fst/fst-decl.h
+include/fst/fst.h
+include/fst/fstlib.h
+include/fst/generic-register.h
+include/fst/heap.h
+include/fst/icu.h
+include/fst/intersect.h
+include/fst/interval-set.h
+include/fst/invert.h
+include/fst/label-reachable.h
+include/fst/lexicographic-weight.h
+include/fst/lock.h
+include/fst/log.h
+include/fst/lookahead-filter.h
+include/fst/lookahead-matcher.h
+include/fst/map.h
+include/fst/mapped-file.h
+include/fst/matcher-fst.h
+include/fst/matcher.h
+include/fst/minimize.h
+include/fst/mutable-fst.h
+include/fst/pair-weight.h
+include/fst/partition.h
+include/fst/power-weight.h
+include/fst/product-weight.h
+include/fst/project.h
+include/fst/properties.h
+include/fst/prune.h
+include/fst/push.h
+include/fst/queue.h
+include/fst/randequivalent.h
+include/fst/randgen.h
+include/fst/random-weight.h
+include/fst/rational.h
+include/fst/register.h
+include/fst/relabel.h
+include/fst/replace-util.h
+include/fst/replace.h
+include/fst/reverse.h
+include/fst/reweight.h
+include/fst/rmepsilon.h
+include/fst/rmfinalepsilon.h
+include/fst/script/arcsort.h
+include/fst/script/arg-packs.h
+include/fst/script/closure.h
+include/fst/script/compile-impl.h
+include/fst/script/compile.h
+include/fst/script/compose.h
+include/fst/script/concat.h
+include/fst/script/connect.h
+include/fst/script/convert.h
+include/fst/script/decode.h
+include/fst/script/determinize.h
+include/fst/script/difference.h
+include/fst/script/disambiguate.h
+include/fst/script/draw-impl.h
+include/fst/script/draw.h
+include/fst/script/encode.h
+include/fst/script/epsnormalize.h
+include/fst/script/equal.h
+include/fst/script/equivalent.h
+include/fst/script/fst-class.h
+include/fst/script/fstscript-decl.h
+include/fst/script/fstscript.h
+include/fst/script/info-impl.h
+include/fst/script/info.h
+include/fst/script/intersect.h
+include/fst/script/invert.h
+include/fst/script/map.h
+include/fst/script/minimize.h
+include/fst/script/print-impl.h
+include/fst/script/print.h
+include/fst/script/project.h
+include/fst/script/prune.h
+include/fst/script/push.h
+include/fst/script/randequivalent.h
+include/fst/script/randgen.h
+include/fst/script/register.h
+include/fst/script/relabel.h
+include/fst/script/replace.h
+include/fst/script/reverse.h
+include/fst/script/reweight.h
+include/fst/script/rmepsilon.h
+include/fst/script/script-impl.h
+include/fst/script/shortest-distance.h
+include/fst/script/shortest-path.h
+include/fst/script/symbols.h
+include/fst/script/synchronize.h
+include/fst/script/text-io.h
+include/fst/script/topsort.h
+include/fst/script/union.h
+include/fst/script/verify.h
+include/fst/script/weight-class.h
+include/fst/shortest-distance.h
+include/fst/shortest-path.h
+include/fst/signed-log-weight.h
+include/fst/slist.h
+include/fst/sparse-power-weight.h
+include/fst/sparse-tuple-weight.h
+include/fst/state-map.h
+include/fst/state-reachable.h
+include/fst/state-table.h
+include/fst/statesort.h
+include/fst/string-weight.h
+include/fst/string.h
+include/fst/symbol-table-ops.h
+include/fst/symbol-table.h
+include/fst/synchronize.h
+include/fst/test-properties.h
+include/fst/topsort.h
+include/fst/tuple-weight.h
+include/fst/types.h
+include/fst/union-find.h
+include/fst/union.h
+include/fst/util.h
+include/fst/vector-fst.h
+include/fst/verify.h
+include/fst/visit.h
+include/fst/weight.h
+lib/fst/arc_lookahead-fst.la
+lib/fst/arc_lookahead-fst.so
+lib/fst/arc_lookahead-fst.so.0
+lib/fst/compact16_acceptor-fst.la
+lib/fst/compact16_acceptor-fst.so
+lib/fst/compact16_acceptor-fst.so.0
+lib/fst/compact16_string-fst.la
+lib/fst/compact16_string-fst.so
+lib/fst/compact16_string-fst.so.0
+lib/fst/compact16_unweighted-fst.la
+lib/fst/compact16_unweighted-fst.so
+lib/fst/compact16_unweighted-fst.so.0
+lib/fst/compact16_unweighted_acceptor-fst.la
+lib/fst/compact16_unweighted_acceptor-fst.so
+lib/fst/compact16_unweighted_acceptor-fst.so.0
+lib/fst/compact16_weighted_string-fst.la
+lib/fst/compact16_weighted_string-fst.so
+lib/fst/compact16_weighted_string-fst.so.0
+lib/fst/compact64_acceptor-fst.la
+lib/fst/compact64_acceptor-fst.so
+lib/fst/compact64_acceptor-fst.so.0
+lib/fst/compact64_string-fst.la
+lib/fst/compact64_string-fst.so
+lib/fst/compact64_string-fst.so.0
+lib/fst/compact64_unweighted-fst.la
+lib/fst/compact64_unweighted-fst.so
+lib/fst/compact64_unweighted-fst.so.0
+lib/fst/compact64_unweighted_acceptor-fst.la
+lib/fst/compact64_unweighted_acceptor-fst.so
+lib/fst/compact64_unweighted_acceptor-fst.so.0
+lib/fst/compact64_weighted_string-fst.la
+lib/fst/compact64_weighted_string-fst.so
+lib/fst/compact64_weighted_string-fst.so.0
+lib/fst/compact8_acceptor-fst.la
+lib/fst/compact8_acceptor-fst.so
+lib/fst/compact8_acceptor-fst.so.0
+lib/fst/compact8_string-fst.la
+lib/fst/compact8_string-fst.so
+lib/fst/compact8_string-fst.so.0
+lib/fst/compact8_unweighted-fst.la
+lib/fst/compact8_unweighted-fst.so
+lib/fst/compact8_unweighted-fst.so.0
+lib/fst/compact8_unweighted_acceptor-fst.la
+lib/fst/compact8_unweighted_acceptor-fst.so
+lib/fst/compact8_unweighted_acceptor-fst.so.0
+lib/fst/compact8_weighted_string-fst.la
+lib/fst/compact8_weighted_string-fst.so
+lib/fst/compact8_weighted_string-fst.so.0
+lib/fst/const16-fst.la
+lib/fst/const16-fst.so
+lib/fst/const16-fst.so.0
+lib/fst/const64-fst.la
+lib/fst/const64-fst.so
+lib/fst/const64-fst.so.0
+lib/fst/const8-fst.la
+lib/fst/const8-fst.so
+lib/fst/const8-fst.so.0
+lib/fst/ilabel_lookahead-fst.la
+lib/fst/ilabel_lookahead-fst.so
+lib/fst/ilabel_lookahead-fst.so.0
+lib/fst/libfstcompact.la
+lib/fst/libfstcompact.so
+lib/fst/libfstcompact.so.1
+lib/fst/libfstconst.la
+lib/fst/libfstconst.so
+lib/fst/libfstconst.so.1
+lib/fst/libfstfar.la
+lib/fst/libfstfar.so
+lib/fst/libfstfar.so.1
+lib/fst/libfstfarscript.la
+lib/fst/libfstfarscript.so
+lib/fst/libfstfarscript.so.1
+lib/fst/libfstlookahead.la
+lib/fst/libfstlookahead.so
+lib/fst/libfstlookahead.so.0
+lib/fst/libfstpdtscript.la
+lib/fst/libfstpdtscript.so
+lib/fst/libfstpdtscript.so.1
+lib/fst/olabel_lookahead-fst.la
+lib/fst/olabel_lookahead-fst.so
+lib/fst/olabel_lookahead-fst.so.0
+lib/libfst.la
+lib/libfst.so
+lib/libfst.so.1
+lib/libfstscript.la
+lib/libfstscript.so
+lib/libfstscript.so.1
+share/licenses/openfst-1.3.4/AL2
+share/licenses/openfst-1.3.4/LICENSE
+share/licenses/openfst-1.3.4/catalog.mk
+@dirrm include/fst/script
+@dirrm include/fst/extensions/pdt
+@dirrm include/fst/extensions/far
+@dirrm include/fst/extensions
+@dirrm include/fst
+@dirrm lib/fst