aboutsummaryrefslogtreecommitdiff
path: root/math/openfst
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-10-03 06:52:41 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-10-03 06:52:41 +0000
commitdc9752c0bb1eed4c1b91d5da189ee9052e115013 (patch)
tree955e721cdf8da610f71af3e368910efc177e5f14 /math/openfst
parent34b715c504fdd8c2aaa4b75fa922500d37100d8f (diff)
downloadports-dc9752c0bb1eed4c1b91d5da189ee9052e115013.tar.gz
ports-dc9752c0bb1eed4c1b91d5da189ee9052e115013.zip
math/openfst: unbreak on 9.x
symbol-table-ops.cc: In function 'bool fst::AddAuxiliarySymbols(const string&, int64, int64, fst::SymbolTable*)': symbol-table-ops.cc:131:43: error: 'to_string' is not a member of 'std' if (index != syms->AddSymbol(prefix + std::to_string(i), index)) { ^ Reported by: pkg-fallout Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=423165
Diffstat (limited to 'math/openfst')
-rw-r--r--math/openfst/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/openfst/Makefile b/math/openfst/Makefile
index 1e14c1e7ef71..4869fd33156c 100644
--- a/math/openfst/Makefile
+++ b/math/openfst/Makefile
@@ -18,6 +18,7 @@ USES= compiler:c++11-lib libtool python:2
USE_LDCONFIG= ${LOCALBASE}/lib/fst
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-bin --enable-compact-fsts --enable-compress --enable-const-fsts --enable-far --enable-linear-fsts --enable-lookahead-fsts --enable-mpdt --enable-ngram-fsts --enable-pdt --enable-python
+CFLAGS+= -D_GLIBCXX_USE_C99 # XXX ports/193528
LDFLAGS+= "-L${LOCALBASE}/lib"
MAKE_ENV+= PYTHON=${PYTHON_CMD}