aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Algorithm-Combinatorics
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2005-11-06 14:50:02 +0000
committerAaron Dalton <aaron@FreeBSD.org>2005-11-06 14:50:02 +0000
commit0e72be37876cc6a135ddbaa540687293bc394cf8 (patch)
tree4cd478db42a5e8c152b7fe17fd11b5132fd85d50 /math/p5-Algorithm-Combinatorics
parent871ccaab532dd37647c782c84b18b0e31c7a99ed (diff)
downloadports-0e72be37876cc6a135ddbaa540687293bc394cf8.tar.gz
ports-0e72be37876cc6a135ddbaa540687293bc394cf8.zip
Add port math/p5-Algorithm-Combinatorics, efficient generation of combinatorial sequences
Approved by: tobez
Notes
Notes: svn path=/head/; revision=147444
Diffstat (limited to 'math/p5-Algorithm-Combinatorics')
-rw-r--r--math/p5-Algorithm-Combinatorics/Makefile32
-rw-r--r--math/p5-Algorithm-Combinatorics/distinfo2
-rw-r--r--math/p5-Algorithm-Combinatorics/pkg-descr13
-rw-r--r--math/p5-Algorithm-Combinatorics/pkg-plist8
4 files changed, 55 insertions, 0 deletions
diff --git a/math/p5-Algorithm-Combinatorics/Makefile b/math/p5-Algorithm-Combinatorics/Makefile
new file mode 100644
index 000000000000..56d85a56ab4b
--- /dev/null
+++ b/math/p5-Algorithm-Combinatorics/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Algorithm-Combinatorics
+# Date created: 05 Nov 2005
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-Combinatorics
+PORTVERSION= 0.08
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Efficient generation of combinatorial sequences
+
+BUILD_DEPENDS= ${SITE_PERL}/Inline/C.pm:${PORTSDIR}/devel/p5-Inline \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Algorithm::Combinatorics.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Algorithm-Combinatorics/distinfo b/math/p5-Algorithm-Combinatorics/distinfo
new file mode 100644
index 000000000000..fbf939b80d48
--- /dev/null
+++ b/math/p5-Algorithm-Combinatorics/distinfo
@@ -0,0 +1,2 @@
+MD5 (Algorithm-Combinatorics-0.08.tar.gz) = 4b6a961344283e88e6f6b000821f2fde
+SIZE (Algorithm-Combinatorics-0.08.tar.gz) = 8306
diff --git a/math/p5-Algorithm-Combinatorics/pkg-descr b/math/p5-Algorithm-Combinatorics/pkg-descr
new file mode 100644
index 000000000000..97f2894310ef
--- /dev/null
+++ b/math/p5-Algorithm-Combinatorics/pkg-descr
@@ -0,0 +1,13 @@
+Algorithm::Combinatorics is an efficient generator of combinatorial
+sequences, where efficient means:
+
+ * Speed: The core loops are written in C.
+ * Memory: No recursion and no stacks are used.
+
+Tuples are generated in lexicographic order.
+
+Author: Xavier Noria (FXN) <fxn@cpan.org>
+WWW: http://search.cpan.org/dist/Algorithm-Combinatorics/
+
+- Aaron Dalton
+aaron@FreeBSD.org
diff --git a/math/p5-Algorithm-Combinatorics/pkg-plist b/math/p5-Algorithm-Combinatorics/pkg-plist
new file mode 100644
index 000000000000..f755cfe9870e
--- /dev/null
+++ b/math/p5-Algorithm-Combinatorics/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Algorithm/Combinatorics.pm
+%%SITE_PERL%%/Algorithm/Combinatorics/C.pm
+%%SITE_PERL%%/Algorithm/Combinatorics/Iterator.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Combinatorics/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Combinatorics
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Algorithm/Combinatorics
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm 2>/dev/null || true