aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Algebra-Symbols/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 20:52:05 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 20:52:05 +0000
commit8eb1b90e83216060bd94863acd3234b1cc4f4af1 (patch)
tree05edb0379745f8c41b701bd23f7da95954b76fdf /math/p5-Math-Algebra-Symbols/Makefile
parentd3e597f06207fd6d2ea720a69befc96eddb9776d (diff)
downloadports-8eb1b90e83216060bd94863acd3234b1cc4f4af1.tar.gz
ports-8eb1b90e83216060bd94863acd3234b1cc4f4af1.zip
Adding port math/p5-Math-Algebra-Symbols, Symbolic Algebra in Pure Perl.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163417
Diffstat (limited to 'math/p5-Math-Algebra-Symbols/Makefile')
-rw-r--r--math/p5-Math-Algebra-Symbols/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/math/p5-Math-Algebra-Symbols/Makefile b/math/p5-Math-Algebra-Symbols/Makefile
new file mode 100644
index 000000000000..800df81c63bd
--- /dev/null
+++ b/math/p5-Math-Algebra-Symbols/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Math-Algebra-Symbols
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Algebra-Symbols
+PORTVERSION= 1.21
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Symbolic Algebra in Pure Perl
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Algebra::Symbols.3 \
+ Math::Algebra::Symbols::Sum.3 \
+ Math::Algebra::Symbols::Symbols.3 \
+ Math::Algebra::Symbols::Term.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= currently requires Perl 5.8. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>