aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-Cephes
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-27 02:29:37 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-27 02:29:37 +0000
commitaf601193d510433d7c57a6b483c1df1f68f5c408 (patch)
tree685413b9364fd674e7c6b71380304c8357170596 /math/p5-Math-Cephes
parent100457e3fe8801d6f7ab6fb9d6328bce80b22863 (diff)
downloadports-af601193d510433d7c57a6b483c1df1f68f5c408.tar.gz
ports-af601193d510433d7c57a6b483c1df1f68f5c408.zip
Adding port math/p5-Math-Cephes, a Perl interface to the Cephes math library.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163571
Diffstat (limited to 'math/p5-Math-Cephes')
-rw-r--r--math/p5-Math-Cephes/Makefile27
-rw-r--r--math/p5-Math-Cephes/distinfo2
-rw-r--r--math/p5-Math-Cephes/pkg-descr11
-rw-r--r--math/p5-Math-Cephes/pkg-plist16
4 files changed, 56 insertions, 0 deletions
diff --git a/math/p5-Math-Cephes/Makefile b/math/p5-Math-Cephes/Makefile
new file mode 100644
index 000000000000..98c33a5c836f
--- /dev/null
+++ b/math/p5-Math-Cephes/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Math-Cephes
+# Date created: 26 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Cephes
+PORTVERSION= 0.42
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl interface to the cephes math library
+
+MAN1= pmath.1
+MAN3= Math::Cephes.3 \
+ Math::Cephes::Complex.3 \
+ Math::Cephes::Fraction.3 \
+ Math::Cephes::Matrix.3 \
+ Math::Cephes::Polynomial.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Cephes/distinfo b/math/p5-Math-Cephes/distinfo
new file mode 100644
index 000000000000..badfd367591b
--- /dev/null
+++ b/math/p5-Math-Cephes/distinfo
@@ -0,0 +1,2 @@
+MD5 (Math-Cephes-0.42.tar.gz) = 5f0a9b1e83b55714110a31764b5ede34
+SIZE (Math-Cephes-0.42.tar.gz) = 300977
diff --git a/math/p5-Math-Cephes/pkg-descr b/math/p5-Math-Cephes/pkg-descr
new file mode 100644
index 000000000000..9f64c9bce12e
--- /dev/null
+++ b/math/p5-Math-Cephes/pkg-descr
@@ -0,0 +1,11 @@
+ This module provides an interface to over 150 functions of the
+ cephes math library of Stephen Moshier. No functions are exported
+ by default, but rather must be imported explicitly, as in
+
+ use Math::Cephes qw(sin cos);
+
+ There are a number of export tags defined which allow
+ importing groups of functions.
+
+WWW: http://search.cpan.org/dist/Math-Cephes
+Author: Randy Kobes
diff --git a/math/p5-Math-Cephes/pkg-plist b/math/p5-Math-Cephes/pkg-plist
new file mode 100644
index 000000000000..bba282e1fdad
--- /dev/null
+++ b/math/p5-Math-Cephes/pkg-plist
@@ -0,0 +1,16 @@
+bin/pmath
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Cephes.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Cephes.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Cephes/Complex.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Cephes/Fraction.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Cephes/Matrix.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Cephes/Polynomial.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Cephes/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Cephes/Cephes.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Cephes/Cephes.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Cephes/libmd/extralibs.ld
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Cephes/libmd
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Cephes
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math/Cephes
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math