aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-FFT
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-03-12 16:04:10 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-03-12 16:04:10 +0000
commit0fcbb68e15f08b7589b1168a2e12f2ac333c8ff2 (patch)
tree68a99061bfcf90f261535bfbc00af3d966501191 /math/p5-Math-FFT
parentab006702aec83efa747c38d6e7f630102607bea0 (diff)
downloadports-0fcbb68e15f08b7589b1168a2e12f2ac333c8ff2.tar.gz
ports-0fcbb68e15f08b7589b1168a2e12f2ac333c8ff2.zip
New port:
Perl module providing an interface to Fast Fourier Transform routines Initial import module version 0.25
Notes
Notes: svn path=/head/; revision=39660
Diffstat (limited to 'math/p5-Math-FFT')
-rw-r--r--math/p5-Math-FFT/Makefile22
-rw-r--r--math/p5-Math-FFT/distinfo1
-rw-r--r--math/p5-Math-FFT/pkg-comment1
-rw-r--r--math/p5-Math-FFT/pkg-descr22
-rw-r--r--math/p5-Math-FFT/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/math/p5-Math-FFT/Makefile b/math/p5-Math-FFT/Makefile
new file mode 100644
index 000000000000..05e72d589c2b
--- /dev/null
+++ b/math/p5-Math-FFT/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Math-FFT
+# Date created: 12 Mar 2001
+# Whom: Mario S F Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-FFT
+PORTVERSION= 0.25
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lioux@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::FFT.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-FFT/distinfo b/math/p5-Math-FFT/distinfo
new file mode 100644
index 000000000000..81bc9f255b70
--- /dev/null
+++ b/math/p5-Math-FFT/distinfo
@@ -0,0 +1 @@
+MD5 (Math-FFT-0.25.tar.gz) = c44ab37a4d21ffa57ea49c01801106fe
diff --git a/math/p5-Math-FFT/pkg-comment b/math/p5-Math-FFT/pkg-comment
new file mode 100644
index 000000000000..b97fad29e4f3
--- /dev/null
+++ b/math/p5-Math-FFT/pkg-comment
@@ -0,0 +1 @@
+Perl module providing an interface to Fast Fourier Transform routines
diff --git a/math/p5-Math-FFT/pkg-descr b/math/p5-Math-FFT/pkg-descr
new file mode 100644
index 000000000000..89af48b762d2
--- /dev/null
+++ b/math/p5-Math-FFT/pkg-descr
@@ -0,0 +1,22 @@
+The Math::FFT module provides an interface to various Fast Fourier
+Transform (FFT) routines of the C routine of fft4g.c; The one-dimensional
+data sets, of size 2^n, are assumed to be sampled at a constant
+rate.
+
+The FFT methods available are
+- cdft: Complex Discrete Fourier Transform
+- rdft: Real Discrete Fourier Transform
+- ddct: Discrete Cosine Transform
+- ddst: Discrete Sine Transform
+- dfct: Cosine Transform of RDFT (Real Symmetric DFT)
+- dfst: Sine Transform of RDFT (Real Symmetric DFT)
+as well as their inverses.
+
+The C code for the FFT routines of fft4g.c is copyrighted 1996-99
+by Takuya OOURA. The file arrays.c included here to handle passing
+arrays to and from C comes from the PGPLOT module of Karl Glazebrook
+<kgb@aaoepp.aao.gov.au>. The perl interface of the Math::FTT module
+is Copyright 2000 by Randy Kobes <randy@theoryx5.uwinnipeg.ca>,
+and may be distributed under the same terms as Perl itself.
+
+WWW: http://momonga.t.u-tokyo.ac.jp/~ooura/fft.html.
diff --git a/math/p5-Math-FFT/pkg-plist b/math/p5-Math-FFT/pkg-plist
new file mode 100644
index 000000000000..b2e51d8d0226
--- /dev/null
+++ b/math/p5-Math-FFT/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/FFT/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/FFT/FFT.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/FFT/FFT.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/FFT.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/FFT
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math